Go Back   Steam Users' Forums > Steam Game Discussions > T - Z > Waveform

Reply
 
Thread Tools Display Modes
Old 04-17-2012, 05:22 PM   #1
m.harmless
 
Join Date: May 2011
Reputation: 9
Posts: 237
Unhappy Game stopped saving data

I've read about the problems other people had with missing profile data, which have been reported to be fixed with the latest update. Steam updated my game today but I still have the following issue:

I haven't played Waveform for a couple of days, but the last time I did everything worked just fine. Just now I decided to play through one level (Uranus 4) and after I completed it, the game didn't save the completion of said level (it still showed 0% and wouldn't let me play the next level)

I then tested this some more and it seems that nothing at all is saved anymore. E.g. when I create a new profile and quit the game the profile is gone. When I play with my existing profile no new data is saved.

I have steam cloud turned off both in the steam settings menu and in the game's properties menu. I suspect that this is part of the problem. There was a similar issue with Space Marine on launch where the game couldn't save some data when steam cloud was turned of globally in the steam settings. I'm assuming this could be a similar issue and hope it can be fixed.

Does anyone have the same problem after the last update?
m.harmless is offline  
Reply With Quote
Old 04-17-2012, 05:39 PM   #2
metz10
 
Join Date: Dec 2011
Reputation: 15
Posts: 120
Wow, I literally just spent about ten/fifteen minutes sending a message to Ryan about this problem.

The only thing that seems to be saving is leaderboard scores. Anything else does not save at all.

Have faith though, I imagine it will be fixed shortly.
metz10 is offline   Reply With Quote
Old 04-17-2012, 06:26 PM   #3
EdenIndustries
 
Join Date: Mar 2012
Reputation: 25
Posts: 427
Sorry about that guys, I'll have it fixed by tomorrow. Thanks for your patience, and sorry about the problem.
EdenIndustries is offline   Reply With Quote
Old 04-17-2012, 06:58 PM   #4
m.harmless
 
Join Date: May 2011
Reputation: 9
Posts: 237
Quote:
Originally Posted by EdenIndustries View Post
Sorry about that guys, I'll have it fixed by tomorrow. Thanks for your patience, and sorry about the problem.
Thanks a lot. Good to know the problem is being worked on.
m.harmless is offline   Reply With Quote
Old 04-17-2012, 08:11 PM   #5
EdenIndustries
 
Join Date: Mar 2012
Reputation: 25
Posts: 427
Ok I have the fix completed locally, and it'll be ready in a new update I'll send to Valve tomorrow.

In case you're curious about why this started happening, I recently switching the game from ascii to unicode encoding of text in order to support international languages. This means that instead of using 1 byte to store each letter, it uses 2 in order to support the many different letters and characters found in the various languages around the world. Well sure enough Windows has a very particular way it likes to handle filenames when you use unicode instead of ascii, which is why trying to retrieve or write to save data stored on the Windows file system (as opposed to the Steam Cloud) ran into a problem after making this change.

In case the technical description bored you (I can't blame you ) all you need to know is that things should be working better starting tomorrow!
EdenIndustries is offline   Reply With Quote
Old 04-18-2012, 02:01 AM   #6
EdenIndustries
 
Join Date: Mar 2012
Reputation: 25
Posts: 427
Ok I've sent the build off to Valve. When it goes live later today this should be fixed. I tried creating and deleting a profile, in addition to playing levels and the Deep Space modes, and that all worked. I think that should just about do it, but of course let me know in case I've forgot anything. Only so much one guy can cover

Thanks!
EdenIndustries is offline   Reply With Quote
Old 04-18-2012, 04:21 AM   #7
jeffers160
 
 
 
Join Date: Apr 2012
Reputation: 0
Posts: 1
Quote:
Originally Posted by EdenIndustries View Post
Ok I've sent the build off to Valve. When it goes live later today this should be fixed. I tried creating and deleting a profile, in addition to playing levels and the Deep Space modes, and that all worked. I think that should just about do it, but of course let me know in case I've forgot anything. Only so much one guy can cover

Thanks!
I must say that the support from EdenIndustries is fantastic, especially when it comes to fixing little bugs and errors =). The game is brilliant too!
jeffers160 is offline   Reply With Quote
Old 04-18-2012, 09:56 AM   #8
EdenIndustries
 
Join Date: Mar 2012
Reputation: 25
Posts: 427
Quote:
I must say that the support from EdenIndustries is fantastic, especially when it comes to fixing little bugs and errors =)
Thanks! I'm just trying to do what I'd hope developers would do when the shoe is on the other foot and I'm the customer

Quote:
The game is brilliant too!
Glad to hear it!

Also the new update is live, so this issue should be fixed. But like always, just let me know if you notice anything not behaving correctly.
EdenIndustries is offline   Reply With Quote
Old 04-18-2012, 01:56 PM   #9
m.harmless
 
Join Date: May 2011
Reputation: 9
Posts: 237
Thumbs up

Quote:
Originally Posted by EdenIndustries View Post
Also the new update is live, so this issue should be fixed. But like always, just let me know if you notice anything not behaving correctly.
I just tested the new updated version of the game on my system and now everything seems to work fine. I could create a new profile and the old profile also got updated after playing.

Thanks a lot for the great support of an awesome game!
m.harmless is offline   Reply With Quote
Old 06-29-2015, 08:52 AM   #10
pijawa2000
 
 
 
Join Date: Jun 2015
Reputation: 0
Posts: 1
Sorry for digging out this post, but I just bought Waveform, and I'm getting the same bug as you. :/
pijawa2000 is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > T - Z > Waveform


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 01:57 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2015, All Rights Reserved.