Go Back   Steam Users' Forums > Steam Game Discussions > T - Z > Team Fortress 2

Reply
 
Thread Tools Display Modes
Old 03-14-2017, 10:03 PM   #1
Terobero
 
 
 
Join Date: Dec 2015
Reputation: 12
Posts: 159
Why most of the custom servers missing underwater texture?

Is it only me where you go underwater in a custom server and you get the pink & black missing stuff color?
Terobero is offline  
Reply With Quote
Old 03-14-2017, 10:23 PM   #2
aabicus
 
 
 
Join Date: Aug 2011
Reputation: 7062
Posts: 16,522
Could you post a screenshot? As someone who doesn't suffer from that, it sounds cool to see
aabicus is offline   Reply With Quote
Old 03-14-2017, 10:36 PM   #3
Thurbo
 
Join Date: Aug 2010
Reputation: 2363
Posts: 5,843
When I got this error it's always been one of two things. Can you see underwater while spectating? In that case, turning HDR on or off usually works although I'm not sure why that is.

If not, the map files may not have been downloaded fully. Try deleting the map and redownload it or better yet, download it from a website that advertises it.


Quote:
Originally Posted by aabicus View Post
Could you post a screenshot? As someone who doesn't suffer from that, it sounds cool to see
There's not much to see. When you're underwater your hud is still visible but other than that your entire screen is just a checkerboard.

In fact, it's so common that I found this within a second of Google searching
Thurbo is offline   Reply With Quote
Old 03-14-2017, 10:42 PM   #4
Terobero
 
 
 
Join Date: Dec 2015
Reputation: 12
Posts: 159
Quote:
Originally Posted by aabicus View Post
Could you post a screenshot? As someone who doesn't suffer from that, it sounds cool to see
Your screen literally becomes that pink & black picture, the whole screen.
Terobero is offline   Reply With Quote
Old 03-15-2017, 07:06 PM   #5
N01
 
 
 
Join Date: Oct 2012
Reputation: 804
Posts: 1,060
1) verify integrity of your game cache. For some odd reason, some of the underwater overlays seems to be incredibly common to corrupt or lose, likely because they are not too commonly used. They are also the most conspicuous when they go bad. One thing you can do is try jumping in the brown water under 2fort, and then try the same thing with well. Regardless, 9/10 times verifying the cache is going to fix it.

2) It may be that the custom map was made poorly or used custom textures that maybe downloaded incorrectly. some water textures are meant for skyboxes. I don't believe they should actually cause errors like that, but they aren't exactly intended to be used in the map proper. It's also possible that the water was implemented incorrectly-the proper way to create it is to apply water texture to the top and nodraw to the bottom and sides, excepting abnormal mapping situations.

point is, the second part is mostly irrelevant. just check the cache.
N01 is offline   Reply With Quote
Old 03-16-2017, 01:44 AM   #6
Distraction
 
 
 
Join Date: May 2011
Reputation: 389
Posts: 1,540
Workshop also breaks lots of things compressed into custom maps. Especially sounds, which freeze the game momentarily for the first time a client hears them.
Distraction is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > T - Z > Team Fortress 2


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 08:45 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2015, All Rights Reserved.