Go Back   Steam Users' Forums > Steam Game Discussions > Q - S > Steel Storm: Burning Retribution

Reply
 
Thread Tools Display Modes
Old 12-28-2012, 04:14 PM   #1
Marcx
 
 
 
Join Date: Aug 2010
Reputation: 16
Posts: 132
Game sloooow - Windows 8

The title describe my problem pretty well...
I had no problem playing it using windows 7 64bit, now using the same notebook but with windows 8 64bit the game is slooow, also in the main menu everything runs laggy...

I have video/audio driver up to date...
I already tried to delete the config.cfg in mygames folder..

My notebook
Dell studio 1555
Core2Duo p8600 2.4GHZ
4GB RAM dual channel
ati mobility hd 4500


any advice???
Marcx is offline  
Reply With Quote
Old 12-28-2012, 10:12 PM   #2
motorsep
 
Kot-in-Action
Join Date: Oct 2010
Reputation: 67
Posts: 391
One thing is that Windows 8 just came out, and I don't have (afaik neither does engine author) Win 8. So technically Win 8 is not supported currently.

Can you try running the game in Win7 / WinXP compatibility mode?

Also, can you check console for any suspicious messages? (if you can type "condump win8_slowness.txt" in the console, without "", and then pastebin that txt file, that would let me see what goes on, if anything)

EDIT: I went to AMD website and searched for your drivers. There is none for Windows 8. I also went to Dell website. No Win 8 drivers for your notebook either. That being said, it seems that your mobility GPU is no longer supported by the hardware manufacturers. There is nothing I can do about making the game run faster if there are no appropriate video drivers. The only thing I can recommend is to go back to Windows 7.

Last edited by motorsep: 12-28-2012 at 10:34 PM.
motorsep is offline   Reply With Quote
Old 12-29-2012, 03:42 AM   #3
Marcx
 
 
 
Join Date: Aug 2010
Reputation: 16
Posts: 132
Hi,
first let me thank you for yor reply...
secondly I do donwload the driver automatically using che amd/ati video card installer and I do play very well a lots of games...
Skyrim / XCOM / CIV V / CS:GO and many others runs with no problems and sometimes with better performance then when I used windows 7...
Actually afaik that's the only games that give me problem...
Then I can imagine that you need to fix/change something to let it run properly and that you're not a big SH, so no problem and I will gladly help you to fix the problems...


here's the condump, hope it can helps..
http://pastebin.com/zx5CAap5
Marcx is offline   Reply With Quote
Old 12-29-2012, 11:26 AM   #4
motorsep
 
Kot-in-Action
Join Date: Oct 2010
Reputation: 67
Posts: 391
GL_VENDOR: Microsoft Corporation
^7GL_RENDERER: GDI Generic
^7GL_VERSION: 1.1.0
^7GL_EXTENSIONS: GL_WIN_swap_hint GL_EXT_bgra GL_EXT_paletted_texture
^7SDL_EXTENSIONS:
^7checking for glbase... enabled
^7checking for OpenGL 2.0 core features... not detected (OpenGL 1.1 loaded)
^7Checking OpenGL extensions...
^7checking for GL_AMD_texture_texture4... not detected
^7checking for GL_ARB_depth_texture... not detected
^7checking for GL_ARB_draw_buffers... not detected
^7checking for GL_ARB_multitexture... not detected
^7checking for GL_ARB_occlusion_query... not detected
^7checking for GL_ARB_shadow... not detected
^7checking for GL_ARB_texture_compression... not detected
^7checking for GL_ARB_texture_cube_map... not detected
^7checking for GL_ARB_texture_env_combine... not detected
^7checking for GL_EXT_texture_env_combine... not detected
^7checking for GL_ARB_texture_gather... not detected
^7checking for GL_ARB_texture_non_power_of_two... not detected
^7checking for GL_ARB_vertex_buffer_object... not detected
^7checking for separatestencil... checking for GL_ATI_separate_stencil... not detected
^7checking for GL_EXT_blend_minmax... not detected
^7checking for GL_EXT_blend_subtract... not detected
^7checking for drawrangeelements... checking for GL_EXT_draw_range_elements... not detected
^7checking for GL_ARB_framebuffer_object... not detected
^7checking for GL_EXT_framebuffer_object... not detected
^7checking for GL_EXT_packed_depth_stencil... not detected
^7checking for GL_EXT_stencil_two_side... not detected
^7checking for GL_EXT_texture3D... not detected
^7checking for GL_EXT_texture_compression_s3tc... not detected
^7checking for GL_EXT_texture_edge_clamp... not detected
^7checking for GL_SGIS_texture_edge_clamp... not detected
^7checking for GL_EXT_texture_filter_anisotropic... not detected
^7checking for GL_EXT_texture_sRGB... not detected
^7checking for GL_ARB_multisample... not detected
^7Using GL1.1 rendering path - 1 texture units, two pass rendering

You see this? That means there is no ATI/AMD driver is being used. Thus you get oldest OpenGL rendering (and I assume it's software emulation, although I might be wrong). It also tells me that whatever automatic download you get are simply not there (no vendor driver is being downloaded).

The games you mentioned run using DirectX (D3D9/10) and since that's Microsoft's API Windows 8 using hardware acceleration to render those. That's why you get good performance in D3D games and poor performance in OpenGL games (Steel Storm is OpenGL only).

So there is no immediate fix for this issue. Let's hope somehow HD4500 will get OpenGL drivers for Win8 (most likely it will not happen). Or you can install Ubuntu and maybe open source driver will do better job

Sorry about that, it's just unfortunate circumstances where Microsoft fails users yet again
motorsep is offline   Reply With Quote
Old 12-29-2012, 12:13 PM   #5
Marcx
 
 
 
Join Date: Aug 2010
Reputation: 16
Posts: 132
Thank you motorsep...
your help was really really useful to find the problem...
I actually did a simple research on google and found a legacy win8 driver, installed it and the games works fine...

here's the link:
http://benchmark3d.com/amd-catalyst-...gacy-windows-8

I although had to downgrade from 12-10 to 12-6....
thank you again..
Marcx is offline   Reply With Quote
Old 12-29-2012, 12:15 PM   #6
motorsep
 
Kot-in-Action
Join Date: Oct 2010
Reputation: 67
Posts: 391
Not a problem! Always glad to help when I can

Good to hear you solved the issue!
motorsep is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > Q - S > Steel Storm: Burning Retribution


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 01:02 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2015, All Rights Reserved.