Go Back   Steam Users' Forums > Steam Game Discussions > Q - S > Star Wars collection > Jedi Knight: Dark Forces II

Reply
 
Thread Tools Display Modes
Old 07-16-2012, 08:17 AM   #1
critbot
 
Join Date: Feb 2012
Reputation: 4
Posts: 20
Animations running way too fast (gun sway etc)

So the game actually looked like it was playing fine. However soon as i walk the gun sway animation is going like 100 times faster than it should be and its just far too distracting and i was hoping to experience this classic as close to how it should be as possible. The game itself doesn't seem to be running too quickly (if anything it seems the enemys fall a bit slowly but it could be my imagination) just the gun/hand animations. My pc is windows 7 x64, has an i3 2100 processor and gtx 550 graphics card. Did anyone run into this problem and find a fix? Anyone help would be very much appreciated.

Last edited by critbot: 07-16-2012 at 08:24 AM.
critbot is offline  
Reply With Quote
Old 07-16-2012, 04:51 PM   #2
critbot
 
Join Date: Feb 2012
Reputation: 4
Posts: 20
Sorry for double post, just had a random development. Out of nowhere the game seemed to run at the normal speed under the same settings it didn't previously, unfortunately it lasted all of 1 minute 30 before the game froze and made a horrible buzzing noise, couldnt close it down and had to shut it off by the power button. This game is lucky its worth the effort, i do hope it pays off i love this game :P.

Last post on this topic. Sorry i cannot be of more help but i only saw one person with the same problem as me. I unfortunately cannot pinpoint a fix for the speed issue, i honestly started it under the same settings it run too fast on previously and its fine all of a sudden. The random crashing seems to have been fixed by the 3d acceleration fix of http://www.jkhub.net/. I haven't progressed far but it certainly got me much further through the level without crashing after adding the dll. Sorry again for the wasted thread i just thought would conclude what happened in case anyone ran into similer problems.

Last edited by critbot: 07-16-2012 at 07:24 PM.
critbot is offline   Reply With Quote
Old 05-13-2013, 12:30 AM   #3
DracoCW
 
Join Date: Aug 2011
Reputation: 6
Posts: 5
If anyone else has this problem, I have found a solution (at least for me). If the weapons sway is to fast and shooting and changing your weapons seems to be glitchy, just force vsync in your video adapter drivers in Windows for JK.exe. This way you limit the fps and the gun sway etc. should no longer be to fast/glitchy.
DracoCW is offline   Reply With Quote
Old 05-12-2014, 11:43 PM   #4
MrRip
 
Join Date: May 2008
Reputation: 0
Posts: 16
Quote:
Originally Posted by DracoCW View Post
If anyone else has this problem, I have found a solution (at least for me). If the weapons sway is to fast and shooting and changing your weapons seems to be glitchy, just force vsync in your video adapter drivers in Windows for JK.exe. This way you limit the fps and the gun sway etc. should no longer be to fast/glitchy.
This just worked for me. Thank you very much.
MrRip is offline   Reply With Quote
Old 09-30-2015, 09:35 PM   #5
nillabomb
 
 
 
Join Date: Mar 2015
Reputation: 0
Posts: 1
I have this problem as well. I start the program in windows xp service pack 3 compatibility mode. I tried the vsync via nvidia control panel (I have a gtx 285 card) but it didn't make a difference
nillabomb is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > Q - S > Star Wars collection > Jedi Knight: Dark Forces II


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 04:31 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2015, All Rights Reserved.