Go Back   Steam Users' Forums > Steam Discussions > Help and Tips

Reply
 
Thread Tools Display Modes
Old 10-29-2009, 10:18 AM   #1
Yedanker
 
 
 
Join Date: Oct 2009
Reputation: 0
Posts: 116
Angry Stuck on 99% Updating Steam Platform

I attempted to download the Steam client update this morning so I could play L4D2, it got stuck 3kb away from finishing every time so I decided to re-install Steam, Now, I can't even launch Steam, it tries to Update the Steam Platform and gets stuck on 99%, If you could help it would be great... I have re-installed it over and over and still no luck, I have tried running it in compatibility mode/admin and nothing works.

I'm running Windows 7 - 32 Bit
Thanks in advance.
Yedanker is offline  
Reply With Quote
Old 10-29-2009, 11:34 AM   #2
Yedanker
 
 
 
Join Date: Oct 2009
Reputation: 0
Posts: 116
Bump because I really need help
Yedanker is offline   Reply With Quote
Old 10-29-2009, 01:14 PM   #3
TehRedfield
 
Guest
Posts: n/a
having this too, Error about something called Blob header or we.
Deleted steam, Reinstalling stuck on 84%
  Reply With Quote
Old 10-29-2009, 01:21 PM   #4
splatdeath
 
Join Date: Oct 2009
Reputation: 0
Posts: 5
i have similar problem, done the usual stuff liek rename clientreg, that didnt work, so uninstaleld steam re-installed and now stuck at connecting to account....

I can only assume its something to do with the update...

Anyone have any other tricks to try?
splatdeath is offline   Reply With Quote
Old 10-29-2009, 01:42 PM   #5
wishoblivion
 
Guest
Posts: n/a
I hope they get this patched. I've found nothing useful on this topic.. nothing has worked for me. Yeah I have the problem too... Ugh this sucks..
  Reply With Quote
Old 10-30-2009, 10:15 AM   #6
Yedanker
 
 
 
Join Date: Oct 2009
Reputation: 0
Posts: 116
I finally managed to get onto Steam by getting my brother to copy his Steam contents other than the steamapps folder and it worked!
Sadly though, my L4D2 still asks for the client update and it gets to 12.56 / 12.59 as always
Anyone know how to fix this bug where it gets stuck 3kb away from finishing the Steam client update needed for L4D2?
Yedanker is offline   Reply With Quote
Old 10-31-2009, 03:02 AM   #7
Yedanker
 
 
 
Join Date: Oct 2009
Reputation: 0
Posts: 116
Oh my god! I'm downloading the demo! FINALLY!
I just shutdown my Zonealarm while updating and it worked! I'm so happy it worked!
Yedanker is offline   Reply With Quote
Old 11-07-2009, 09:28 AM   #8
marekfreak1
 
Join Date: May 2009
Reputation: 31
Posts: 458
Yip, a friend has (i.e. had) issues installing Steam on Windows 7 with the ZoneAlarm firewall. For some reason, ZA did not prompt/recognize the signature to allow the steam msi file to run. Turning off ZA briefly, running the Steam install, then turning ZA firewall back on again worked. ZA recognized Steam only once it was installed and no issues since then.

This is the only problem I have with ZA. Some games/progs setups dont work until I disable ZA for a brief moment.

Otherwise Steam is running flawlessly on his Windows 7 system and so is L4D. I'm upgrading to Win 7 Pro 64 Bit soon, but just waiting to resolve some issues with the whole Dual Boot mess, since I have 2 various OS running on 4 separate hard-drives and I want to install Win 7 on a its own dedicated hard drive.

Last edited by marekfreak1: 11-07-2009 at 09:32 AM.
marekfreak1 is offline   Reply With Quote
Old 02-28-2010, 07:30 PM   #9
DoctorFuji
 
Join Date: Feb 2010
Reputation: 0
Posts: 4
Thumbs up Have you tried closing your firewall program?

In the past, I closed any firewall programs before starting Steam. I just installed Windows 7 and was reinstalling my Half Life 2, etc and having the Steam update stall at 99%. However, I tried it again after shutting down my firewall program, Zone Alarm (even though I had given Steam permissions). Once I did that, Steam started up with no problems. Just remember to restart your firewall after you close Steam.

Yikes.. I did not read through all the posts. I see that ZA is mentioned as a culprit in the two posts before mine.
DoctorFuji is offline   Reply With Quote
Old 03-10-2010, 11:36 AM   #10
Mr-Sticks
 
Guest
Posts: n/a
Yes, disabling ZA (and windows firewall) Allowed me to get steam to work on Win 7

If it doesnt work, you're screwed
  Reply With Quote
Old 03-29-2010, 01:44 PM   #11
jimmyt1988
 
Join Date: Dec 2008
Reputation: 0
Posts: 6
Steam updating stuck on 99% or 26-27%: SOLUTION

I found the solution to our steam problem.

Windows 7 / Vista solution

1: Load up Steam, wait till it's stuck on 99%.
2: Press "Start" button, type "msconfig" into the search bar and press enter.
3: Under the "Boot" tab where the "Boot options" are, tick "Safe boot" then tick "Network".
4: Restart your computer and allow it to load up in safe mode.
5: Everything will most likely look big and ugly.
6: Load up Steam, once it completes the update, log in.
7: Press "Start" button, type "msconfig" into the search bar and press enter.
8: Under the "Boot" tab where the "Boot options" are, un-tick "Safe boot".
9: Restart in to normal Windows.
10: Run Steam successfully.
jimmyt1988 is offline   Reply With Quote
Old 04-03-2010, 05:36 PM   #12
narayandude
 
Guest
Posts: n/a
I had the same problem. I deactivated zone alarm and it worked. Win7 64bit
  Reply With Quote
Old 04-04-2010, 05:17 AM   #13
sambob
 
Join Date: Feb 2010
Reputation: 118
Posts: 767
Quote:
Originally Posted by Mr-Sticks View Post
Yes, disabling ZA (and windows firewall) Allowed me to get steam to work on Win 7

If it doesnt work, you're screwed
Having more than one firewall is not a good idea.
sambob is offline   Reply With Quote
Old 04-04-2010, 05:19 AM   #14
7265PDFJ4691
 
Banned
Join Date: Apr 2009
Reputation: 0
Posts: 6
Guys, just NEVER use ZoneAlarm I'm BEGGING you!
7265PDFJ4691 is offline   Reply With Quote
Old 04-14-2010, 09:34 PM   #15
Killshot
 
Guest
Posts: n/a
Quote:
Originally Posted by khrylle View Post
Guys, just NEVER use ZoneAlarm I'm BEGGING you!
which firewall would you suggest then?
  Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Discussions > Help and Tips


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 11:24 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.