Go Back   Steam Users' Forums > Steam Discussions > Help and Tips

Reply
 
Thread Tools Display Modes
Old 11-10-2009, 09:59 PM   #1
Tig3r
 
Guest
Posts: n/a
A general game problem. PLEASE HELP!

I know i posted in earlier thread about a computer problem a couple days ago, but i now realize what my problem is.

So i recently downloaded the L4D2 Demo to test out my new beast of a computer, but it was short-lived as my computer decided to stop sending signal to my monitor (A Vision MW22E BAD in case you're wondering) and i have to hold the power button to get it to work again.

First, my specs.
AMD Phenom II X4 945
8GB DDR2 RAM
Windows 7 Home Premium 64-bit
NVidia GeForce 250
1TB SATA-II 3.0Gb/s 7200RPM HDD

Second, what I've tried.
I have updated ALL my drivers for the necessary things and all the necessary updates from Microsoft.
I first played it on Very High, but it shut down right as it finished loaded.
Then i played it on everything low, with everything off, and i played for about 20-30 seconds then it shut down on me again, which is frustrating because i don't want any issues when I purchase TF2 because i can't wait to finally get to play it. (I first played it on Xbox and hated it with a passion.)
And this happens with any games i play, not just this one.

Any help would be much appreciated!!
 
Reply With Quote
Old 11-11-2009, 05:15 AM   #2
wardenofdeath95
 
Banned
Join Date: Jul 2009
Reputation: 20
Posts: 192
holy 8gb ram
wardenofdeath95 is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Discussions > Help and Tips


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 12:19 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.