Go Back   Steam Users' Forums > Steam Game Discussions > M - P > Mass Effect series

Reply
 
Thread Tools Display Modes
Old 09-07-2011, 05:31 PM   #16
BlackD
 
Join Date: Aug 2011
Reputation: 0
Posts: 4
It appears the Steam version of Mass Effect doesn't update to the latest patch version which corrects launch issues.

http://files.bioware.com/masseffect/...EFIGS_1.02.exe

Download and run the update. It will ask if you want to update your game version, and once it's completed, Mass Effect should launch fine from Steam, without having to use any compatiablility or admin tricks.

+BlackD
BlackD is offline   Reply With Quote
Old 12-24-2011, 07:27 AM   #17
ecode
 
Banned
Join Date: Oct 2011
Reputation: 0
Posts: 10
Alright, if anyone is still having the same problem, here's the fix:
Go to your Steam folder located at Program files. From there you want to go to steamapps --> common --> mass effect. Now that you're here, right click Luancher.exe --> Properties --> compatibility and Run it as administrator and XP SP2. Do the same for MassEffectLauncher.exe. Now you go to Binaries which is located at the same folder as the previous .exe's (Program Files --> Steam --> steamapps --> common --> mass effect). And while you're there you must do the same thing for the exe files as you did for exe files in your mass effect folder.
Now it should work properly.

If this didn't work or you didn't understand something, please PM me and I'll try to help you.
ecode is offline   Reply With Quote
Old 12-24-2011, 09:45 AM   #18
KaijuFan
 
 
 
Join Date: Jul 2011
Reputation: 0
Posts: 5
Quote:
Originally Posted by ecode View Post
Alright, if anyone is still having the same problem, here's the fix:
Go to your Steam folder located at Program files. From there you want to go to steamapps --> common --> mass effect. Now that you're here, right click Luancher.exe --> Properties --> compatibility and Run it as administrator and XP SP2. Do the same for MassEffectLauncher.exe. Now you go to Binaries which is located at the same folder as the previous .exe's (Program Files --> Steam --> steamapps --> common --> mass effect). And while you're there you must do the same thing for the exe files as you did for exe files in your mass effect folder.
Now it should work properly.
This fixed all my issues, thank you so much for posting!
KaijuFan is offline   Reply With Quote
Old 12-24-2011, 11:56 AM   #19
ecode
 
Banned
Join Date: Oct 2011
Reputation: 0
Posts: 10
No problem, glad to help.
ecode is offline   Reply With Quote
Old 12-24-2011, 05:11 PM   #20
Atech66
 
Join Date: Oct 2011
Reputation: 77
Posts: 673
Same OS and i have'nt had any problems at all.. I never changed any launch options, compatability or admin on any of my steam games.. i better knock on wood.
Atech66 is offline   Reply With Quote
Old 12-24-2011, 05:21 PM   #21
ecode
 
Banned
Join Date: Oct 2011
Reputation: 0
Posts: 10
Something else than OS might cause this problem. Seen people with vista and win7 who've had this same issue. And I had this same issue and I'm a vista user.
ecode is offline   Reply With Quote
Old 12-27-2011, 11:23 PM   #22
LunaGeme
 
Join Date: Dec 2011
Reputation: 0
Posts: 1
Quote:
Originally Posted by ecode View Post
Alright, if anyone is still having the same problem, here's the fix:
Go to your Steam folder located at Program files. From there you want to go to steamapps --> common --> mass effect. Now that you're here, right click Luancher.exe --> Properties --> compatibility and Run it as administrator and XP SP2. Do the same for MassEffectLauncher.exe. Now you go to Binaries which is located at the same folder as the previous .exe's (Program Files --> Steam --> steamapps --> common --> mass effect). And while you're there you must do the same thing for the exe files as you did for exe files in your mass effect folder.
Now it should work properly.

If this didn't work or you didn't understand something, please PM me and I'll try to help you.
I just adquire the game and have the problem, this solution work for me, thanks
LunaGeme is offline   Reply With Quote
Old 01-05-2012, 10:42 AM   #23
rabidturky6759
 
Join Date: Jan 2012
Reputation: 0
Posts: 14
Quote:
Originally Posted by ecode View Post
Alright, if anyone is still having the same problem, here's the fix:
Go to your Steam folder located at Program files. From there you want to go to steamapps --> common --> mass effect. Now that you're here, right click Luancher.exe --> Properties --> compatibility and Run it as administrator and XP SP2. Do the same for MassEffectLauncher.exe. Now you go to Binaries which is located at the same folder as the previous .exe's (Program Files --> Steam --> steamapps --> common --> mass effect). And while you're there you must do the same thing for the exe files as you did for exe files in your mass effect folder.
Now it should work properly.

If this didn't work or you didn't understand something, please PM me and I'll try to help you.
thanks man it totally works now
rabidturky6759 is offline   Reply With Quote
Old 04-15-2012, 07:28 AM   #24
aristides
 
Join Date: Mar 2011
Reputation: 0
Posts: 1
Quote:
Originally Posted by ecode View Post
Alright, if anyone is still having the same problem, here's the fix:
Go to your Steam folder located at Program files. From there you want to go to steamapps --> common --> mass effect. Now that you're here, right click Luancher.exe --> Properties --> compatibility and Run it as administrator and XP SP2. Do the same for MassEffectLauncher.exe. Now you go to Binaries which is located at the same folder as the previous .exe's (Program Files --> Steam --> steamapps --> common --> mass effect). And while you're there you must do the same thing for the exe files as you did for exe files in your mass effect folder.
Now it should work properly.

If this didn't work or you didn't understand something, please PM me and I'll try to help you.
Doesn't work for me. But game runs perfectly in windowed mode.
aristides is offline   Reply With Quote
Old 09-01-2012, 02:54 PM   #25
Phugalu
 
Join Date: Feb 2011
Reputation: 0
Posts: 8
I had the problem where ME didn't launch in Vista 64.
Seems that it has problems running in Vista.
Here is what helped me:

1) in /program files/Mass Effect/Binaries locate the OpenAL32.dll and wrap_oal.dll files

2) Rename OpenAL32.dll to OpenAL32.bak

3) Rename wrap_oal.dll to OpenAL32.dll

4) Launch as Admin by using the MassEffect.exe

Works fine after that!
Phugalu is offline   Reply With Quote
Old 07-23-2013, 09:23 AM   #26
Lodestar
 
Join Date: Jul 2012
Reputation: 0
Posts: 2
Quote:
Originally Posted by BlackD View Post
It appears the Steam version of Mass Effect doesn't update to the latest patch version which corrects launch issues.

http://files.bioware.com/masseffect/...EFIGS_1.02.exe

Download and run the update. It will ask if you want to update your game version, and once it's completed, Mass Effect should launch fine from Steam, without having to use any compatiablility or admin tricks.

+BlackD
I just did this and was told, it did not install properly use appropriate method for this version of windows or some such. No idea what it is talking about, but have I just patched my game and jaffed it up, requiring a fresh install by this?
Lodestar is offline   Reply With Quote
Old 09-05-2013, 03:40 PM   #27
blueblaze23
 
Join Date: May 2006
Reputation: 0
Posts: 20
Thumbs up Here's what worked for me

Just wanted to mention, this is something unique to 64-bit versions of Windows. The DirectX installer that automatically triggers with the first launch does not handle the 64-bit resources properly.

I went through the entire "laundry list" with this problem myself:
  • Verified game cache
  • Set compatibility option; Run As Administrator
  • Set compatibility option; WinXP SP3
  • Set compatibility option; WinXP SP2 (just in case, no diff' rly)
  • Attempted manual launch through MassEffectLauncher.exe
  • Attempted manual launch; binaries\MassEffect.exe
None of these had any effect. In fact, it seems that the MassEffectLauncher app (when you click on Play) just recursively triggers the command in Steam, so it's exactly the same as clicking on Play in Steam.

So, I can confirm that manually installing the DirectX files that came with ME1 will, in fact, get past this Application Error problem. (the "silent crash" problem) When you launch DXSETUP manually, the installer takes a fresh look at the entire system; the auto-launched version was limited by BioWare and/or Valve which targets the specific assets of the game. (except it was targeted for 32-bit/x86 resources only)

A reboot doesn't hurt either.

My specs:
AMD FX-6300 (3 x dual-core) 3.5GHz
8GB RAM - DDR3 PC-12800
nVidia GTX 550 Ti - 1GB DDR5 VRAM
Windows 7 Home Premium 64-bit
Best of luck!
blueblaze23 is offline   Reply With Quote
Old 11-02-2013, 09:02 AM   #28
JosephBroze
 
Join Date: Mar 2007
Reputation: 19
Posts: 131
Quote:
Originally Posted by BlackD View Post
It appears the Steam version of Mass Effect doesn't update to the latest patch version which corrects launch issues.

http://files.bioware.com/masseffect/...EFIGS_1.02.exe

Download and run the update. It will ask if you want to update your game version, and once it's completed, Mass Effect should launch fine from Steam, without having to use any compatiablility or admin tricks.

+BlackD
For the record, I had launch problems of the "failed to start game (app already running)" sort on my XP x64, and this patch handily fixed it.
JosephBroze is offline   Reply With Quote
Old 01-01-2014, 08:41 PM   #29
prophet82
 
 
 
Join Date: Jan 2010
Reputation: 0
Posts: 106
ok the problem im having is i launch it and the screen goes black i just smash esc and few times and it comes up with the loading screen
prophet82 is offline   Reply With Quote
Old 01-17-2014, 01:05 PM   #30
pigosso
 
 
 
Join Date: Nov 2010
Reputation: 59
Posts: 465
Quote:
Originally Posted by prophet82 View Post
ok the problem im having is i launch it and the screen goes black i just smash esc and few times and it comes up with the loading screen
http://pcgamingwiki.com/wiki/Mass_Ef...oesn.27t_start
pigosso is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > M - P > Mass Effect series


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 04:45 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.