Go Back   Steam Users' Forums > Steam Discussions > Help and Tips

Reply
 
Thread Tools Display Modes
Old 11-14-2009, 10:17 AM   #1
aimanyusra
 
Guest
Posts: n/a
Games running 1.5x faster than normal.

Hi I just installed WIn 7 Pro 32-bit 2 days ago and I immediately found out that my games run faster. I redownloaded CS1.6 on Steam the other day and I seem to walk/shoot faster than normal.

This affects online play as I'm assuming that I'm moving faster than the server, hence causing me to lag. I don't really know how to explain this.
Thing is, this only happens when I turn off Vsync.
When I turn it on, the problem seems to go away. But I play CS competitively so I need 100 fps, which is why I need vsync off,

I've also installed Arkham Asylum, and noticed that Batman seemed to walk faster than what I've seen on Youtube, and the in-game speech ALWAYS ends after the character's mouth stops moving. (Only in-game, not cut scenes).

Note that I turn vsync off in my Nvidia global settings.

My specs are:
Intel C2D E6400 @ 2.13ghz no OC
3gb ram
xfx 9600gt xxx stock OC @ newest nvidia drivers
Steelseries siberia USB soundcard

Help needed
 
Reply With Quote
Old 11-14-2009, 12:07 PM   #2
Frigid
 
Join Date: Nov 2005
Reputation: 366
Posts: 2,703
This happens to me in Madden for PC.

To fix it I press Ctrl + Alt + Del, find the process, right click on it, set affinity, and only have 1 processor box checked.
Frigid is offline   Reply With Quote
Old 11-14-2009, 08:28 PM   #3
aimanyusra
 
Guest
Posts: n/a
Quote:
Originally Posted by Frigid View Post
This happens to me in Madden for PC.

To fix it I press Ctrl + Alt + Del, find the process, right click on it, set affinity, and only have 1 processor box checked.
Thanks for the reply, but didn't work for CS for me. If possible I'd like to attach the demo of me showing the lag..

Oh and running on one core for Batman just makes it worst. (The speed is normal, but now the game becomes laggy)
  Reply With Quote
Old 11-15-2009, 08:00 AM   #4
aimanyusra
 
Guest
Posts: n/a
No one knows?
  Reply With Quote
Old 11-15-2009, 08:05 AM   #5
UserU
 
Banned
Join Date: Dec 2008
Reputation: 69
Posts: 1,360
Apparently, a dual-core optimizer works. The problem might be due to full core utilization, therefore speeding up the games
UserU is offline   Reply With Quote
Old 11-15-2009, 10:10 AM   #6
aimanyusra
 
Guest
Posts: n/a
I've been trying to look out for an Intel dual-core optimizer. I tried Winthrottle, but it just lags everything. I didn't face this while using Vista Ultimate before I upgrade.. Could it be driver related? I'm using a Gigabyte motherboard, don't think they released a Win 7 driver
  Reply With Quote
Old 11-16-2009, 01:51 AM   #7
aimanyusra
 
Guest
Posts: n/a
Bump?
can't play my games
  Reply With Quote
Old 11-16-2009, 03:34 AM   #8
UserU
 
Banned
Join Date: Dec 2008
Reputation: 69
Posts: 1,360
I've read some forums and the solution given was uninstalling the GPU drivers and re-downloading the latest version. Or perhaps try using the AMD DCO for yours. It might help.
UserU is offline   Reply With Quote
Old 11-17-2009, 01:45 AM   #9
aimanyusra
 
Guest
Posts: n/a
I've tried the GPU drivers from new to old, which are supported by W7, even the beta ones. Didn't work. Can the AMD DCO work for my Core 2 duo?
  Reply With Quote
Old 11-17-2009, 02:05 AM   #10
UserU
 
Banned
Join Date: Dec 2008
Reputation: 69
Posts: 1,360
Well, I'm not throughly sure, but this topic relates the question and this. But you've to face the risk just in case this happens

Be patient as the results are very random. You might ask the mods for solution if these fails.
UserU is offline   Reply With Quote
Old 11-17-2009, 02:40 AM   #11
Mangr0v3
 
 
 
Join Date: Sep 2008
Reputation: 4313
Posts: 13,608
Quote:
Originally Posted by aimanyusra View Post
But I play CS competitively so I need 100 fps, which is why I need vsync off
Why do you need to render frames faster than your monitor can display them to you?
Mangr0v3 is offline   Reply With Quote
Old 11-17-2009, 03:47 AM   #12
irogue
 
Join Date: Nov 2009
Reputation: 171
Posts: 971
Sounds like a sound card driver related issue if the like you say " and the in-game speech ALWAYS ends after the character's mouth stops moving. (Only in-game, not cut scenes)." happens.

I wouldnt say the games running too fast ive heard of old games running too fast on AMD based machines but not intel but then again i havent googled this issue "intel+C2D+games+run+to+fast"

have you done a benchmark or frame rate comparison from old system setup to new one with win 7 vs vista?

Console command too view frame rate is " net_graph 1 " if i recall in source engine based games not sure abotu batman maybe use FRAPS for that.

Sorry to be vague but thats all i can think of man.
irogue is offline   Reply With Quote
Old 11-17-2009, 04:57 AM   #13
Patrician
 
Guest
Posts: n/a
Quote:
Originally Posted by Mangr0v3 View Post
Why do you need to render frames faster than your monitor can display them to you?
It's simply something they need...look at QIII progamer demos...no textures, bumpmaps...and it's a very old game :]
  Reply With Quote
Old 11-17-2009, 12:16 PM   #14
aimanyusra
 
Guest
Posts: n/a
@UserU, I just tried installing the DCO, I tried running it but it didn't open anything so.. Not compatible I guess?

@Mangr0ve, with vsync on and fps cap at 75fps, I will lose response time when other players use 100fps, their mouse response is faster (don't know why).

@irogue, I know how fast the games run on my pc before I installed Win7.. And compared to now, what I'm getting is not normal. I'm achieving 100fps on net_graph 3 and cl_showfps. And from what I know, the character voices' timings are spot on, just that their models render too quickly or something.


@Patrician, yeah it optimizes our game.

Oh and movies and other media play fine, only games.
  Reply With Quote
Old 11-17-2009, 04:02 PM   #15
irogue
 
Join Date: Nov 2009
Reputation: 171
Posts: 971
Sorry i couldnt help mate, i hope you get more replys soon!
irogue is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Discussions > Help and Tips


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 07:50 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.