Go Back   Steam Users' Forums > Steam Discussions > Help and Tips

Reply
 
Thread Tools Display Modes
Old 11-27-2009, 11:57 AM   #1
RaveMoyers
 
Join Date: Nov 2009
Reputation: 30
Posts: 33
Lightbulb Windows 7 Ping Spikes [FIX]

Hi there, I've recently had an extremely annoying issue regarding sound, games, multiplayer, and Windows 7. When I would start up a game (such as Counter-Strike Source or Heroes of Newerth) and connect to server
, my fps and ping would be nominally OK, but the game would lag. In HoN this would be displayed by the heroes moving jerkily around the map, even though my fps and ping were good. In Counter Strike, this evidenced itself by glitchy nades that don't bounce smoothly, and whenever sounds are played, the ping spikes a bit. It's kind of like playing on a 33 tic server, for those of you familiar with the game. None of these issues occurred in single player games or in the aforementioned games with a local server. Symptoms included warping, skipping, and lagging while moving or viewing other players move.

Anyway, I searched and searched here and couldn't find anything, but finally I found something in Google (note: this is only a partial fix, don't do this, see update):

* Stop and disable the "Multimedia Class Scheduler" service
* Run regedit and go to "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servi ces\Audiosrv"
* Double click on the entry "DependOnService" and delete the line with "MMCSS" from the text box
* Reboot and enjoy lag free games


I diagnosed the issue by realizing that by disabling audio devices in device manager, lag would disappear in-game. So glad I found this solution after installing 6 different audio drivers and generally being very frustrated. Just thought I'd leave this here as a reference for others with a similar issue.

Update: doing this will likely induce audio issues such as crackling, popping, stuttering, and skipping. My final solution was to leave this service enabled but disable it's network throttling component (if you already did the first fix you should undo it and re-enable the service). This resolved my audio issues caused by disabling the MMCS while keeping my games lag free. This is not a solution if you are not experiencing network issues. If you are experiencing audio issues only, you should make sure the MMCSS is running. The best way to test if you have this problem is to disable your sound device in Device Manager and then see if the lag persists. If it does, you have some other issue. If the lag goes away, re-enable your sound device and try the following fix:

Quote:
Leave the multimedia class scheduler service running, but disable its network throttling "feature":

* Open regedit
* Go to: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Multimedia\SystemProfile
* There will be an entry for network performance throttling, default value is 10; set it to FFFFFFFF hex (willl look like 0xFFFFFFFF to the right of the entry)
* Reboot


Here are some example threads where this fix was useful:
Counter-Strike Series & Windows 7 = Lag?
stuttering in games. (mainly valve)
High Ping and Choke in Windows 7 (CSS/TF2)

Games affected:
Source Engine Games (Team Fortress 2 (TF2), Left 4 Dead, Counter Strike Source (CS:S, CSS))
Heroes of Newerth (HoN)
Call of Duty Series (CoD), possibly including Modern Warfare
Overlord Series (Overlord, Overlord: Raising Hell, Overlord 2)

Post if you find another game that's affected so I can add it to this list!

For those interested, here are some articles on the MMCSS:
http://courtneymalone.com/2007/08/28...network-speed/
http://blogs.msdn.com/larryosterman/...slowdowns.aspx
http://msdn.microsoft.com/en-us/libr...8VS.85%29.aspx
http://blogs.technet.com/markrussino...7/1833290.aspx
http://www.thebits.info/windows/vista-mcs-56.htm


My optimal solution was to keep the MMCS service running, as if you turn it off your audio may start cackling/skipping in an annoying fashion. However, I disabled the network throttling component of this service. I believe it's a general audio problem specific to Windows 7 and multiplayer / online games. I don't think the audio card or the drivers make a difference, or at least they didn't in my case.

Leave the multimedia class scheduler service running, but disable its network throttling feature:

* Open regedit
* Go to: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Multimedia\SystemProfile
* There will be an entry for network performance throttling, default value is 10; set it to FFFFFFFF hex (willl look like 0xFFFFFFFF to the right of the entry)
* Reboot


This removed the lag I was experiencing while still enabling me to have normal sound in-game. Specs in profile.
RaveMoyers is offline  
Reply With Quote
Old 01-05-2010, 10:46 PM   #2
Vekter
 
Join Date: Aug 2008
Reputation: 219
Posts: 856
Fix those links and I'll be willing to believe that this won't crash my Windows install.
Vekter is offline   Reply With Quote
Old 01-05-2010, 10:57 PM   #3
Arctic Ice
 
Arctic Ice's Avatar
 
Volunteer Moderator
Join Date: Apr 2006
Reputation: 1539
Posts: 5,927
I posted this in the TF2 thread about the same subject:

For those interested in the details from Microsoft.com:

Quote:
Because multimedia programs require more resources, the Windows networking stack implements a throttling mechanism to restrict the processing of non-multimedia network traffic to 10 packets per millisecond.
Quote:
By default, the value for the NetworkThrottlingIndex registry entry is set to 10. When the NetworkThrottlingIndex registry entry does not exist, the behavior resembles the default behavior. Network throttling can be completely turned off by setting the value to FFFFFFFF (hexadecimal). You must restart the computer after you make a change to the value of the NetworkThrottlingIndex registry entry.
Quote:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Multimedia\SystemProfile\
Name : NetworkThrottlingIndex
Value type : DWORD
Value data : From integer 1 through integer 70 (Decimal) (Decimal)
Arctic Ice is offline   Reply With Quote
Old 01-27-2010, 02:00 PM   #4
tritanium1
 
Guest
Posts: n/a
Fix worked perfectly

I too experienced similar audio/fps issues and experimented/researched extensively.

I have Realtek onboard audio and also tried several different driver versions from their website, looking for a solution.

Once I realized this issue occured only during online sessions, I began to research a little more into a potential network issue.

All Source games appeared to be affected in my case including TF2, L4D, GMOD, and possibly others.

I am happy to report that after implementing this quick registry hack, all problems seem to have been resolved (on all games affected).

Thanks very much for the brilliant troubleshooting!
  Reply With Quote
Old 02-02-2010, 09:41 AM   #5
DrunkenDBD
 
 
 
Join Date: Feb 2006
Reputation: 0
Posts: 53
I just posted this fix in another thread, this is the exact problem I had and the registry fix resolved my lag issues.
DrunkenDBD is offline   Reply With Quote
Old 02-02-2010, 11:19 AM   #6
FulValBot (ITA)
 
 
 
Join Date: Oct 2007
Reputation: 113
Posts: 2,617
i suggest to send feedback on microsoft... we need an official fix for it, also for vista, not only 7.
FulValBot (ITA) is offline   Reply With Quote
Old 02-04-2010, 06:51 PM   #7
spawn_
 
Banned
Join Date: Feb 2009
Reputation: 7
Posts: 238
this ing amazin. u are my hero dude. no more lag spikes in harsh battle and my ping improved. thank u very much. all w7 users should do this nao.
spawn_ is offline   Reply With Quote
Old 03-06-2010, 12:58 PM   #8
KeithTalent
 
Guest
Posts: n/a
I was really hoping this would work for me, since I can barely play TF2 due to the crazy packet loss/lag spikes I have been getting. Unfortunately I made this change, but it almost seemed worse after doing so.

I followed the instructions near the bottom of the OP, but is there something else I need to do to get this fix working correctly?

Thanks.

KT
  Reply With Quote
Old 03-07-2010, 10:49 PM   #9
Milamber
 
Guest
Posts: n/a
Thanks, this is a good fix

Edit: +rep

Last edited by Milamber: 03-08-2010 at 10:00 PM.
  Reply With Quote
Old 03-08-2010, 09:55 PM   #10
Phyxion
 
 
 
Join Date: Mar 2009
Reputation: 0
Posts: 102
Actually seemed to work for me, still testing though.
Phyxion is offline   Reply With Quote
Old 03-09-2010, 12:02 PM   #11
OccFatal
 
Join Date: Oct 2007
Reputation: 3
Posts: 20
@KiethTalent: To narrow the cause of your issue, if you disable your sound card in device manager, then play an affected game and the issue goes away, this fix should work for you. Otherwise the problem lies elsewhere.

btw, source thread (looks like it's had a minor update): http://www.sevenforums.com/gaming/31...ndows-7-a.html

Last edited by OccFatal: 03-09-2010 at 12:21 PM.
OccFatal is offline   Reply With Quote
Old 03-15-2010, 06:04 AM   #12
aforumtotalkon1
 
Join Date: Mar 2010
Reputation: 170
Posts: 2,160
Is it normal when I click modify that the value data is 'a' for network throttle? Even though the value does say (10) on the right?


and 8 F's makes the value on the right say 0xffffffff (4294967295)? I know the 0xfffffff is normal btw
aforumtotalkon1 is offline   Reply With Quote
Old 03-15-2010, 07:01 AM   #13
joemtnbike
 
Join Date: Apr 2009
Reputation: 1062
Posts: 2,427
I just set mine to 0x00000032 (50) allowing 50000 packets/second and it works great also. as I was afraid disabling altogether might cause some other problem. MS states that 0x00000010-0x00000046 (10-70) are acceptable values with 0xffffffff disabling it altogether. Reference MS support article linked by Arctic Ice above.
joemtnbike is offline   Reply With Quote
Old 03-23-2010, 04:59 AM   #14
phil44
 
Guest
Posts: n/a
@aforumtotalkon1:
Yes that's normal, 'a' is the hexadecimal value, and '10' is the decimal value. You can switch between which one your changing/viewing when you double click the registry entry, and the other will always be the equivalent hexadecimal/decimal value. So after you change it, 'ffffffff' will be your hexadecimal value, and '4294967295' your decimal value.

Also, I can confirm that this has fixed my stuttering issues with Bad Company 2, which was making the game unplayable despite a high fps and low ping.

Thanks RaveMoyers for the thread, I was getting quite frustrated not being able to play BC2. The odd thing though, is this problem hasn't affected any of my other games, nor the BC2 beta. And no, it definitely is not placebo, the game is running noticably smoother now, it was practically unplayable before this fix.

Last edited by phil44: 03-23-2010 at 05:04 AM. Reason: Forgot to thank RaveMoyers for the fix.
  Reply With Quote
Old 03-27-2010, 02:28 AM   #15
Sotorious
 
Join Date: Sep 2007
Reputation: 11
Posts: 228
This won't effect anything in the long run will it? do you think Microsoft knows about this. I have noticed this when i installed my 2nd sound card since i am using to an asus xonar d2, as well as onboard for headphones, right now i disabled all my sounds and went into bfbc2 and i was not getting those mini frame chops. I have yet to try cs cause i was noticing the whole nade thing, but it doesn't happen consistently.
Sotorious is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Discussions > Help and Tips


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 08:33 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.