Go Back   Steam Users' Forums > Steam Discussions > Help and Tips

Closed Thread
 
Thread Tools Display Modes
Old 12-17-2009, 08:11 PM   #1
jethrosoup
 
Guest
Posts: n/a
Steam says I'm not connected to internet

I'm running Windows 7 64bit. Steam has worked for me for as long as I can remember until now. I get the error, "Steam.exe (main exception): To run Steam, you must first connect to the Internet"

Of course, I'm connected to the internet. I tried uninstalling and reinstalling Steam, to no avail.

My internet connection is currently whitelisted, so it's possible a website is getting blocked, but I can't figure out which one, if one exists. Are there any websites besides steampowered.com that it needs to run? Thanks!
 
Old 12-17-2009, 08:18 PM   #2
Bearkin
 
 
 
Banned
Join Date: Dec 2009
Reputation: 3811
Posts: 1,188
No idea if this is even revelant but are you running it as an administrator? Again, I don't even have Windows 7 so I don't even know if that's still an issue like it was in Vista.
Bearkin is offline  
Old 12-17-2009, 08:24 PM   #3
jethrosoup
 
Guest
Posts: n/a
I tried running it as an administrator, but it still just hangs at the update window for a bit until it gives me the error.
 
Old 12-17-2009, 09:16 PM   #4
jethrosoup
 
Guest
Posts: n/a
So, what sites besides steampowered.com are needed to run Steam? Are there any special sites where downloads are hosted or something?
 
Old 12-17-2009, 09:22 PM   #5
Bearkin
 
 
 
Banned
Join Date: Dec 2009
Reputation: 3811
Posts: 1,188
Have you changed your firewall settings or changed/installed anything that could potentially affect your internet?
Bearkin is offline  
Old 12-17-2009, 09:48 PM   #6
MADDOGGE
 
Join Date: Jan 2008
Reputation: 11740
Posts: 26,211
Quote:
Originally Posted by jethrosoup View Post
I'm running Windows 7 64bit. Steam has worked for me for as long as I can remember until now. I get the error, "Steam.exe (main exception): To run Steam, you must first connect to the Internet"

Of course, I'm connected to the internet. I tried uninstalling and reinstalling Steam, to no avail.

My internet connection is currently whitelisted, so it's possible a website is getting blocked, but I can't figure out which one, if one exists. Are there any websites besides steampowered.com that it needs to run? Thanks!
I run Win7 64 and have no problem connecting to Steam normally unless they are having server problems. Make sure you have given permissions to any firewalls and or AV you are running. You shouldn't need any other site to run Steam. Try restarting your PC if you haven't done so yet.
MADDOGGE is offline  
Old 12-17-2009, 10:30 PM   #7
jethrosoup
 
Guest
Posts: n/a
Everything checks out with the firewall and AV. Steam has all of the permissions it needs.

I'll mess with my router to see if any part of Steam is getting blocked by the whitelist. Any other suggestions as to what might be causing this?
 
Old 12-28-2010, 04:21 PM   #8
spartan1323
 
Guest
Posts: n/a
im having the same problem. have you figured it out yet?
 
Old 12-28-2010, 10:50 PM   #9
Pots'N'Pans
 
Guest
Posts: n/a
I'M HAVING THE EXACT SAME PROBLEM AS WELL. Windows 7 64bit.

I've done everything, to deleting specific files, and i re-installed steam twice now and it gives me the same message after it "tries" to update being stuck at 0%. "Steam.exe (main exception): To run Steam, you must first connect to the Internet"
I checked my firewall and anti virus, everything is clear.

Does anyone know how to fix this?
 
Old 06-27-2011, 02:47 PM   #10
athenastar17
 
Guest
Posts: n/a
Still unsolved?

I'm going to revive this topic because I'm having the same problem and I can't find a solution. I have checked that I'm online, restarted, reinstalled steam several times, deleted the "blob" file several times, repaired steam installation, turned off my firewall, logged in on a browser to make sure the steam servers are running, tried at several different days and different times of day - everything. I'm running a brand spanking new Windows 7 64-bit laptop. Steam worked fine on my old Windows XP laptop. I don't know what else to do.
 
Old 06-28-2011, 04:05 AM   #11
athenastar17
 
Guest
Posts: n/a
The solution I found:
It seems the internet at my place of residence was blocking steam. It wasn't my connection or my firewall, but the ones providing my internet. It works fine on a university wi-fi network. Which...sucks, since apparently I can't connect to steam at home where I would actually play games.
 
Old 06-28-2011, 04:23 AM   #12
falcondimon
 
 
 
Join Date: Oct 2010
Reputation: 22
Posts: 182
I've got same problem, but I can log into my acc. It just says no connection and i cant normally play anything! When I log into my brother's account, everything's fine, but on mine... I also tried logging on different computers, but still nothing.
falcondimon is offline  
Old 06-28-2011, 04:48 AM   #13
Wazgrel
 
 
 
Join Date: Nov 2008
Reputation: 34
Posts: 618
Same problem... Some of my friends are online (I can see through steam profile page), but I get NO CONNECTION error at the bottom of the screen.

HALP!!!

Edit: Aaaargh!! Let me in!! Not cool dude, I need my fix!!

Last edited by Wazgrel: 06-28-2011 at 04:56 AM.
Wazgrel is offline  
Old 06-28-2011, 05:15 AM   #14
kassarin
 
 
 
Join Date: May 2011
Reputation: 0
Posts: 10
Its back... the bug... ITS BACK... OH THE HORROR T-T
kassarin is offline  
Old 06-28-2011, 05:18 AM   #15
Sierra Oscar
 
Sierra Oscar's Avatar
 
Volunteer Moderator
Join Date: Dec 2005
Reputation: 6782
Posts: 44,764
Lets try and keep it to this thread. Thanks!
Sierra Oscar is offline  
Closed Thread

Go Back   Steam Users' Forums > Steam Discussions > Help and Tips


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 03:57 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.