Go Back   Steam Users' Forums > Steam Discussions > Help and Tips

Reply
 
Thread Tools Display Modes
Old 12-20-2009, 11:09 PM   #1
turbomelon
 
Guest
Posts: n/a
steam freezes up windows 7 laptop

This is kind of a longshot, but I've spent hours searching google and steam's forums.

I recently got a Asus G51-J the Corei7 laptop, and whenever I try to fire up steam it completely locks up my computer. I've isolated the problem to when steam client services tries to start up, but I can't figure out what the fix is.

I'm using windows 7 and I've tried everything from reducing user access control to shutting off my firewall, antivirus and every other non essential background process. I've done registry cleaning, updated all my drivers and tried out every single "fix" stated on various other tech forums and steam forums. So pretty much whenever steam tries to start up it locks up my computer.

I've even tried to run an event logger to see what happens, but the second steam client services starts up it locks the computer up and even the event logger can't catch what happens.

I was wondering if anyone on here had any possible suggestions. When my laptop freezes its not one of those oh ctrl+alt+del end process it completely locks up everything and you have to hard shut down. Thanks in advance anyone.
 
Reply With Quote
Old 01-05-2010, 05:24 AM   #2
mglas72
 
Join Date: May 2009
Reputation: 0
Posts: 6
I have the same laptop and this very same problem started for me tonite. It has been running without issue and the problem came from nowhere.
Did you ever find a solution?
Thanks.
mglas72 is offline   Reply With Quote
Old 01-10-2010, 05:02 PM   #3
xindependentxcs
 
Guest
Posts: n/a
Same here. I cant find the solution to this. I got a G60Vx
  Reply With Quote
Old 01-10-2010, 07:29 PM   #4
xindependentxcs
 
Guest
Posts: n/a
Do a system restore. It has solved my problems so far.
  Reply With Quote
Old 01-23-2010, 06:28 AM   #5
Difoune
 
Guest
Posts: n/a
Same problem for me

Quote:
Originally Posted by turbomelon View Post
This is kind of a longshot, but I've spent hours searching google and steam's forums.

I recently got a Asus G51-J the Corei7 laptop, and whenever I try to fire up steam it completely locks up my computer. I've isolated the problem to when steam client services tries to start up, but I can't figure out what the fix is.

I'm using windows 7 and I've tried everything from reducing user access control to shutting off my firewall, antivirus and every other non essential background process. I've done registry cleaning, updated all my drivers and tried out every single "fix" stated on various other tech forums and steam forums. So pretty much whenever steam tries to start up it locks up my computer.

I've even tried to run an event logger to see what happens, but the second steam client services starts up it locks the computer up and even the event logger can't catch what happens.

I was wondering if anyone on here had any possible suggestions. When my laptop freezes its not one of those oh ctrl+alt+del end process it completely locks up everything and you have to hard shut down. Thanks in advance anyone.
Hi

I got eaxctly the same problem. Did you find the solution ? The steam support is trying to help but nothing solved the problem so far.

Cheers

Stef
  Reply With Quote
Old 02-13-2010, 09:02 AM   #6
ipes
 
Guest
Posts: n/a
I've got the 3D version of this laptop and it was doing the same thing to me on the 2nd day I had it......I just fixed it this morning. Go uninstall anything that says creative in the add remove programs......mediasource and soundblaster audigy. Steam just loaded for me after doing that with no freezing
  Reply With Quote
Old 02-13-2010, 07:06 PM   #7
Solid_Static
 
Join Date: Jan 2007
Reputation: 0
Posts: 10
I can confirm that. I uninstalled the Creative Audigy thing and all is good.

Last edited by Solid_Static: 02-13-2010 at 07:18 PM.
Solid_Static is offline   Reply With Quote
Old 04-20-2010, 01:55 PM   #8
FreIHh.
 
 
 
Join Date: Jun 2008
Reputation: 22
Posts: 553
Hi

I use a Asus G60JX-JX040V

Same problem, same fix : delete all Creative programs

Thank you very much
FreIHh. is offline   Reply With Quote
Old 04-23-2010, 09:14 AM   #9
Magichands88
 
Guest
Posts: n/a
I've got an ASUS G60JX-RBBX05, uninstalled all the Creative stuff, started working again perfectly. I haven't the foggiest idea as to why this stuff makes it stop working OR why it doesn't do it right away, but takes a few days. Anyway, uninstalling it all will fix your issues and you still have sound, so no worries there.
  Reply With Quote
Old 04-27-2010, 03:36 PM   #10
FreIHh.
 
 
 
Join Date: Jun 2008
Reputation: 22
Posts: 553
Do you guys have problems of freeze recording a demo ? fps fast dropping etc as here : http://forums.steampowered.com/forum....php?t=1225653 it's an asus ROG too
FreIHh. is offline   Reply With Quote
Old 05-02-2010, 04:32 AM   #11
pavan168
 
Guest
Posts: n/a
WOW thanks a lot (Y)
  Reply With Quote
Old 06-21-2010, 10:17 AM   #12
Benson99
 
Guest
Posts: n/a
The reason it locks up the computer is becasue for some reason all Asus G-series laptops come with 2 sound driver. When i read the above solution it reminded me of something i had read in the reveiws for my G60; that in order for you to do any real gaming you have to remove one of the sound drivers otherwise they conflict and slow the game down or in extreme cases lock up the computer. That is the reason and once you do i have noticed that my speakers (and all other sound) actually sound a bit better then before. thanks for the help.
  Reply With Quote
Old 06-21-2010, 02:04 PM   #13
paponeo
 
Join Date: Apr 2010
Reputation: 0
Posts: 10
I have that too...

I rlly have that too..anybody reply to my Fourm? it says Help?! anyway, i have 2 probblems
paponeo is offline   Reply With Quote
Old 09-09-2010, 12:14 PM   #14
thefiddycow
 
Guest
Posts: n/a
I had the same problem, and when i deleted the Creative Audigy thing, it fixed it. But now since i deleted that sound blaster software, the sound for games like my Modern Warfare 2 is complete crap. are there any fixes?
  Reply With Quote
Old 09-13-2010, 10:18 AM   #15
michael92782
 
Guest
Posts: n/a
alright im using the asus g73jh-a1 and i went thru and got rid of all the creative files but im still experiencing all the lockups just not as frequently is there something else going on with the newer asus setups that im missing? i get about 20 minutes into running steam or playing one of my steam games then the blasted thing goes unresponsive and i gotta do a hard boot to get it back
  Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Discussions > Help and Tips


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 01:30 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2012, All Rights Reserved.