Go Back   Steam Users' Forums > Steam Game Discussions > H - L > Harvest: Massive Encounter

Reply
 
Thread Tools Display Modes
Old 01-04-2010, 01:50 PM   #1
shoefish
 
Join Date: Jan 2010
Reputation: 0
Posts: 2
Guns not working?

Hi, love the game and have been having a lot of fun with wave mode, but have just started getting a gamebreaking bug. My turrets/missile towers no longer target enemies. I'm running windows 7 x64, and the bug shows up in any new game. I can load older saves and they still work fine.

I have tried deleting local content and reinstalling, but still getting the same issue.

Last edited by shoefish: 01-04-2010 at 02:05 PM.
shoefish is offline  
Reply With Quote
Old 01-05-2010, 12:58 AM   #2
jeb_
 
Join Date: Jan 2009
Reputation: 2
Posts: 24
Hello

I saw you posted this in our forums as well.. The reason why I haven't replied earlier is because this bug is one of those "uuuuuuuuuuuuhhhh..." bugs. I'd like to give you a more intelligent reply, but for now this will have to do:

Uuuuuhhh...
jeb_ is offline   Reply With Quote
Old 01-11-2011, 07:21 PM   #3
spacewaker
 
Join Date: Jul 2010
Reputation: 0
Posts: 2
I Have the same or a similar problem i think. only the turrets do target if i speed up time. The turrets occasionaly just turn very slowly in normal time. So slowly that they cant keep up with anything.
spacewaker is offline   Reply With Quote
Old 05-08-2011, 10:38 PM   #4
Blxz
 
Join Date: Mar 2011
Reputation: 3
Posts: 124
No idea what your problem is without some more information but.... are you sure you have enough power for your turrets?
Blxz is offline   Reply With Quote
Old 08-04-2011, 01:01 PM   #5
ec2011
 
Join Date: Aug 2011
Reputation: 0
Posts: 2
Same here; Win 7 x64 and the guns don't respond to incoming enemies. I tried to speed up the game and they work normally but slow and normal time they don't move. Is there going to be a fix for this? It is a very difficult game at hyper speed
ec2011 is offline   Reply With Quote
Old 08-07-2011, 10:49 PM   #6
VooDooAddict
 
Join Date: Nov 2006
Reputation: 4
Posts: 64
I've been having the same problem for at least a year... it seems clear that they are not planning to fix the issue. The excuse is it's a hard bug to track down ... but I think at this point it's just an excuse. There is no more effort. People have submitted many details regarding this issue and nothing.


It works fine on my Win7 32-bit netbook, though sluggish and only 1280x768.


It's really frustrating is this was one of my favorite ever tower defense style games. What makes me sick is that it's still for sale... and there seems to be no chance of a fix. New buyers could easily be SOL without knowing it.
VooDooAddict is offline   Reply With Quote
Old 12-02-2011, 05:32 AM   #7
Godwin
 
Join Date: Dec 2010
Reputation: 0
Posts: 48
hmm Picked up this game recently, loving it so far
Luckily no issue like that. Bit bad to hear that they won't fix it, if what you're saying is true. Could also be due a number of more legitimate reasons though.
Godwin is offline   Reply With Quote
Old 04-12-2012, 09:41 AM   #8
thewreck
 
Join Date: May 2010
Reputation: 3
Posts: 6
Smile

Hi!

Developer here!

I'm part of Oxeye Game Studio, and despite the name, we are not much of a studio. Just a couple of friends that make games independently. I'm currently working on a game called Cobalt.

I don't know if jeb ever found out why that bug was happening or if he managed to fix it, however, jeb did work for some while on a patch for harvest. Since our mac-guy had left the group a while back he tried to compile the patch for OSX himself, but failed in spectacular fashion. Since he did not want to split the OS versions he decided to put up the patch as a beta on the forums and wait.

Now, for a couple of months, we have employed an outside contractor that has re-ported harvest for OSX, and along side with that, fixed a bunch of other issues. This new version and the re-port for OSX is around the corner, but I do not know if it fixes the gun shooting bug specifically. It does however include a hold fire button in the attack priorities menu.

The bug in question has never occurred to me, and jeb never spoke to me about it (not that I could have done anything about it anyway since jeb is the c++ coder.)

I know jeb still has desire to make sure harvest is a healthy game, and the hurdle the last one or two years has been the loss of our OSX support and knowledge. Now that Tommaso is helping us things are at least more hopeful!
thewreck is offline   Reply With Quote
Old 04-12-2012, 11:45 AM   #9
graspee
 
 
 
Join Date: Jul 2011
Reputation: 1988
Posts: 4,065
Quote:
Originally Posted by thewreck View Post
Hi!

Developer here!

I'm part of Oxeye Game Studio, and despite the name, we are not much of a studio. Just a couple of friends that make games independently. I'm currently working on a game called Cobalt.

I don't know if jeb ever found out why that bug was happening or if he managed to fix it, however, jeb did work for some while on a patch for harvest. Since our mac-guy had left the group a while back he tried to compile the patch for OSX himself, but failed in spectacular fashion. Since he did not want to split the OS versions he decided to put up the patch as a beta on the forums and wait.

Now, for a couple of months, we have employed an outside contractor that has re-ported harvest for OSX, and along side with that, fixed a bunch of other issues. This new version and the re-port for OSX is around the corner, but I do not know if it fixes the gun shooting bug specifically. It does however include a hold fire button in the attack priorities menu.

The bug in question has never occurred to me, and jeb never spoke to me about it (not that I could have done anything about it anyway since jeb is the c++ coder.)

I know jeb still has desire to make sure harvest is a healthy game, and the hurdle the last one or two years has been the loss of our OSX support and knowledge. Now that Tommaso is helping us things are at least more hopeful!
Thanks for coming to comment. I'm really enjoying the game so far.
graspee is online now   Reply With Quote
Old 04-24-2012, 04:16 PM   #10
ec2011
 
Join Date: Aug 2011
Reputation: 0
Posts: 2
I am happy to report that the 4.17.2012 patch fixed the guns not working problem for me. I played a full game last night for the first time. What a great game!
ec2011 is offline   Reply With Quote
Old 04-24-2012, 07:49 PM   #11
graspee
 
 
 
Join Date: Jul 2011
Reputation: 1988
Posts: 4,065
Quote:
Originally Posted by ec2011 View Post
I am happy to report that the 4.17.2012 patch fixed the guns not working problem for me. I played a full game last night for the first time. What a great game!
I'm really happy to hear that. Well done, developers! Thank you.
graspee is online now   Reply With Quote
Old 07-11-2012, 02:14 PM   #12
Friendliest
 
Join Date: Jan 2010
Reputation: 822
Posts: 3,971
Quote:
Originally Posted by graspee View Post
Thanks for coming to comment. I'm really enjoying the game so far.
Yes I was enjoying it too, for my first 5-6 games, until it broke.

Quote:
Originally Posted by graspee View Post
I'm really happy to hear that. Well done, developers! Thank you.
I wouldn't be so quick with the congratulations. I still have this problem.

Guns (laser towers) target enemies super slowly, to the extent that they never actually fire on them. This is in normal mode, hephaestus, and I tend to do a "boom" build, where I build as much econ as possible before building a laser. going above normal speed "fixes" the problem, but obviously this is not a real fix.

Just bought the game through indie royale, and my game is patched up to date.

Would really like to see a fix -- and soon -- as this breaks the game for all practical intents and purposes.

FWIW Win7 x64. 1600x900 resolution. fullscreen.


thank you.


P.S. and to the developers: "we are not a real game studio" is the last thing ppl in our position want to hear. just saying. you will also forgive me if your rambling response about an OSX patch fails to inspire confidence, when no one in this thread has even mentioned OSX, and in fact, several have specifically mentioned Win7 x64. (and need I mention how inappropriate and audacious it is to plug your new "product", at this time, as well?)

seems like it should be a simple, and clear, issue to fix -- with a little effort -- and I hope to see it addressed soon. thank you.


P.P.S. - might I also suggest that if you as a "pseudo-studio" have no intention of fixing this game, that you just open source it so that someone who has the time and inclination can?

Last edited by Friendliest: 07-11-2012 at 02:34 PM.
Friendliest is offline   Reply With Quote
Old 07-15-2012, 01:29 PM   #13
Marrishka
 
Join Date: Jul 2011
Reputation: 0
Posts: 8
Dear Friendliest,

Might I suggest getting a new forum username? Because you're a real jerk.

I can't come up with a serious response to that. Your post is so full of contempt that I have to conclude you are either trolling the developer or you're just a naturally angry person. Either way, there's nothing to contribute here.

Regardless, go away.
Marrishka is offline   Reply With Quote
Old 07-18-2012, 06:02 PM   #14
Friendliest
 
Join Date: Jan 2010
Reputation: 822
Posts: 3,971
Quote:
Originally Posted by Marrishka View Post
Dear Friendliest, ... you're a real jerk. ... go away.
I am righteously disappointed in a product I bought and you have exactly one* legitimate basis on which to counter my criticisms, which you chose not to exercise. So, until you do, IMO keep your opinions and name-calling to yourself. And by the way I suggest you read what I write according to its exact literal meaning and stop trying to speculate on connotations.

*Yes, I understand support for Win7x64 is not advertised, but we're talking about something that's A) probably a real simple** fix and B) a FUNDAMENTAL issue; game is basically completely broken until it is fixed. It's like if you bought call of duty and your gun wouldn't shoot! (**hint: the fact that it occurs on 64-bit systems, and only starts happening after the user has played several games, should both be gigantic clues)

visit Nation Red forums and learn how a small "indie" development team should treat their fans. I have literally seen an issue -- one that I submitted -- patched within an hour. Obviously a gold standard and I don't expect this sort of solution for every company/every issue, but... the message I'm getting from these guys is "we don't take ourselves seriously, so neither should you. we just don't feel like fixing this bug. no worries, though, as we already have your money. good day."

what do you expect out of me, in response to that: to send them a "thank you" card and nice a box of chocolates?
Friendliest is offline   Reply With Quote
Old 10-06-2012, 04:38 PM   #15
GaryDefiance
 
 
 
Join Date: Oct 2012
Reputation: 0
Posts: 1
um...

ok, first off Friendliest, you are asking a developer to pay someone to work for 30+ hours to FIND and FIX a bug that is a specific problem with windows 7.
the REASON they cited the other game, was to point out the fairly obvious fact that this game is OVER 4 YEARS OLD, AND NO LONGER PART OF THEIR FOCUS. you are literally like the people who complained that doom didn't work natively in windows 98. the game was released BEFORE WINDOWS 7.

oh, and the fix probably took me less time than it took you to insult some great game developers.
it's called compatability mode. cause you know, when windows 7 has an issue running something, you should always try that first.

instructions:
find your harvest.exe in the steam apps folder.
right click.
go to propeties.
click the compatability tab.
click the checkbox next to "run this program in compatability mode for: (choose version)
Windows XP sp3 worked for me.

see? and that cost alot less than the hundreds of dollars you were demanding for a patch.
GaryDefiance is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > H - L > Harvest: Massive Encounter


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 09:10 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2012, All Rights Reserved.