Go Back   Steam Users' Forums > Steam Discussions > Help and Tips

Reply
 
Thread Tools Display Modes
Old 02-12-2010, 05:25 PM   #1
BCSP
 
Guest
Posts: n/a
Steam connection error

Hi there, hope someone can help with this it's driving me banannas.

I loaded up steam today and started up a game of L4D. I was in a game 3 or 4 minutes until I got disconnected and timed out. Exited the game to find a "connection to steam lost" error or something similiar.

So I restarted steam and now get "Could not connect to steam network" error every time I start. Still have internet access, router setting haven't changed either. I've tried starting in offline mode but still get the same error (eh?!)
I've also tried deleting my clientregistry.blob file and appupdate.blob file too but it doesn't help. After deleting the file steam starts updating then asks me to login but gives me the same error again.

Pretty sure it must be client side as a mate of mine in the same house has no problem connecting.

Help much appreciated at this point.
 
Reply With Quote
Old 02-12-2010, 08:53 PM   #2
Nickanack
 
Guest
Posts: n/a
I too am having this problem.
  Reply With Quote
Old 02-13-2010, 03:43 AM   #3
BCSP
 
Guest
Posts: n/a
Just tried downloading and running steam again with the repair option, still no luck
  Reply With Quote
Old 02-13-2010, 04:05 AM   #4
BCSP
 
Guest
Posts: n/a
Tried logging in with mates account. Still no luck
  Reply With Quote
Old 02-13-2010, 11:33 AM   #5
gjb
 
Guest
Posts: n/a
I have the same. Found another thread on the forum:

http://forums.steampowered.com/forum...php?p=13491313

And for some other guy, and me, removing the steamapps folder (or renaming it) results in steam starting just fine. I'll be testing if it is a specific game tomorrow.
  Reply With Quote
Old 02-14-2010, 03:12 AM   #6
BCSP
 
Guest
Posts: n/a
Hi guys
So, after spending all day making a backup of my steamapps folder (bloody massive). I uninstalled steam and gave it a clean install. Steam started up no bother. Then I copied back in the original steamapps folder and the problem came back. I believe the only file overwritten by copying back in the steamapps folder was winui.gcf

So go to your steamapps folder and delete the winui.gcf file and start up steam. Don't worry about making a backup, steam appears to rebuild the file and start up fine then.

Hope this works for you guys.
  Reply With Quote
Old 02-14-2010, 08:41 AM   #7
gjb
 
Guest
Posts: n/a
Great,

Works for me as well. No need to reinstall steam (which saves backing up all the games, or downloading them again), just remove the wingui.gcf file
  Reply With Quote
Old 11-14-2010, 12:42 PM   #8
punisherXD
 
Guest
Posts: n/a
hey i tried it too but it still has the error
  Reply With Quote
Old 08-29-2011, 08:04 AM   #9
dustonian101
 
Guest
Posts: n/a
uhhhm my steam folder/ steamapps doesn't have a wingui.gcf file

should I be alarmed?
  Reply With Quote
Old 08-29-2011, 12:43 PM   #10
H1ND3NBURG
 
Guest
Posts: n/a
I'm having this same problem, but I can't get into my steamapps folder to delete the winui.gcf file. What do I do?
  Reply With Quote
Old 09-20-2011, 06:07 PM   #11
the working hou
 
Guest
Posts: n/a
If it helps, I just realized mine was doing this cause I was running PeerBlock.
  Reply With Quote
Old 12-21-2011, 07:23 PM   #12
yellokirby
 
Join Date: Nov 2011
Reputation: 0
Posts: 1
yep, mine was also not working because of peerblock. i simply disabled it, and steam connected perfectly again.
yellokirby is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Discussions > Help and Tips


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 02:27 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2012, All Rights Reserved.