Go Back   Steam Users' Forums > Steam Game Discussions > M - P > Metro 2033

Reply
 
Thread Tools Display Modes
Old 03-16-2010, 11:01 AM   #1
HedgeZ
 
Guest
Posts: n/a
Fix for "Executable not Working".

Cause of error:
DirectX saying X3DAudio1_7.dll is missing, thus blocking
the game from starting up.

Solution to error:
Go to the following website :
http://www.microsoft.com/downloads/d...displaylang=en

Click download.

This will download the DirectX update.
Launch the dxwebsetup.exe and it will download the missing file
as well as any updates.


You may now successfully launch the game and play to your hearts
content.

Your Welcome ^^

Edit: This fix is for people, like myself, that were unable to simply launch the game. If your Metro2033.exe is crashing whilst in-game, well that's another issue. Since it hasn't happened to me, I am unable to come up with a certain fix. However I would assume that your graphic driver is out-of-date, since this is an issue that happens to many people over many games, due to people not checking for new driver releases from time to time. Best of luck.

Last edited by HedgeZ: 03-27-2010 at 02:15 AM.
 
Reply With Quote
Old 03-16-2010, 03:59 PM   #2
liho1eye
 
 
 
Join Date: Feb 2009
Reputation: 104
Posts: 1,803
didn't help me...

edit: restarting a few times did

Last edited by liho1eye: 03-16-2010 at 04:10 PM.
liho1eye is offline   Reply With Quote
Old 03-22-2010, 02:44 PM   #3
Shirky
 
Join Date: Aug 2009
Reputation: 0
Posts: 60
This helped me by getting to the logo screen then before it finished it crashed, I have restarted my computer and steam several times, still crashs, any help?
Shirky is offline   Reply With Quote
Old 03-22-2010, 03:24 PM   #4
Pinbag
 
Guest
Posts: n/a
Well i found my fix ...

Desactivate the physix
and now it works super

very strange...
  Reply With Quote
Old 03-23-2010, 06:42 PM   #5
M.i.S. Nemesis
 
Guest
Posts: n/a
Quote:
Originally Posted by Pinbag View Post
Well i found my fix ...

Desactivate the physix
and now it works super

very strange...
How do you deactivate the Physx?
  Reply With Quote
Old 03-24-2010, 01:37 AM   #6
Pinbag
 
Guest
Posts: n/a
Quote:
Originally Posted by Pinbag View Post
Well i found my fix ...

Desactivate the physix
and now it works super

very strange...
I noticed the same.

Strange thing is he did a syncro with a warning all my saves could be lost the next day... I did a syncro to check my data was genuine. => everything ok

And i have played a full day without the damn error showing up after x-time i reanabled the physix .

It worked withour issiue's for 8 hours.

And gues what i had again yesterday night when i entered the outpost ...

Executable not working ....

Im back to square one.


The weirdest is i have a xfx gtx 295
4gig ram and a quad core processor ....

I can run Alien Vs predator 2 on max and Napoleon Total War.
But not Metro 2033

I hope some patch will deliver us of this frustrating moments..

Because i realy like this game !!!
  Reply With Quote
Old 03-24-2010, 01:37 AM   #7
Pinbag
 
Guest
Posts: n/a
Quote:
Originally Posted by M.i.S. Nemesis View Post
How do you deactivate the Physx?
Under game options i believe.
  Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > M - P > Metro 2033


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 08:49 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2012, All Rights Reserved.