Go Back   Steam Users' Forums > Steam Game Discussions > # - C > Battlefield series

Reply
 
Thread Tools Display Modes
Old 03-22-2010, 10:26 PM   #1
kofine10
 
Guest
Posts: n/a
playing with a friend on the same internet connection problem

my house mate and i have with success played bad company 2 online together for the past two weeks until a few evenings ago. The problem was we were both getting kicked whenever the other tried to join the game. If it is just one of us trying to play online we have no problems. We both cant be playing on separate servers either. We reset the router to get a different ip address which worked. we played a few games together on 1 server. After a while the people on our team were constantly complaining so we left to join another server. In trying to connect to the server we both were experiencing kick issues again. Anyone else having this problem or know how to fix it?
 
Reply With Quote
Old 03-22-2010, 11:43 PM   #2
Quadmeister
 
Guest
Posts: n/a
Quote:
Originally Posted by kofine10 View Post
my house mate and i have with success played bad company 2 online together for the past two weeks until a few evenings ago. The problem was we were both getting kicked whenever the other tried to join the game. If it is just one of us trying to play online we have no problems. We both cant be playing on separate servers either. We reset the router to get a different ip address which worked. we played a few games together on 1 server. After a while the people on our team were constantly complaining so we left to join another server. In trying to connect to the server we both were experiencing kick issues again. Anyone else having this problem or know how to fix it?
1. Make sure you have DHCP is ENABLED on your router.
2. Make sure both PCs are set to AUTOMATIC IP. This means that you are not statically assigning an IP to each PC.
3. Make sure you have uPnP ENABLED on your router. This will automatically OPEN the ports needed for each PC.
4. Once you do this, make sure you RESTART your router and PCs.


Id recommend restoring your modem to factory default, then resetting it as above.

found that in the EA forums. hope it helps.
  Reply With Quote
Old 03-23-2010, 12:00 AM   #3
TartanCowboy
 
Guest
Posts: n/a
Quote:
Originally Posted by Quadmeister View Post
1. Make sure you have DHCP is ENABLED on your router.
2. Make sure both PCs are set to AUTOMATIC IP. This means that you are not statically assigning an IP to each PC.
3. Make sure you have uPnP ENABLED on your router. This will automatically OPEN the ports needed for each PC.
4. Once you do this, make sure you RESTART your router and PCs.


Id recommend restoring your modem to factory default, then resetting it as above.

found that in the EA forums. hope it helps.

Correct in some ways but this is not the issue

The issue is that you need each Bad Company to use Different ports. give it a goole search.. i read it someplace i forgot where now.. i'm sorry... but you need BC2 to use a differant port
  Reply With Quote
Old 03-23-2010, 12:13 AM   #4
zomgzomg
 
Join Date: May 2009
Reputation: 42
Posts: 1,082
I can't really say what's wrong here, but the advice given seems to be based on random guessing and not understanding how NAT routing works...

1: DHCP and automatic IP on PCs should have absolutely no effect. If you have static IP addresses in your LAN, it has absolutely no effect on how the outside network perceives it.
2: Using different ports does not matter. NAT routing uses a bit flag in the IP packets to tell what IP address they should go.
zomgzomg is offline   Reply With Quote
Old 03-23-2010, 01:42 AM   #5
Lojen
 
Guest
Posts: n/a
Yeah I have this same problem. If my partner joins while I am already playing I will get kicked, and vice versa. Happens I guess about 80% of the time.

All we can do is rejoin after being kicked and that seems to work ok, in so much as the kick only seems to happen the first time and reconnecting does not kick again.

Sadly I haven't been able to fix this myself so would be interested to hear any other suggestions (have already done everything suggested above).
  Reply With Quote
Old 03-23-2010, 01:48 AM   #6
ziggo0
 
Join Date: Jun 2004
Reputation: 46
Posts: 1,110
^^^pretty much.

I had a buddy over for a week and we ran into this same issue. DHCP was on for him but I used a static IP and ports forwarded to myself. I had to un-enable those ports and turn on upnp to even let him login. After this he would find a server, I'd connect, it would boot him but I'd get in and he would simply rejoin.
ziggo0 is offline   Reply With Quote
Old 03-24-2010, 01:40 AM   #7
thet3rminat0r
 
Guest
Posts: n/a
Right-click on the shortcut you start the game with and select properties.
In the target line add +set net_port 18126
Do the same on the second pc but use a different port like +set net_port 18127 this can be used for an unlimited amount of computers just make sure the port is allowed through your router. if yours is steam right-click on game select properties then go to launch options and copy paste the +set net_port 18126 there.
  Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > # - C > Battlefield series


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 10:33 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.