Go Back   Steam Users' Forums > Steam Game Discussions > D - G > Deus Ex series

Reply
 
Thread Tools Display Modes
Old 04-20-2010, 07:14 PM   #1
WholeWheat
 
Guest
Posts: n/a
Crash on startup

I just bought Deus Ex and the game crashes on start up. No error messages show up except for "Deus Ex has stopped working" I can get the game to run in safe mode for a few minutes before it freezes. I have tried multiple renderers and other fixes but nothing works. Any help would be appreciated.

Specs:
Windows 7 64bit
Intel core 2 duo
nvidia 9600 gt
4 gigs of ram
 
Reply With Quote
Old 04-20-2010, 07:29 PM   #2
x0rsw1tch
 
Join Date: Jul 2006
Reputation: 25
Posts: 75
I can manage to get to the main menu, then the game freezes. Have to kill the process.

WindowsXP
Athlon64 3800x2 @ 2.5
3GB DDR400
GeForce 9600GT
x0rsw1tch is offline   Reply With Quote
Old 04-20-2010, 08:11 PM   #3
Z3R0OneOneSe7en
 
Join Date: Sep 2009
Reputation: 13
Posts: 214
also have same problem

stats

(CPU1) Intel® Core™2 Duo CPU T5550 @ 1.83GHz @ 1833MHz (Gateway P-6860FX mainboard) (RAM) 4GB, 1.69GB free (HDDs) 298GB, 41.3GB free (VGA1) NVIDIA GeForce 8800M GTS (512MB), 1440x900x32, 60Hz (OS) Microsoft® Windows Vista™ Home Premium (SP2) 64-bi
Z3R0OneOneSe7en is offline   Reply With Quote
Old 04-20-2010, 10:19 PM   #4
LlamaNL
 
 
 
Join Date: Apr 2008
Reputation: 72
Posts: 378
same here
Win7 64bit
Athlon 64x2 4400
hd3870
LlamaNL is offline   Reply With Quote
Old 04-20-2010, 10:41 PM   #5
LlamaNL
 
 
 
Join Date: Apr 2008
Reputation: 72
Posts: 378
messed with some different renderers, the only one that doesn't crash straight to desktop is the d3d10 one but that one doesn't go further then a black screen
LlamaNL is offline   Reply With Quote
Old 04-21-2010, 06:59 AM   #6
juniorcba
 
 
 
Join Date: Oct 2009
Reputation: 0
Posts: 7
Same here...

C2D E7400@3GHz
5GB RAM@900MHz
Gigabyte EP45-UD3L
GeForce 9600GT
Win7 64bits Ultimate
juniorcba is offline   Reply With Quote
Old 04-21-2010, 07:13 AM   #7
sleepydragy
 
Join Date: Mar 2009
Reputation: 4
Posts: 398
you bought a game that was made for windows 95/98 and your questioning why its crashing?
sleepydragy is offline   Reply With Quote
Old 04-21-2010, 08:59 AM   #8
Z3R0OneOneSe7en
 
Join Date: Sep 2009
Reputation: 13
Posts: 214
Quote:
Originally Posted by Z3R0OneOneSe7en View Post
also have same problem

stats

(CPU1) Intel® Core™2 Duo CPU T5550 @ 1.83GHz @ 1833MHz (Gateway P-6860FX mainboard) (RAM) 4GB, 1.69GB free (HDDs) 298GB, 41.3GB free (VGA1) NVIDIA GeForce 8800M GTS (512MB), 1440x900x32, 60Hz (OS) Microsoft® Windows Vista™ Home Premium (SP2) 64-bi
fixed it


i went to the DEP panel and turn it off for Deus Ex..now it runs like a dream
Z3R0OneOneSe7en is offline   Reply With Quote
Old 04-21-2010, 09:03 AM   #9
RuinationMkII
 
Guest
Posts: n/a
Quote:
Originally Posted by sleepydragy View Post
you bought a game that was made for windows 95/98 and your questioning why its crashing?
Cause Steam is offering it in a time when no one uses those OSs? One would assume that they got it to run on current software/hardware. We don't want to believe that Steam would steal from us.
  Reply With Quote
Old 04-21-2010, 03:50 PM   #10
Bulletzen
 
Join Date: Sep 2007
Reputation: 24
Posts: 120
Quote:
Originally Posted by Z3R0OneOneSe7en View Post
fixed it


i went to the DEP panel and turn it off for Deus Ex..now it runs like a dream
Forgive my ignorance but what is the DEP panel? I have exactly the same issues as poster #1 and it's starting to irritate.

Specs:
Windows 7 64bit
Intel Quad core 6700
ATI Radeon 4870x2
4 gigs of ram
Bulletzen is offline   Reply With Quote
Old 04-21-2010, 09:44 PM   #11
Theshado
 
Join Date: Dec 2009
Reputation: 0
Posts: 82
May I all so ask what the Dep panel as I am not 100% sure what that is

Vista
Crash when sound comes on...

So I have to press new game before the music comes on...
Theshado is offline   Reply With Quote
Old 04-22-2010, 02:27 AM   #12
Revenile
 
Join Date: Aug 2009
Reputation: 6
Posts: 63
Ok, the DEP disable fix does work, it fixed my problem. The DEP is the thing that watches all programs that use memory to make sure they aren't up to something. To disable it (on windows 7 anyway) do the following:

Right click the Computer icon and click properties

Click the "Advanced system settings" link on the left side.

It should be on the "advanced" tab, click "settings" in the Performance box.

Go to the "Data Execution Prevention" tab

Click the "Add" button

Add Deus Ex's exe to the list

Click ok

click apply and ok

close everything out

Play the game, it should work now, it fixed my problem.
Revenile is offline   Reply With Quote
Old 04-22-2010, 07:03 AM   #13
Theshado
 
Join Date: Dec 2009
Reputation: 0
Posts: 82
I enter the name in it just said there is no file name that..
Theshado is offline   Reply With Quote
Old 04-22-2010, 02:54 PM   #14
Theshado
 
Join Date: Dec 2009
Reputation: 0
Posts: 82
Yea any one nkow the true name for the files as Deus Ex.exe is now allowed
Theshado is offline   Reply With Quote
Old 04-22-2010, 03:41 PM   #15
aeroa1
 
Join Date: Jul 2009
Reputation: 2
Posts: 100
The running file is called DX2Main.exe
CAn anyone tell me how to do this on XP? I right clicked on My Computer and it gives me the tabs "System Restore (obviously not...), Automatic Updates (obvious again...) Remote (pretty sure its not), General (nope), Computer Name (yeah...) Hardware, and Advanced... First guess was Advanced... So in that I have Performance, User Profiles, and Startup and Recovery... any advice on how to do this for me?? Cuz I don't think it is in any of those...
aeroa1 is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > D - G > Deus Ex series


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 10:37 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.