Go Back   Steam Users' Forums > Steam Game Discussions > D - G > Grand Theft Auto series

Reply
 
Thread Tools Display Modes
Old 05-04-2010, 08:27 AM   #1
jtm33
 
 
 
Join Date: Feb 2008
Reputation: 36
Posts: 472
GTAIV FATAL ERROR: Windows Vista: Need to have Service Pack 1 or higher to proceed.

Getting this error upon launch: GTAIV FATAL ERROR RMN20: Windows Vista: Need to have Service Pack 1 or higher to proceed.

How can I fix this? I have tried verifying cache and reinstalling to no effect. Game was working perfectly fine until a few days ago.
jtm33 is offline  
Reply With Quote
Old 05-04-2010, 08:41 AM   #2
jtm33
 
 
 
Join Date: Feb 2008
Reputation: 36
Posts: 472
yeah compatibility mode does work, but I want to know why this just randomly started happening a few days ago. I would like to be able to use steam community in-game and launch it without using compatibility.
jtm33 is offline   Reply With Quote
Old 11-29-2010, 03:23 AM   #3
Peter4real
 
Guest
Posts: n/a
same thing here

But I got windows 7 so I dont know why it doesnt work. But im trying to download service pack 1 for windows 7. So if that doesnt work Steam will hear from me!
  Reply With Quote
Old 03-06-2011, 11:03 AM   #4
ramy32
 
Guest
Posts: n/a
Yeah, what gives? I'm running Windows 7, not vista... Why do I get this error? How can I contact steam about this?
  Reply With Quote
Old 03-06-2011, 11:39 AM   #5
Narchotic
 
Guest
Posts: n/a
Sounds like Steam has got its self stuck in compatabilty mode.

This is how I and others have managed to fix it:

1. Hit start->run->regedit
2. Go to key: HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers
3. Look for a entry with your path to steam.exe
4. Delete that entry
5. If you dont find it there try HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers

You should also be able to launch the game via the gta exe located in steamapps > common > GTAIV without the need to mess with the registry, or the need to have Steam running. Steam will still be stuck in compatibility mode, though.
  Reply With Quote
Old 09-03-2011, 09:13 AM   #6
Yablo
 
Join Date: Nov 2009
Reputation: 0
Posts: 18
I am also getting this error. I deleted the registry entry with the path to steam.exe with no resolution. I am also on windows 7
Yablo is offline   Reply With Quote
Old 09-03-2011, 11:23 AM   #7
Mgp
 
 
 
Join Date: Nov 2009
Reputation: 57
Posts: 839
Quote:
Originally Posted by Narchotic View Post
Sounds like Steam has got its self stuck in compatabilty mode.

This is how I and others have managed to fix it:

1. Hit start->run->regedit
2. Go to key: HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers
3. Look for a entry with your path to steam.exe
4. Delete that entry
5. If you dont find it there try HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers

You should also be able to launch the game via the gta exe located in steamapps > common > GTAIV without the need to mess with the registry, or the need to have Steam running. Steam will still be stuck in compatibility mode, though.
this.
Mgp is offline   Reply With Quote
Old 09-23-2011, 08:00 PM   #8
snypes
 
Join Date: May 2009
Reputation: 4
Posts: 143
i need to bump this because im not sure what to do. help please!
snypes is offline   Reply With Quote
Old 09-23-2011, 08:07 PM   #9
snypes
 
Join Date: May 2009
Reputation: 4
Posts: 143
id also like to say i have windows 7 (service pack 1) and im getting this error! i just got the game today, please help bros!
snypes is offline   Reply With Quote
Old 09-24-2011, 11:02 AM   #10
Fedoteh
 
 
 
Join Date: Dec 2010
Reputation: 0
Posts: 63
Bump. I've got the same error today. What is going on? Anyone tried reinstalling Steam?
Fedoteh is offline   Reply With Quote
Old 09-24-2011, 11:21 AM   #11
Fedoteh
 
 
 
Join Date: Dec 2010
Reputation: 0
Posts: 63
Well, i did the compatibility and now it works. Today i desinstalled a few games from Steam, and it said me something strange. I don't remember the message, but i ignore it and everything works fine, except this. I put compatibility with Windows 7, and now it works. Maybe later i'd try reinstalling steam.
Fedoteh is offline   Reply With Quote
Old 09-25-2011, 03:16 AM   #12
Gamer1014
 
Join Date: May 2010
Reputation: 8
Posts: 52
Had the same problem and I have Windows 7 pro w/SP1 was able to fix here is what I did not sure if this will help but give it a try
1. Open your Grand theft Auto IV EFLC folder this is usually located in C:\Program Files x86\steam\steamapps\common\grandtheft auto iv episodes from liberty city\EFLC folder
2. select the LaunchEFLC.exe dont double click it just select it once then right click it
3. Next select at the bottom Properties
4. Now select the Compatibility tab
5. Next you will probably need to select the unchecked box for compatibility mode then select the drop down box and select window 7 or vista if thats what you have.

Not sure why this happened but this fixed it for me and can run it through steam menu. Hope this helps some of you

Be sure to click the apply button too when you change the compatibility just to be safe
Gamer1014 is offline   Reply With Quote
Old 11-28-2011, 08:48 PM   #13
dropblack
 
Join Date: Nov 2011
Reputation: 0
Posts: 7
I've been experiencing this problem as well. I tried the following:

5. If you dont find it there try HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers

But it didn't work. When I deleted the entry I was given a warning message that I might experience some stability issues. Can anyone tell me if I should be concerned?

I've since tried running Rage and it crashes every time I try to open it, but I suspect that is a different issue...
dropblack is offline   Reply With Quote
Old 12-20-2011, 02:04 PM   #14
Bear809
 
 
 
Banned
Join Date: Dec 2011
Reputation: 51
Posts: 850
I have this issue too, bump!
Bear809 is offline   Reply With Quote
Old 12-23-2011, 11:15 AM   #15
Mclovin300
 
Join Date: Feb 2010
Reputation: 7
Posts: 65
I've got windows 7 and found an easy fix for this. It turned out steam was running in windows vista compatibility mode. This is how to fix it.

1. Right click your steam shortcut.
2. Click on properties.
3. Choose the compatibility tab.
4. Make sure the compatibility mode box is NOT checked.
5. Restart Steam

Your game should be working now. This happened to me about a month ago I have no idea why. Some update must have messed things up. Hopefully this helps all of you.
Mclovin300 is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > D - G > Grand Theft Auto series


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 08:16 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2012, All Rights Reserved.