Go Back   Steam Users' Forums > Steam Discussions > Steam for Mac > Source games

Reply
Click here to go to the first staff post in this thread.  
Thread Tools Display Modes
Old 05-12-2010, 06:16 PM   #1
RUSBoris
 
Join Date: Feb 2005
Reputation: 8
Posts: 834
[How-To] - Increase GFX quality and get 50-60 FPS with less tearing

I was getting really bad FPS with default settings on my 9600GT.

To fix this, I use these settings: http://img28.imageshack.us/i/portali.png/

Basically, the default settings enable color correction and Vsync. Both of these lower FPS (Vsync on purpose does this to prevent tearing). Color correction not only lowers FPS, but makes textures blurry.

If you remove Vsync, you will get smooth gameplay but the tearing will be unbearable. What you want to do is increase the graphics enough so that your FPS is acceptable but minimizes tearing due to the FPS.

With these settings, I went from 10-30 FPS to 50-60 FPS with slightly better graphics and AF. There is still some tearing but it's much much better and playable. Give it a try
RUSBoris is offline  
Reply With Quote
Old 05-12-2010, 06:26 PM   #2
gentlem
 
Join Date: Jul 2009
Reputation: 71
Posts: 783
Many tanks! I haven't really tried out portal yet (figured I should get my work done first) but I'm sure this will come in handy.

Thanks!
gentlem is offline   Reply With Quote
Old 05-12-2010, 06:27 PM   #3
Kralec
 
Guest
Posts: n/a
I have a Nvidia Geforce 9400M, should I get the same results if I use these settings?
  Reply With Quote
Old 05-12-2010, 06:31 PM   This is the last staff post in this thread.   #4
rbarris
 
Join Date: Apr 2010
Reputation: 1265
Posts: 1,026
This is good info, we really appreciate the experimentation. Some great insights here.
rbarris is offline   Reply With Quote
Old 05-12-2010, 06:31 PM   #5
njpunker23
 
Guest
Posts: n/a
Great tip RUSBoris I can confirm that the above settings have increased texture quality and FPS. With little to no 'tearing' on a unibody MBP 2.93 Ghz, 9600M GT, 4 GB 1067 DDR3
  Reply With Quote
Old 05-12-2010, 06:32 PM   #6
drunkugly
 
 
 
Join Date: Jan 2009
Reputation: 9
Posts: 362
this all seems to work great for nvidia cards. not so much with ati cards. i get good frame rates until i enter a room with water, then its a slide show. the only fix i found was to go from widescreen to 4:3 ratio and up the fov to 90. this doubled my frame rates in water rooms to a whopping 25 fps. this makes me very afraid for the likelihood of l4d2 running at all. congrats to you nvidia people.
drunkugly is offline   Reply With Quote
Old 05-12-2010, 06:36 PM   #7
RUSBoris
 
Join Date: Feb 2005
Reputation: 8
Posts: 834
Quote:
Originally Posted by drunkugly View Post
this all seems to work great for nvidia cards. not so much with ati cards. i get good frame rates until i enter a room with water, then its a slide show. the only fix i found was to go from widescreen to 4:3 ratio and up the fov to 90. this doubled my frame rates in water rooms to a whopping 25 fps. this makes me very afraid for the likelihood of l4d2 running at all. congrats to you nvidia people.
Try reducing or turning off reflections. Sounds like it should resolve that

Quote:
I have a Nvidia Geforce 9400M, should I get the same results if I use these settings?
No, but the same concept should apply.

Turn off Vsync and color correction, and then adjust other graphical settings until you get a good balance of smooth FPS and tearing. If it's confusing for you, you could start with the settings I use in the screenshot, but your FPS will likely be too low. Try turning AF to 0 and put the shaders on low, and lowering other settings until you get decent FPS

Last edited by RUSBoris: 05-12-2010 at 06:41 PM.
RUSBoris is offline   Reply With Quote
Old 05-12-2010, 06:51 PM   #8
Kralec
 
Guest
Posts: n/a
I used the exact same settings and I'm getting silky smooth framerates, thanks!
  Reply With Quote
Old 05-12-2010, 06:55 PM   #9
digwagner
 
Guest
Posts: n/a
This worked very well for me. I went from running medium texture detail and getting around 25 to 30 FPS to running very high detail at native (1440x900) resolution. Everything runs smooth averaging at around 40-50 FPS except for portals in only certain locations cause my FPS to drop to about 4. Half of the time, portals will work fine, usually bringing my FPS to around 30 at lowest, but the other half of the time it drops my FPS to 4. Any idea what causes this?
  Reply With Quote
Old 05-12-2010, 06:57 PM   #10
RUSBoris
 
Join Date: Feb 2005
Reputation: 8
Posts: 834
Quote:
Originally Posted by digwagner View Post
This worked very well for me. I went from running medium texture detail and getting around 25 to 30 FPS to running very high detail at native (1440x900) resolution. Everything runs smooth averaging at around 40-50 FPS except for portals in only certain locations cause my FPS to drop to about 4. Half of the time, portals will work fine, usually bringing my FPS to around 30 at lowest, but the other half of the time it drops my FPS to 4. Any idea what causes this?
Guess they'll work on optimizing this in future updates. For now all you can really do is lowering the portal # in the first window in the settings menu.
RUSBoris is offline   Reply With Quote
Old 05-12-2010, 07:01 PM   #11
heretic5
 
Guest
Posts: n/a
Anyone else have a big framerate drop in rooms with water? Recommended setting was "reflect all" but even on "simple reflections" the framerate takes a hit. The game also seems to stutter a lot. New graphics drives Apple/ATI/nVidia please,ok, thank you.

EDIT: Just saw drunkugly's post. At least I'm not alone :/

Last edited by heretic5: 05-12-2010 at 07:04 PM.
  Reply With Quote
Old 05-12-2010, 07:03 PM   #12
RUSBoris
 
Join Date: Feb 2005
Reputation: 8
Posts: 834
Quote:
Originally Posted by heretic5 View Post
Anyone else have a big framerate drop in rooms with water? Recommended setting was "reflect all" but even on "simple reflections" the framerate takes a hit. The game also seems to stutter a lot. New graphics drives Apple/ATI/nVidia please,ok, thank you.
For stuttering: how much RAM do you have? To have a stutter free experience you should have 4-6GB.

If you have less, lower the graphic settings (namely textures)
RUSBoris is offline   Reply With Quote
Old 05-12-2010, 07:10 PM   #13
heretic5
 
Guest
Posts: n/a
Quote:
Originally Posted by RUSBoris View Post
For stuttering: how much RAM do you have? To have a stutter free experience you should have 4-6GB.

If you have less, lower the graphic settings (namely textures)
2 gig ram. The thing is, this game runs flawless on max settings at my native res in bootcamp. Now, on OSX, I'm struggling to make it run decent on lower settings. I understand this is new and it will be patched and apple has already announced better openGL performance in the next update which should help, it's just kinda frustrating that it runs considerably worse than it does on "the other side".
  Reply With Quote
Old 05-12-2010, 07:16 PM   #14
Zhazelmyer
 
Join Date: Apr 2010
Reputation: 11
Posts: 69
Well, I'm rolling 8 gig o' ram, and my iMac is running the HD4670, and I'm getting some choppiness and terrible FPS. I've got portals down to nil, and anything that doesn't like to cooperate with openGL I've got disabled (anti-aliasing/vertsync), also my reflections are minimal, so this is strange. Any other suggestions/optimizations I can move towards to make this any easier?

Also, my sound just cut out. No idea why.
Zhazelmyer is offline   Reply With Quote
Old 05-12-2010, 07:21 PM   #15
drunkugly
 
 
 
Join Date: Jan 2009
Reputation: 9
Posts: 362
yeah, my reflections settings are as low as they can go.
do you have an ati card heretic5? just wondering if there's a pattern here.
drunkugly is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Discussions > Steam for Mac > Source games


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 10:55 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.