Go Back   Steam Users' Forums > Steam Discussions > Steam for Mac > Source games

Reply
 
Thread Tools Display Modes
Old 05-12-2010, 09:15 PM   #1
victori
 
Join Date: May 2010
Reputation: 0
Posts: 78
Post your Portal FPS / Mac Setup

Since majority of the posts are "issue posts", I just want to say that Portal runs perfect here on my mac pro; no visual glitches or any bugs noticed.

MacPro: 3.0ghz (Quad) / Geforce 8800GT / 8 Gigs Ram
Mac OS X 10.6.3

250 fps max
150 fps average
60 fps low

Settings: All High - 4xAA / 16xAnisotropic - windowed 1027x768 res

Good job in optimizing the source engine for OpenGL. The performance is much better than what I experienced with codeweavers wine.

Last edited by victori: 05-12-2010 at 10:47 PM.
victori is offline  
Reply With Quote
Old 05-12-2010, 09:23 PM   #2
travislopes
 
Join Date: May 2009
Reputation: 142
Posts: 151
Aluminum MacBook: 2.4GHz C2D / GeForce 9400M / 4GB RAM

35 fps max
25 fps average
15 fps low
travislopes is offline   Reply With Quote
Old 05-12-2010, 09:35 PM   #3
Sambo110
 
 
 
Join Date: Nov 2008
Reputation: 25
Posts: 642
20" iMac, 2.4ghz Core 2 Duo, Ati Radeon 2400HD Mobility, I get about 20-35 FPS, not entirely sure of the settings. Wish it ran better, but CS:S I know exactly how well it runs in Windows, so will be interesting to see that.
Sambo110 is offline   Reply With Quote
Old 05-12-2010, 09:38 PM   #4
poopdedoop78
 
Guest
Posts: n/a
MacPro1,1 2.66GHz 6GB ram, HD4870 1GB GFX

max 50fps
min 12fps

this is a ton worse compared to in windows (boot camp on the same machine)

max ~200-250pfs
min 70fps
  Reply With Quote
Old 05-12-2010, 09:49 PM   #5
DMXell
 
Guest
Posts: n/a
Macbook Pro (late 2008)
2.4 GHz, 2 GB DDR3 SDRAM, Nvidia 9600m GT 256MB

1280x800, all settings maxed with 0x AA and no Motion Blur

Max 60 fps (vertical sync enabled)
Min 6 fps (water + portal funnels with a few apps running in the background, like Google Chrome)

Compared to Windows this is rather bad. In Windows I could push 1080p, max settings, 8x AA and still get never dip below 60 fps.
  Reply With Quote
Old 05-12-2010, 10:02 PM   #6
Patchumz
 
Join Date: May 2010
Reputation: 2
Posts: 138
I'm just going to keep passing this information on, You get MUCH worse performance because Apple's graphics card drivers are horrible and outdated. We are having the same issue with the StarCraft II Beta, and that's what they've told us is the problem. (It's an OpenGL thing)
Patchumz is offline   Reply With Quote
Old 05-12-2010, 10:21 PM   #7
yokken
 
Guest
Posts: n/a
First-gen Unibody MBP, 2.4GHz, 4GB DDR3, 9400M (256mb shared vram)

High: 40fps
Avg: 30fps
Low: 20fps

Everything on low except medium textures. No vsync.
  Reply With Quote
Old 05-12-2010, 10:26 PM   #8
kroqben
 
Guest
Posts: n/a
could you guys post os version as well? i think the problems i've seen (and am experiencing) are limited to 10.5.8...
  Reply With Quote
Old 05-13-2010, 02:29 AM   #9
Ausl0
 
 
 
Join Date: Dec 2007
Reputation: 3
Posts: 18
13" Unibody MacBook Pro: 2.26GHz C2D / Nvidia Geforce 9400M / 4 Gigs Ram
Mac OS X 10.6.3

50 fps max
35 fps average
25 fps low

Settings: All Max - 0xAA, No VSync, No Color Correction, No Motion Blur / Trilinear Filtering - Fullscreen 1280x800

I get pretty comparable results from using bootcamp.
Ausl0 is offline   Reply With Quote
Old 05-13-2010, 03:04 AM   #10
smogsy
 
Join Date: Aug 2006
Reputation: 0
Posts: 176
MacPro 2009 : 2.26ghz (octcore) / ATI 4870/ 12GB ram
Mac OS X 10.6.3

100 fps max
90fps average
40 fps low

Settings: All High+very high - 4xAA / 16xAnisotropic -Fullscreen 2560x1600 res
smogsy is offline   Reply With Quote
Old 05-13-2010, 03:26 AM   #11
jeanlain
 
Join Date: Mar 2010
Reputation: 242
Posts: 967
Quote:
Originally Posted by poopdedoop78 View Post
MacPro1,1 2.66GHz 6GB ram, HD4870 1GB GFX

max 50fps
min 12fps

this is a ton worse compared to in windows (boot camp on the same machine)

max ~200-250pfs
min 70fps
What are your screen res and settings?
I basically have the same system (flashed sapphire) but I get better results.
1050*1680, high settings, 2x AA, 4x AF, no blur, no color correction.
max 150 (300 under windows)
min 30-40 in some large rooms with water and open portals (I think it's 80-90 under windows)
most of the time over 60 (I have Vsync enabled)
So I basically get 50% of the framerate I have under bootcamp (xp).

The 8800GT seems to handle the game better, from the report we see. But the 4870 should be more powerful.

Last edited by jeanlain: 05-13-2010 at 06:03 AM.
jeanlain is offline   Reply With Quote
Old 05-13-2010, 03:26 AM   #12
jeanlain
 
Join Date: Mar 2010
Reputation: 242
Posts: 967
Quote:
Originally Posted by victori View Post
Since majority of the posts are "issue posts", I just want to say that Portal runs perfect here on my mac pro; no visual glitches or any bugs noticed.

MacPro: 3.0ghz (Quad) / Geforce 8800GT / 8 Gigs Ram
Mac OS X 10.6.3

250 fps max
150 fps average
60 fps low

Settings: All High - 4xAA / 16xAnisotropic - windowed 1027x768 res

Good job in optimizing the source engine for OpenGL. The performance is much better than what I experienced with codeweavers wine.
Out of curiosity, why don't you push the resolution a bit higher?

Last edited by jeanlain: 05-13-2010 at 04:56 AM.
jeanlain is offline   Reply With Quote
Old 05-13-2010, 03:28 AM   #13
jeanlain
 
Join Date: Mar 2010
Reputation: 242
Posts: 967
Quote:
Originally Posted by Patchumz View Post
I'm just going to keep passing this information on, You get MUCH worse performance because Apple's graphics card drivers are horrible and outdated.
Well, technically they're not outdated. They are as recent as OS X 10.6.3, for better or worse (likely worse).
jeanlain is offline   Reply With Quote
Old 05-13-2010, 03:36 AM   #14
WinstonChurchil
 
Join Date: Nov 2004
Reputation: 47
Posts: 438
Macbook Pro from 2009
- 2.8ghz
- 9600M
- 4GB DDR3 ram

Settings:

- res 1920x1200
- 2x AA and 2x AF
- everything else on high (or very high, where possible)

Haven't played much yet, but the intro map (where you start) gives me an average of 19fps.

The exact same settings on that same macbook pro on win7 and dx9 render the very same level at an average of 35fps.
WinstonChurchil is offline   Reply With Quote
Old 05-13-2010, 03:40 AM   #15
Hydrus
 
Guest
Posts: n/a
On my Imac 8,1, 2.4 Ghz, ATI HD2400 with 1 GB of Ram I get a Pathetic Frame rate even at all Settings on low, Granted i decided to try it in Native Resolution. and in Rooms with the Toxic Water it causes it to go into Slide show mode which in this game is absolutely Infuriating. I dont have an Exact read out on the FPS because i didn't bother to do that, The Game is practically un playable on OSX where as on windows i can actually run the Game in native Resolution and on Max Graphics Save for AA And Get a solid 40 - 50 FPS. This really in all Honesty Makes me sad (but not as sad as the Lack of TF2)
  Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Discussions > Steam for Mac > Source games


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 06:53 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.