Go Back   Steam Users' Forums > Steam Discussions > Help and Tips

Reply
 
Thread Tools Display Modes
Old 05-13-2010, 01:03 PM   #1
Psychotronic
 
Join Date: Sep 2007
Reputation: 0
Posts: 18
Help With Sideways Screen

Attempting to play TF2 on my work laptop (which means that I am unable to upgrade the vid card, so don't suggest that as a fix, please), which is:

Dell Latitude E4300
XP Pro SP3
P9600 @ 2.53 GHz
2 GB RAM
onboard Intel video GMA 4500 1 GHZ
run at 1280 x 800

So, yeah -- I know it won't be great at it, but I'll get to play on my lunch hour occasionally, right?

The game loads SIDEWAYS -- i.e.: what should be the TOP is on the left side. The Windows fix (ctr-alt-arrow) just flips it 180 degrees, so it's never right side up. Other Steam games (admittedly, older ones such as CS) that I've tried work fine.

Any ideas on how to fix this problem???? I looked but could not find a solution. Thanks!
Psychotronic is offline  
Reply With Quote
Old 05-15-2010, 10:31 AM   #2
Psychotronic
 
Join Date: Sep 2007
Reputation: 0
Posts: 18
28 views and no ideas, eh? Hmmm...
Psychotronic is offline   Reply With Quote
Old 05-15-2010, 10:41 AM   #3
TheMG
 
TheMG's Avatar
 
Volunteer Moderator
Join Date: Mar 2007
Reputation: 1899
Posts: 10,283
Can you grab a screenshot of that? I'm not 100% sure what you're trying to describe. Never heard of any problem like it before.
TheMG is offline   Reply With Quote
Old 05-15-2010, 11:21 AM   #4
Sgt_Hawk
 
Guest
Posts: n/a
Have you tried playing in windowed mode?
You can do this one fo two ways, one would be to start Team Fortress 2 and go into options, video, then on the right hand side(or bottom in your case) you should see an option that says "fullscreen", try changing that to "Play in a window".(It may also be a good idea to lower TF2's resolution aswell, but that's your choice.)
  Reply With Quote
Old 05-15-2010, 11:48 AM   #5
Amander
 
 
 
Join Date: Feb 2010
Reputation: 561
Posts: 8,142
Did you play around in the Intel GPU utulities? AFAIK they can set such stuff on a per-app-base.
Amander is offline   Reply With Quote
Old 05-16-2010, 07:19 AM   #6
Psychotronic
 
Join Date: Sep 2007
Reputation: 0
Posts: 18
Quote:
Originally Posted by TheMG View Post
Can you grab a screenshot of that? I'm not 100% sure what you're trying to describe. Never heard of any problem like it before.
Don't know how to do that, sorry. Also, the mouse goes sideways as well. Down is right, Up is left, etc...but only in TF2.

Basically, the whole thing (screen and mouse function) is 45 degrees counter-clockwise.
Psychotronic is offline   Reply With Quote
Old 05-16-2010, 07:24 AM   #7
Psychotronic
 
Join Date: Sep 2007
Reputation: 0
Posts: 18
Quote:
Originally Posted by Sgt_Hawk View Post
Have you tried playing in windowed mode?
You can do this one fo two ways, one would be to start Team Fortress 2 and go into options, video, then on the right hand side(or bottom in your case) you should see an option that says "fullscreen", try changing that to "Play in a window".(It may also be a good idea to lower TF2's resolution aswell, but that's your choice.)
I will try that now, thanks!
Psychotronic is offline   Reply With Quote
Old 05-16-2010, 07:33 AM   #8
jor
 
 
 
Join Date: Feb 2007
Reputation: 63
Posts: 1,463
Try ctrl+alt+arrow keys.
On an Intel GPU these shortcuts will orient the display in the given direction, might work.
jor is offline   Reply With Quote
Old 05-16-2010, 08:17 AM   #9
Psychotronic
 
Join Date: Sep 2007
Reputation: 0
Posts: 18
Quote:
Originally Posted by jor View Post
Try ctrl+alt+arrow keys.
On an Intel GPU these shortcuts will orient the display in the given direction, might work.

That was the first thing I tried, it didn't work. Well, it sort of worked -- it flipped it 180 degrees, but never right-side-up. Weird.
Psychotronic is offline   Reply With Quote
Old 05-16-2010, 08:18 AM   #10
jor
 
 
 
Join Date: Feb 2007
Reputation: 63
Posts: 1,463
You did try the up arrow as well? Pretty weird the orientation is screwed up in the first place, but it should support all four directions.
jor is offline   Reply With Quote
Old 05-16-2010, 08:31 AM   #11
joemtnbike
 
Join Date: Apr 2009
Reputation: 1062
Posts: 2,426
ctrl + alt + up arrow.
I also think there is a way to disable the reorienting of the screen altogether i just can't recall it at the moment.
joemtnbike is offline   Reply With Quote
Old 05-16-2010, 08:58 AM   #12
Petchyy
 
Join Date: Mar 2009
Reputation: 606
Posts: 1,856
What a weird problem, it's nothing to do with any auto rotate feature on your monitor is it?
Petchyy is offline   Reply With Quote
Old 05-16-2010, 11:10 AM   #13
Psychotronic
 
Join Date: Sep 2007
Reputation: 0
Posts: 18
Quote:
Originally Posted by Petchyy View Post
What a weird problem, it's nothing to do with any auto rotate feature on your monitor is it?
Dunno, I'm on a laptop.
Psychotronic is offline   Reply With Quote
Old 06-03-2010, 10:26 AM   #14
zip_0000
 
Guest
Posts: n/a
I've actually got exactly the same problem:

Going to a conference, and I thought I'd install TF2 on my work laptop, and it came up sideways. None of the display settings had any effect.

Mine is a Latitude E6500.

I was able to solve it though by following the configuration suggestions here:
http://www.gamespot.com/pc/action/te...413&pid=437678

I'm not sure exactly why that would make it not sideways, but it did. I hope this helps!
  Reply With Quote
Old 06-03-2010, 10:37 AM   #15
Tenkari
 
Join Date: May 2010
Reputation: 10
Posts: 602
well, i know with windows 7, there are options to change the orientation of the screen, and theres an option for all four directions.

there may be a way to do it in game settings as well if it happened to you.
Tenkari is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Discussions > Help and Tips


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 09:20 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.