Go Back   Steam Users' Forums > Steam Game Discussions > Q - S > Serious Sam series > The Second Encounter

Reply
 
Thread Tools Display Modes
Old 05-21-2010, 07:49 AM   #1
pixelmilitant
 
Join Date: Oct 2009
Reputation: 13
Posts: 19
SSHD:TSE not starting after patch

Hi all,

I'm finding that since the patch which was released today, I've not been able to start SSHD:TSE. My Steam status goes in-game for a few seconds and then drops back to 'online'.

I have verified the cache many times (which causes steam to download an 11.3 MB update), and running the game after causes a popup to show, reading "Completing installation". After that, the installers for VCRedist and another installer, but the game does not run.

I've also tried running with a disabled antivirus and firewall, just in-case they were causing some false positive blockages.

I thought maybe if I run the game straight from the Bin folder in 'steamapps' it might fire up. I receive this error:


---------------------------
SamHD_TSE.exe - Bad Image
---------------------------
C:\Windows\system32\X3DAudio1_7.dll is either not designed to run on Windows or it contains an error. Try installing the program again using the original installation media or contact your system administrator or the software vendor for support.
---------------------------
OK
---------------------------


I'm aware of a few issues similar in the past, but it sounds like they're solved with a verify or two.

Hopefully my info helps.

I'm running Win7 Pro 64 Bit, Q6600, ATI 5770, 4gb of ram.


Thanks,
PixMil
pixelmilitant is offline  
Reply With Quote
Old 05-21-2010, 08:21 AM   #2
Mr.Henky
 
Guest
Posts: n/a
Try to download standalone DX Redist from here.
  Reply With Quote
Old 05-21-2010, 05:00 PM   #3
pixelmilitant
 
Join Date: Oct 2009
Reputation: 13
Posts: 19
Quote:
Originally Posted by Mr.Henky View Post
Try to download standalone DX Redist from here.
Thanks for that.

I should've mentioned that I had attempted to use the DirectX web setup, but it reported I had the latest installation. I will try the full redist.

I'm grabbing it from here though:

http://www.microsoft.com/downloads/d...7-5ab8109cb4f5
pixelmilitant is offline   Reply With Quote
Old 05-21-2010, 05:20 PM   #4
pixelmilitant
 
Join Date: Oct 2009
Reputation: 13
Posts: 19
Ok, I downloaded the DX redist package and attempted to run SSHDTSE with no luck. Maybe a reboot to kick the DLLs into speed.

brb!
pixelmilitant is offline   Reply With Quote
Old 05-21-2010, 05:27 PM   #5
pixelmilitant
 
Join Date: Oct 2009
Reputation: 13
Posts: 19
Nope, no luck unfortunately.
pixelmilitant is offline   Reply With Quote
Old 05-22-2010, 05:57 AM   #6
pixelmilitant
 
Join Date: Oct 2009
Reputation: 13
Posts: 19
Crap. I just spent the afternoon downloading the entire game again, and I have exactly the same issue.

*sad panda*
pixelmilitant is offline   Reply With Quote
Old 05-22-2010, 02:42 PM   #7
_Politician_
 
Join Date: Dec 2009
Reputation: 46
Posts: 49
Quote:
Originally Posted by pixelmilitant View Post
Crap. I just spent the afternoon downloading the entire game again, and I have exactly the same issue.

*sad panda*
Can you confirm that 'X3DAudio1_7.dll' is in the directory 'C:\Windows\system32\' ?

If that is not the case, you might want to put it there manually.
_Politician_ is offline   Reply With Quote
Old 05-22-2010, 07:09 PM   #8
pixelmilitant
 
Join Date: Oct 2009
Reputation: 13
Posts: 19
Hi, thanks for the input.

I can confirm that X3DAudio7_1.dll exists in the correct folder. Also, if I rename the file to X3DAudio7_1.bak and run the DirectX redist installer, it replaces the file.

I've also checked the digital signatures on the SamHD_TSE.exe executable and DLL and have no problems there.
pixelmilitant is offline   Reply With Quote
Old 05-23-2010, 04:10 AM   #9
pixelmilitant
 
Join Date: Oct 2009
Reputation: 13
Posts: 19
Me again.

I read online that a "bad image" error tends towards an malware infection, but I've run scans using my virus scanner (Comodo) and malware scanner (Ad-Aware) and found nothing.
pixelmilitant is offline   Reply With Quote
Old 05-23-2010, 10:34 AM   #10
FulValBot (ITA)
 
 
 
Join Date: Oct 2007
Reputation: 113
Posts: 2,603
verify cache of game. tryo also to exclude sshd tse on your anti-malwares.
FulValBot (ITA) is offline   Reply With Quote
Old 05-23-2010, 04:26 PM   #11
pixelmilitant
 
Join Date: Oct 2009
Reputation: 13
Posts: 19
Quote:
Originally Posted by FulValBot (ITA) View Post
verify cache of game. tryo also to exclude sshd tse on your anti-malwares.

Quote:
Originally Posted by pixelmilitant View Post
I have verified the cache many times (which causes steam to download an 11.3 MB update


Thanks for that, but verifying does not solve this issue.

I've run Spybot Search and Destroy to perform another spyware check, and I was also recommended to run the windows command "SFC /scannow", which returned no errors.

I have added the entire steam folder and specifically SSHD:TSE as exceptions to both my firewall and antivirus application. (both Comodo free systems http://antivirus.comodo.com/)

This has not resolved the issue, which only presented itself after the 234MB patch.
pixelmilitant is offline   Reply With Quote
Old 05-24-2010, 03:59 AM   #12
alenl
 
alenl's Avatar
 
Croteam
Join Date: Nov 2009
Reputation: 336
Posts: 1,072
The reason you see this now, and not earlier is that since the patch the game uses new XAudio, whereas it previously a different (older) dll. This dll that it uses now seems to be damaged on your machine. Can you please get an MD5 checksum of that dll (use a tool like this: http://www.md5summer.org/ , or whatever suits you) ? Also, please search the entire Windows folder for diles of that name. You may have more than one in different subfolders. Maybe only one is damaged.
alenl is offline   Reply With Quote
Old 05-24-2010, 04:21 AM   #13
pixelmilitant
 
Join Date: Oct 2009
Reputation: 13
Posts: 19
Well, no MD5 required, but i feel like an idiot.

I did a search, and the same DLL is in sysWOW64, not just system32. Due to the fact i use a 64-bit system, it is referring to the DLL located in sysWOW64, even though the error reports the system32 DLL is broken.

Well, thanks alenl for pointing me in the right direction!

Much appreciated for the prompt response.
pixelmilitant is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > Q - S > Serious Sam series > The Second Encounter


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 04:45 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2012, All Rights Reserved.