Go Back   Steam Users' Forums > Steam Game Discussions > D - G > F.E.A.R. series

Reply
 
Thread Tools Display Modes
Old 06-13-2010, 05:31 AM   #1
SolidMonkee
 
Guest
Posts: n/a
Weird Performance issues in Original FEAR...

I can run this game on max settings at 60fps but after around 20 minutes of playtime the framerate drops to about 20 or lower and just stays there until I exit the entire game and start again, then I get another 20 minutes of smooth gameplay at 60fps before it drops to 20fps again.

Is this a memory leak or something? Anyone else have this issue?

edit: NM...just noticed the logitech fps/polling issue in the FAQ.

Last edited by SolidMonkee: 06-13-2010 at 05:36 AM.
 
Reply With Quote
Old 06-14-2010, 08:32 AM   #2
joeywyss
 
Guest
Posts: n/a
Same issue, no Logitech

I have the same issue, and I don't have any Logitech controllers...
  Reply With Quote
Old 06-14-2010, 10:28 PM   #3
Zippy
 
 
 
Join Date: Jun 2006
Reputation: 318
Posts: 4,593
Same problem.
Zippy is offline   Reply With Quote
Old 06-15-2010, 08:05 AM   #4
Verwandlung
 
Join Date: May 2009
Reputation: 195
Posts: 1,398
+1 here

Max settings

core i7
6gb ram
4890 (latest drivers)

Goes from 100-200 to -40 fps for no apparent reason

(tried the logitech fps/polling thing)
Verwandlung is offline   Reply With Quote
Old 06-15-2010, 08:51 AM   #5
Odyssey1319
 
 
 
Join Date: Jan 2009
Reputation: 102
Posts: 848
Regardless of whether or not you're running Logitech gear, anyone running Windows Vista or Windows 7 should disable all HID-compliant devices under Control Panel > Device Manager > Human Interface Devices. Do not disable HID-compliant consumer control devices. I got a noticeable jump in performance on these specifications:

Intel Core 2 Duo E8400 @ 3.0 GHz
4 GB RAM
Sapphire ATi Radeon HD 5850 @ 1 GB

My minimum/maximum FPS (with vsync enabled) went from 23.4/58 to 57/75 on maximum settings.

Last edited by Odyssey1319: 06-15-2010 at 08:54 AM.
Odyssey1319 is offline   Reply With Quote
Old 06-15-2010, 09:26 AM   #6
Verwandlung
 
Join Date: May 2009
Reputation: 195
Posts: 1,398
Question

So which of those should I disable? And what exactly is it I am changing?

http://i48.tinypic.com/15rfk9t.jpg

thanks in advance

Last edited by Verwandlung: 06-15-2010 at 10:09 AM.
Verwandlung is offline   Reply With Quote
Old 06-15-2010, 01:50 PM   #7
Odyssey1319
 
 
 
Join Date: Jan 2009
Reputation: 102
Posts: 848
Quote:
Originally Posted by Odyssey1319 View Post
Regardless of whether or not you're running Logitech gear, anyone running Windows Vista or Windows 7 should disable all HID-compliant devices under Control Panel > Device Manager > Human Interface Devices. Do not disable HID-compliant consumer control devices.
I think I made it pretty clear. Just disable HID-compliant devices, not HID-compliant consumer control devices. As for what you're changing exactly, I'm not sure, but it doesn't affect your mouse and keyboard. If you have a tablet, however, that's definitely not going to work right until you re-enable everything.

Last edited by Odyssey1319: 06-15-2010 at 01:53 PM.
Odyssey1319 is offline   Reply With Quote
Old 06-16-2010, 02:55 AM   #8
Verwandlung
 
Join Date: May 2009
Reputation: 195
Posts: 1,398
Yes you were very clear.
It didn't change the performance of the game for me unfortunately. What it did do was disable some 'extra' functions of my keyboard (volume control etc.)
Hence I thought I was missing some HID-compliant device..

thanks anyway
Verwandlung is offline   Reply With Quote
Old 06-16-2010, 08:04 AM   #9
Stixsworld
 
 
 
Join Date: Nov 2008
Reputation: 125
Posts: 1,027
I have the entire fear series and well http://www.stixsworld.com/DxDiag.txt and my processor is overclocked to be 3.21Ghz and well I easily get well above 60+FPS smoothly in each game with no issues really...

---Stixsmaster
Stixsworld is offline   Reply With Quote
Old 06-16-2010, 07:37 PM   #10
KarlMonster
 
Join Date: May 2009
Reputation: 58
Posts: 786
My system should also be pretty quick. The game mostly ran fine for me, but every once in a while, I'd just get stuck in one spot doing far less than 20fps. It was just weird, and seemed to happen most often in specific locations. One thing that seemed to help a little; if I thought the framerate was starting to bog, I'd jump a few times. I can't imagine why, but I think somehow I was getting stuck in the floor, and that may have caused a memory leak?

If I could get past those points, I was fine.
KarlMonster is offline   Reply With Quote
Old 06-17-2010, 03:51 AM   #11
Verwandlung
 
Join Date: May 2009
Reputation: 195
Posts: 1,398
I did what Odyssey1319 suggested AND turned on Vsync now the game keeps a steady 59 /60 FPS and rarely drops below that except in certain locations as Karl described mostly during some of the 'surreal horror' parts. But it's playable so I am happy
Verwandlung is offline   Reply With Quote
Old 06-17-2010, 08:25 PM   #12
glasseye67
 
Join Date: Apr 2009
Reputation: 97
Posts: 888
Funny you should mention a memory leak but I think you are right. I have always had trouble with the sound in the first F.E.A.R. breaking windows my sound turns to the stuttering and hissing and I have to restart the saved game.
glasseye67 is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > D - G > F.E.A.R. series


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 05:34 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2012, All Rights Reserved.