Go Back   Steam Users' Forums > Steam Game Discussions > # - C > Beyond Good & Evil

Reply
 
Thread Tools Display Modes
Old 06-25-2010, 01:40 AM   #1
idioteque6
 
Guest
Posts: n/a
Will BG&E work on Windows 7?

Want to revisit this game and would like to know if it will work on Windows 7 64 bit?
 
Reply With Quote
Old 06-25-2010, 09:46 PM   #2
D3xter
 
Join Date: Jun 2009
Reputation: 164
Posts: 291
The Good Old Games version does: http://www.gog.com/en/gamecard/beyond_good_and_evil/

I don't know about Steam... it says Windows 2000/XP only...
D3xter is offline   Reply With Quote
Old 06-25-2010, 10:57 PM   #3
Czar Zach
 
Guest
Posts: n/a
It works on mine, but there's lots of graphical errors, like models wacking out and textures, so it's unplayable in my opinion.


I'm runing 64-bit Windows 7, i've also tried messing with administator rights, and the XP/2000 compatability modes.
  Reply With Quote
Old 06-27-2010, 02:24 AM   #4
Froyok
 
Guest
Posts: n/a
Quote:
Originally Posted by Czar Zach View Post
It works on mine, but there's lots of graphical errors, like models wacking out and textures, so it's unplayable in my opinion.


I'm runing 64-bit Windows 7, i've also tried messing with administator rights, and the XP/2000 compatability modes.
Try this : http://forums.steampowered.com/forum...d.php?t=682893

The game work for me, but I have a lot of bad performances, in the city by example. Otherwise the game run fine.
  Reply With Quote
Old 06-27-2010, 11:25 PM   #5
idioteque6
 
Guest
Posts: n/a
Quote:
Originally Posted by Czar Zach View Post
It works on mine, but there's lots of graphical errors, like models wacking out and textures, so it's unplayable in my opinion.


I'm runing 64-bit Windows 7, i've also tried messing with administator rights, and the XP/2000 compatability modes.
Thanks, don't think I'll get it then.
  Reply With Quote
Old 07-12-2010, 01:21 PM   #6
Morasta
 
Guest
Posts: n/a
Mine works just fine under windows 7 x64 and x32 (steam version). The trick is to check the box for manually config settings and make sure anti-aliasing is disabled.

Sometimes I see a random blip during the intro menu, but after that it runs fine. I'm about 4.5 hours in and no problems since I made those changes.

EDIT:
I'll add that there is very little graphical degradation without AA turned on. If you zoom WAY in on the edge of a few characters here and there it's not quite as smooth, but it's hardly noticeable let alone detrimental.
  Reply With Quote
Old 07-13-2010, 06:07 AM   #7
_jema987
 
Join Date: Aug 2007
Reputation: 66
Posts: 398
The GOG version works fine and is better value IMO.
_jema987 is offline   Reply With Quote
Old 07-14-2010, 07:28 AM   #8
Stixsworld
 
 
 
Join Date: Nov 2008
Reputation: 125
Posts: 1,027
I got steam version working 100% just have to check off HW Vertex Processing in Advanced Settings of the SettingsApplication.exe and well you can have everything else checked and maxed out fine...

---Stixsmaster
Stixsworld is offline   Reply With Quote
Old 07-14-2010, 07:46 AM   #9
DJ_Professor_K
 
Join Date: Nov 2008
Reputation: 91
Posts: 1,560
It's a try and miss on todays machines with todays OSs.

GOG version works perfectly, steam version isn't optimized and unchecking HW Vertex Processing, won't always do the trick.

You have big chanses of getting artifacts on steams version... sad they don't patch the steam version :/

I have all 3 versions, original, steam and gog, and i'm stuck playign gog since both others don't work, evan doing what's posted everywhere (well it works fine on my old machine with vista, but i rarelly use that one so...).
DJ_Professor_K is offline   Reply With Quote
Old 07-14-2010, 11:03 AM   #10
Morasta
 
Guest
Posts: n/a
Quote:
Originally Posted by DJ_Professor_K View Post
It's a try and miss on todays machines with todays OSs.

GOG version works perfectly, steam version isn't optimized and unchecking HW Vertex Processing, won't always do the trick.

You have big chanses of getting artifacts on steams version... sad they don't patch the steam version :/

I have all 3 versions, original, steam and gog, and i'm stuck playign gog since both others don't work, evan doing what's posted everywhere (well it works fine on my old machine with vista, but i rarelly use that one so...).
Did you try turning off AA as well? That was what did the trick for me.
  Reply With Quote
Old 07-15-2010, 12:54 PM   #11
Leevor1701
 
Join Date: Jul 2010
Reputation: 0
Posts: 13
These settings worked for me and it looks good:

Turn off Antialiasing
Turn off the W buffer
Leave everything else on inclusing the HW Vertex Processing


I re-enabled (forced) Antialiasing and enabled V-sync using the Nvidia Control Panel. Works a treat

Windows 7 Ultimate 64-bit
Nvidia GeForce GTS 250
257.21 Display drivers
Leevor1701 is offline   Reply With Quote
Old 07-20-2010, 04:51 PM   #12
Barbossa_Haruo
 
 
 
Join Date: Apr 2009
Reputation: 13
Posts: 435
Quote:
Originally Posted by Leevor1701 View Post
These settings worked for me and it looks good:

Turn off Antialiasing
Turn off the W buffer
Leave everything else on inclusing the HW Vertex Processing


I re-enabled (forced) Antialiasing and enabled V-sync using the Nvidia Control Panel. Works a treat

Windows 7 Ultimate 64-bit
Nvidia GeForce GTS 250
257.21 Display drivers
I'll have to try that, when i did mine, it had a bad slowdown at points.. but i'm running the same card as you, so i'll try it.
Barbossa_Haruo is offline   Reply With Quote
Old 08-28-2010, 10:55 PM   #13
tikwid
 
Join Date: Jan 2010
Reputation: 0
Posts: 18
Quote:
Originally Posted by idioteque6 View Post
Want to revisit this game and would like to know if it will work on Windows 7 64 bit?
I have Win7 64 and it's constant 60FPS for me. I just have to disable anti-aliasing because it causes issues. Everything else is enabled and maxed out. At large resolutions like 1600x1200 you won't need AA anyway.
tikwid is offline   Reply With Quote
Old 10-06-2010, 03:27 AM   #14
Melonfodder
 
Join Date: Sep 2010
Reputation: 0
Posts: 20
After some messing around in the Nvidia control panel around I've finally gotten BG&E to run flawlessly. I'm so bloody happy about this!

The computer in mind is an i5-750, Win7 x64 with a GTX470 in it, so this is one of the PCs that the problem should surface on - and it did. Turning off HW Vertex processing caused very poor performance for me so I wanted to fiddle around a little more with it:

1. First of all, I've ticked the manual compatibility checkbox in the SettingsApplication executable; W Buffer is the only unticked box. Water detail, flare and shadows are set to high whilst AA remains off.

2. In my Nvidia control panel I've set a few settings for the bge executable that apparently hit a magic switch to make it stop glitching in-game. Now, my language for the control panel is Swedish and I see no option to turn it into English, so work with me on this one:

Anistropic filtering: 8x
Antialiasing - Mode: Override application
Antialiasing - Setting: 4x
Antialiasing - Transparency: 4x(supersampling)
Multi-display/mixed GPU acceleration: Single display performance
Texture filtering - Anistropic sample optimisation: On
Texture filtering - Negative LOD bias: Clamp
Texture filtering - Trilinear optimisation: On
Texture filtering - Quality: Quality
Threaded optimisation: Off
Triple buffering: On
Vsync: Forced on
"Maximum/Extended length" (something in my cp that I couldn't find a good translation for. I suspect it might be for OGL but it doesn't hurt: On

I suspect that it might be something as simple as just the Vsync, but right now I'm not too keen to see what causes the absence of glitches. What I'm going to do now is try to set a custom resolution so that it's proper widescreen mode, and I guess I'll also try and find the registry hack to remove the black borders. I'll come back with more info if I find something... And let's hope that I'm not full of with this; I did play-test for half an hour without glitches but it's yet to remain proven fully. Thought I'd share it anyway!

In the end I wonder if it's just D9EX on Vista/7 that's the problem, or if it's new drivers?
Melonfodder is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > # - C > Beyond Good & Evil


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 11:36 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2012, All Rights Reserved.