Go Back   Steam Users' Forums > Steam Game Discussions > H - L > LEGO Harry Potter

Reply
 
Thread Tools Display Modes
Old 07-06-2010, 09:59 AM   #1
sag_ich_nicht
 
Guest
Posts: n/a
Exclamation [FIX] Immediate Crash to Desktop on Startup

Hello.

Here's how to fix the issue for immediate crashes to the Desktop when starting Lego Harry Potter: Years 1-4:

Windows XP:
1. Open your sound cards control panel, and set the sampling frequency to 48 KHz or 44.1 KHz.
2. It's fixed

Windows Vista / Windows 7:
1. Open your sound cards control panel, and set the sampling frequency to 48 KHz or 44.1 KHz.
2. Rightclick the speaker icon in the notification area of your start bar (also known as the systray area). Select playback devices.
3. Doubleclick your playback device.
4. Go to advanced.
5. Set the sampling frequency to either:
24 bit, 48000 Hz
16 bit, 48000 Hz
24 bit, 44100 Hz
16 bit, 44100 Hz
6. It's fixed.

Obviously you should revert both settings back to the highest possible value when you are done playing, otherwise your sound quality will be decreased.

This game is a terrible port from the XBox 360, and can't deal with any sampling frequency setting above 48 KHz. :|
 
Reply With Quote
Old 07-08-2010, 11:47 AM   #2
Tubular
 
Join Date: Sep 2007
Reputation: 4
Posts: 335
thank you so much for this post!
Tubular is offline   Reply With Quote
Old 07-08-2010, 03:29 PM   #3
distobj
 
Join Date: May 2008
Reputation: 0
Posts: 4
FWIW, in Windows 7, I just had to ensure that I was using "Speakers" as my default playback device. If I used "Digital Output", then I got the crash.
distobj is offline   Reply With Quote
Old 07-08-2010, 07:55 PM   #4
Tubular
 
Join Date: Sep 2007
Reputation: 4
Posts: 335
worked perfectly!
Tubular is offline   Reply With Quote
Old 07-12-2010, 10:32 AM   #5
ScouseSandwich
 
Join Date: Jul 2010
Reputation: 6
Posts: 34
Quote:
Originally Posted by distobj View Post
FWIW, in Windows 7, I just had to ensure that I was using "Speakers" as my default playback device. If I used "Digital Output", then I got the crash.
This didnt work for me but it may others

Quote:
Originally Posted by sag_ich_nicht View Post
Hello.

Here's how to fix the issue for immediate crashes to the Desktop when starting Lego Harry Potter: Years 1-4:

Windows XP:
1. Open your sound cards control panel, and set the sampling frequency to 48 KHz or 44.1 KHz.
2. It's fixed

Windows Vista / Windows 7:
1. Open your sound cards control panel, and set the sampling frequency to 48 KHz or 44.1 KHz.
2. Rightclick the speaker icon in the notification area of your start bar (also known as the systray area). Select playback devices.
3. Doubleclick your playback device.
4. Go to advanced.
5. Set the sampling frequency to either:
24 bit, 48000 Hz
16 bit, 48000 Hz
24 bit, 44100 Hz
16 bit, 44100 Hz
6. It's fixed.

Obviously you should revert both settings back to the highest possible value when you are done playing, otherwise your sound quality will be decreased.

This game is a terrible port from the XBox 360, and can't deal with any sampling frequency setting above 48 KHz. :|
On the other hand this method worked perfectly, thanks for the help!
ScouseSandwich is offline   Reply With Quote
Old 07-13-2010, 10:30 AM   #6
AxellSlade
 
 
 
Join Date: Nov 2009
Reputation: 0
Posts: 11
Tried all kinds of sampling frequency and no go for me. :Sigh:
AxellSlade is offline   Reply With Quote
Old 10-22-2010, 10:51 AM   #7
beach9thstreet
 
Guest
Posts: n/a
How do you do step 1? Open your sound cards control panel, and set the sampling frequency to 48 KHz or 44.1 KHz.

I have Windows 7, I was able to do the other steps, but i cant find the sound control panel. I mean i went to control panel and sounds, but i didnt see anything there to change the sampling frequency. What do i click on?

Forget it, I didnt realzie that was the later steps. Moron me! Buyt either way it didnt work

Last edited by beach9thstreet: 10-22-2010 at 10:53 AM. Reason: Moron me!
  Reply With Quote
Old 02-09-2012, 08:49 AM   #8
Timiditas
 
Join Date: Aug 2010
Reputation: 0
Posts: 74
Quote:
Originally Posted by sag_ich_nicht View Post
5. Set the sampling frequency to either:
24 bit, 48000 Hz
16 bit, 48000 Hz
24 bit, 44100 Hz
16 bit, 44100 Hz
6. It's fixed.
Obviously now I am paying for removing my crappy Creative Labs soundcard with even crappier Win7-driversupport.
I only have two options there, both are 96khz:
http://voodoovictim.bplaced.net/report/pottercrap.jpg

If this game doesn't want me, I don't want it either. And I am NOT going to buy *another* crappy Creative Labs soundcard.
If my mainboard had ISA-slots, I'd stick in my AWE64.
Timiditas is offline   Reply With Quote
Old 02-18-2012, 04:55 AM   #9
Initiative
 
Join Date: Jan 2012
Reputation: 33
Posts: 223
Quote:
Originally Posted by beach9thstreet View Post
I have Windows 7, I was able to do the other steps, but i cant find the sound control panel. I mean i went to control panel and sounds, but i didnt see anything there to change the sampling frequency. What do i click on?
This. Help! Imma nub!
Initiative is offline   Reply With Quote
Old 06-01-2012, 01:59 PM   #10
methimpikehoses
 
Join Date: Jan 2010
Reputation: 0
Posts: 35
thanks for the fixe!
methimpikehoses is offline   Reply With Quote
Old 04-02-2013, 01:30 PM   #11
PSYDEX
 
 
 
Join Date: Sep 2011
Reputation: 7
Posts: 178
This thread should be pinned!
PSYDEX is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > H - L > LEGO Harry Potter


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 04:49 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.