Go Back   Steam Users' Forums > Steam Discussions > Steam for Mac > Steam

Reply
 
Thread Tools Display Modes
Old 07-26-2010, 11:40 AM   #1
dbostwick
 
Guest
Posts: n/a
Steam Crashes

I logged on today to get the TF2 Steam Beta Client must be running error, so I restarted steam, and it tried to update the client, and then wouldn't get past connecting to account before crashing. I did a 100% wipe and reinstall of steam and it still crashes when I try to login.

Error log from console:

7/26/10 10:38:25 AM [0x0-0x5a05a].com.valvesoftware.steam[751] threadtools.cpp (2185) : Assertion Failed: Tried to create a thread that has already been created!
7/26/10 10:38:25 AM [0x0-0x5a05a].com.valvesoftware.steam[751] threadtools.cpp (2185) : Assertion Failed: Tried to create a thread that has already been created!
7/26/10 10:38:25 AM [0x0-0x5a05a].com.valvesoftware.steam[751] Assert( Assertion Failed: Tried to create a thread that has already been created! ):/Users/rackadmin/buildslave/steam_rel_client_osx/build/src/tier0/threadtools.cpp:2185
7/26/10 10:38:25 AM [0x0-0x5a05a].com.valvesoftware.steam[751] KeyValues Error: LoadFromBuffer: missing { (current key: '��') in file steam/games/PlatformMenu.vdf
7/26/10 10:38:25 AM [0x0-0x5a05a].com.valvesoftware.steam[751] ExecCommandLine: "/Users/dbostwick/Downloads/Steam.app/Contents/MacOS/osx32/steam -psn_0_368730 steam://open/main"
7/26/10 10:38:25 AM [0x0-0x5a05a].com.valvesoftware.steam[751] ExecSteamURL: "steam://open/main"
7/26/10 10:38:27 AM ReportCrash[743] Saved crash report for steam[756] version ??? (1.0) to /Users/dbostwick/Library/Logs/DiagnosticReports/steam_2010-07-26-103827_Linda-Bostwicks-MacBook-Pro.crash
7/26/10 10:38:28 AM [0x0-0x5a05a].com.valvesoftware.steam[751] /Users/dbostwick/Downloads/Steam.app/Contents/MacOS/steam.sh: line 63: 756 Bus error ${DEBUGGER} "${STEAMROOT}"/${PLATFORM}/${STEAMEXE} $@
7/26/10 10:38:28 AM com.apple.launchd.peruser.503[80] ([0x0-0x5a05a].com.valvesoftware.steam[751]) Exited with exit code: 138
 
Reply With Quote
Old 07-26-2010, 11:43 AM   #2
dbostwick
 
Guest
Posts: n/a
I removed my steamapp folder that I replaced because I don't want to spend 20+ hours reinstalling portal, TF2, CS:S, etc and now its launching. Is there anyway that TF2 could have broken my steam?
  Reply With Quote
Old 07-26-2010, 11:47 AM   #3
dbostwick
 
Guest
Posts: n/a
Update - I placed only TF2 files back in, and it seems to be launching now, minus a 200mb update for TF2, Ill keep adding games till I get the problem.
  Reply With Quote
Old 07-26-2010, 11:49 AM   #4
dbostwick
 
Guest
Posts: n/a
"multiplayer ob mac binaries.gcf" and "portal content.gcf" seem to be causing the problem. Should those files have spaces in them?
  Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Discussions > Steam for Mac > Steam


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 01:21 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.