Go Back   Steam Users' Forums > Steam Game Discussions > Q - S > Star Wars collection > Knights of the Old Republic Series

Reply
 
Thread Tools Display Modes
Old 08-16-2010, 07:48 PM   #1
trojanrabbit.gg
 
 
 
Join Date: Mar 2010
Reputation: 6009
Posts: 1,640
Exclamation No Cutscenes when run in widescreen...

So I finally got this game to run in 1680x1050 resolution. The game runs perfectly, but I have no cutscenes. The screen just stays black when the cutscenes are supposed to be running. I can hear them, I just cannot see them. Anyone know of a possible fix for this?
trojanrabbit.gg is offline  
Reply With Quote
Old 08-17-2010, 02:57 AM   #2
JackM
 
 
 
Join Date: Jun 2010
Reputation: 227
Posts: 761
Are you using the trick described here to get widescreen resolution in KotOR? I have used it myself without any issue with the cut-scenes.
JackM is offline   Reply With Quote
Old 08-17-2010, 09:24 PM   #3
trojanrabbit.gg
 
 
 
Join Date: Mar 2010
Reputation: 6009
Posts: 1,640
Yeah, I used that trick. I got the game to work in my native resolution of 1680x1050, but had no cut scenes at all... If I alt tabed out of the game and then went back in then the cutscene would pop up, but that just becomes quite annoying. When the cutscenes do come up, they are nice because they actually fill the whole screen and not just a box in the middle like usual... But I can't seem to get them to work without consistently having to alt tab in and out of the game...

I was also able to avoid the cutscene error by running the game in a window. But when run in a window, the game began to stutter and lag constantly...

I may just end up having to just replaying the game in a 4:3 aspect ratio
trojanrabbit.gg is offline   Reply With Quote
Old 08-18-2010, 08:49 AM   #4
trojanrabbit.gg
 
 
 
Join Date: Mar 2010
Reputation: 6009
Posts: 1,640
Found the solution in an old thread...

Quote:
Originally Posted by Sweetz View Post
The movies have always been problematic. By default, the game is hardcoded to run movies at 800x600 regardless of your chosen resolution. Some people's monitors/video cards don't like the way the game mode switches and don't display the movies regardless.

With the widescreen mod we change the movies to run at the modded resolution, which sometimes fixes them for people who don't have show up 800x600, but it seems also breaks them for some people who did have them show up at 800x600.

If the movies worked for you pre-mod, it's possible to perform the mod without altering the movie resolution as follows:


1. Use UniWS to undo the previous patch on the game, or download a fresh copy of the executable.
2. Open the patches.ini file that comes with UniWS in Wordpad (if you open it in Notepad, you won't have line breaks).
3. Scroll down to the section labeled: [Star Wars: KOTOR (1024x768 interface)]
4. Find the lines below (make sure you're still in the 1024x768 section!) and delete them:
;movies edit 1
p4modfile=swkotor.exe
p4undofile=swkotorc.undom1
p4sig=800200007515813DD8D17800E001
p4sigwild=00000000000000
p4xoffset=0
p4yoffset=12
p4occur=1
;movies edit 2
p5modfile=swkotor.exe
p5undofile=swkotorc.undom2
p5sig=80020000C7442410E001
p5sigwild=0000000000
p5xoffset=0
p5yoffset=8
p5occur=1

5. Save the file and then repatch the game with UniWS following the normal instructions.

I'll leave this thread up just in case others have the same issues... This fix worked...
trojanrabbit.gg is offline   Reply With Quote
Old 09-15-2010, 10:39 AM   #5
Zamzy
 
Join Date: Sep 2009
Reputation: 0
Posts: 21
How do you enable 'windowed mode' ? I am having this issue as well with running the game, and haven't taken the time to try and find a crack/fix for it. But a windowed option would be pretty sweet if possible.
Zamzy is offline   Reply With Quote
Old 09-15-2010, 05:33 PM   #6
fscherrer
 
Join Date: Sep 2010
Reputation: 0
Posts: 4
Lightbulb swkotor.ini

Quote:
Originally Posted by Zamzy View Post
How do you enable 'windowed mode' ? I am having this issue as well with running the game, and haven't taken the time to try and find a crack/fix for it. But a windowed option would be pretty sweet if possible.
Edit your steam\steamapps\common\swkotor\swkotor.ini, search for FullScreen=1 (it's under [Graphics Options]) and change it to FullScreen=0

It worked for me
fscherrer is offline   Reply With Quote
Old 01-05-2013, 05:42 PM   #7
Gvaz
 
 
 
Join Date: Oct 2007
Reputation: 14
Posts: 784
Quote:
Originally Posted by trojanrabbit.gg View Post
Found the solution in an old thread...




I'll leave this thread up just in case others have the same issues... This fix worked...
Doesn't work for me, I just tried it
Gvaz is offline   Reply With Quote
Old 03-24-2013, 04:38 AM   #8
kaghler
 
Join Date: Nov 2010
Reputation: 85
Posts: 41
There's two "Fullscreen=1", change both of them.
kaghler is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > Q - S > Star Wars collection > Knights of the Old Republic Series


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 02:17 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2012, All Rights Reserved.