Go Back   Steam Users' Forums > Steam Discussions > Help and Tips

Reply
 
Thread Tools Display Modes
Old 09-03-2010, 02:29 PM   #1
AtomicSabotage
 
Guest
Posts: n/a
Company of Heroes crashes at launch

Hey guys. I bough all three Company of Heroes games for the weekend sale, but none of them work. I get the windows "Preparing to launch company of heroes" and then after about 10 seconds I get a pop-up crash report from a Relic program.


Anyone know how I can fix this?

Here's my specs.

ASUS K42JV-X1
Windows 7 Home Premium 64-bit
Intel Core i5 450M 2.4GHz Processor
4GB DDR3 RAM
500GB 7200RPM HDD
1GB DDR3 VRAM NVIDIA GeForce GT 335M
 
Reply With Quote
Old 09-03-2010, 03:49 PM   #2
xX_Renegade_Xx
 
 
 
Join Date: Nov 2009
Reputation: 1909
Posts: 4,446
Try this thread, if nothing helps try posting in that section of the forum and one of the devs will get back to you:

http://forums.steampowered.com/forum...d.php?t=578322
xX_Renegade_Xx is offline   Reply With Quote
Old 09-03-2010, 04:17 PM   #3
AtomicSabotage
 
Guest
Posts: n/a
^^ Thanks a lot. The language change method worked like a charm!

Last edited by AtomicSabotage: 09-03-2010 at 04:32 PM.
  Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Discussions > Help and Tips


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 09:23 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.