Go Back   Steam Users' Forums > Steam Game Discussions > H - L > King's Bounty series

Reply
 
Thread Tools Display Modes
Old 10-17-2010, 02:18 PM   #16
Panimu
 
Join Date: Jul 2006
Reputation: 5
Posts: 221
Did you play for more than 2 minutes? I find it goes away ..
Panimu is offline   Reply With Quote
Old 10-22-2010, 01:22 PM   #17
yenik
 
Join Date: Mar 2008
Reputation: 0
Posts: 33
Most of the issues related to flickering go away with time, but you will still see strange artifacts. For example when you enter a fight, look at the text, it will be distorted. 10.10WHQL still has this problem. If you're a KB gamer, don't bother updating.

Last edited by yenik: 10-22-2010 at 01:35 PM.
yenik is offline   Reply With Quote
Old 10-24-2010, 05:39 AM   #18
Ashaad
 
Join Date: Nov 2008
Reputation: 0
Posts: 73
This is sooo bad...i really was enjoying playing this game.
Ashaad is offline   Reply With Quote
Old 11-11-2010, 02:17 PM   #19
DiceDuP
 
 
 
Join Date: Nov 2007
Reputation: 19
Posts: 492
Blah, just came back for a run thru of this game and I have this flickering issue also.

5770 card. Ran fine a few months back
DiceDuP is offline   Reply With Quote
Old 11-18-2010, 01:26 PM   #20
yenik
 
Join Date: Mar 2008
Reputation: 0
Posts: 33
Use the 10.7 driver release for now guys. It's the best release they did this year IMO. Has no issues with KB, VLC hardware acceleration, and no flickering issues with 2D clockspeeds when overclocking.
yenik is offline   Reply With Quote
Old 11-27-2010, 01:32 PM   #21
AshTray
 
Join Date: Jun 2010
Reputation: 8
Posts: 173
10.11 here and I also have flickering.. Gah, I wish I would had checked this forum before I bought the Platinum Edition..

HD5850

Is ATI aware of this issue, has someone told them?
AshTray is offline   Reply With Quote
Old 11-27-2010, 02:35 PM   #22
rustayne
 
Join Date: Jul 2008
Reputation: 0
Posts: 44
I managed to get it to stop flickering by just turning off shadows. I have restarted it 3 times, and all 3 times it worked just fine. Hopefully that helps.
rustayne is offline   Reply With Quote
Old 11-28-2010, 05:21 PM   #23
syndicatedragon
 
Join Date: Nov 2009
Reputation: 0
Posts: 13
I recommend posting the problem here on the AMD driver feedback page.
syndicatedragon is offline   Reply With Quote
Old 12-04-2010, 07:22 PM   #24
joey_sfb
 
Join Date: Aug 2009
Reputation: 0
Posts: 16
Runing HD5970 /w 10.11 win 7 32bit 4G, RAID 0 2THDD. The game has no flicking but the save game is inconsistent. I can't find some of my game saves. Weird! Otherwise a great game!
joey_sfb is offline   Reply With Quote
Old 12-12-2010, 09:53 PM   #25
Cruga
 
Join Date: Nov 2010
Reputation: 2
Posts: 25
is there a specific CCC setting that is causing this?
Cruga is offline   Reply With Quote
Old 12-14-2010, 08:15 AM   #26
rmilcik
 
 
 
Join Date: Jan 2010
Reputation: 0
Posts: 15
Don't know if this will help or not, but I was fiddling with settings trying to get rid of flickering for Force Unleashed 2. Disabling the Catalyst A.I. in the CCC helped Force Unleashed, but caused flickering in King's Bounty. I reactivated A.I. and KB runs like a champ.
rmilcik is offline   Reply With Quote
Old 12-14-2010, 07:22 PM   #27
Linith
 
Join Date: Dec 2010
Reputation: 0
Posts: 9
Get the 10.10e drivers over at guru3d.com. It should work.
Linith is offline   Reply With Quote
Old 12-15-2010, 10:00 AM   #28
yenik
 
Join Date: Mar 2008
Reputation: 0
Posts: 33
Anyone try the 10.12s yet? http://sites.amd.com/us/game/downloa...n_win7-64.aspx
yenik is offline   Reply With Quote
Old 12-15-2010, 05:56 PM   #29
yenik
 
Join Date: Mar 2008
Reputation: 0
Posts: 33
Problem still exists on 10.12. I recommend going back to a clean install on 10.6. Driver uninstall, safe mode Driversweeper + CCleaner, reboot and install 10.6. Xfire KB players 10.4a or 10.5a is still probably the best shot.

I've sent another support ticket and uploaded a video of the problem for AMD to review.

Regarding NV, don't kid yourself. NV drivers are worse in this game than AMD. http://forums.steampowered.com/forum....php?t=1339585 Stuttering and freezing, so no need to fan boi it up.

Last edited by yenik: 12-18-2010 at 01:41 PM.
yenik is offline   Reply With Quote
Old 12-20-2010, 10:03 AM   #30
Icupnimpn2
 
Guest
Posts: n/a
I can't take credit for this since I read it after some hard searching a couple of months back. Here's how you can get the flickering to stop for a while every time it starts:

-Don't quit playing, but enter the graphics option menu.
-Hover your mouse pointer over a radio button/click box until the flickering stops completely.
-Enjoy the game... until the flickering starts again.

It really does work like a charm. Can't explain why, for the life of me.

Hope this helps.

By the way, this seems to work regardless of driver version. I'll keep hoping there's a real fix eventually. But this mouse hover trick is quick and easy enough to use whenever the flickering happens that it's not really a bother.

Last edited by Icupnimpn2: 12-20-2010 at 10:06 AM. Reason: added detail
  Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > H - L > King's Bounty series


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 05:05 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.