Go Back   Steam Users' Forums > Steam Discussions > Steam for Mac > Source games

Reply
Click here to go to the first staff post in this thread.  
Thread Tools Display Modes
Old 10-07-2010, 12:31 PM   #1
packinheat
 
Guest
Posts: n/a
L4D2 "can't find background image" error on startup

So I finally managed to download Left 4 Dead 2 (from a server in Beijing as anything even remotely close to me was completely dead) but the game doesn't start..

I get an error saying "Can't find background image 'materials/console/background01.vtf'"

Any help?

I'm running a 2010 MBP 13" with Snow Leopard for starters if it makes any difference.

Thanks

Last edited by packinheat: 10-07-2010 at 12:35 PM.
 
Reply With Quote
Old 10-07-2010, 01:15 PM   #2
MansoN69
 
Join Date: Jun 2010
Reputation: 0
Posts: 8
Same here.
MansoN69 is offline   Reply With Quote
Old 10-07-2010, 01:18 PM   This is the last staff post in this thread.   #3
alfred
 
alfred's Avatar
 
Valve
Join Date: Jan 2003
Reputation: 188
Posts: 294
Use the games property page in Steam to validate your install.
alfred is offline   Reply With Quote
Old 10-07-2010, 08:53 PM   #4
packinheat
 
Guest
Posts: n/a
Thanks for the reply,

it says all files succesfully validated.

The defragment shows something ridiculous like 2487679766779% fragmentation and refuses to do anything but I'm guessing that's because it doesn't play well with the Mac OS file system (which really shouldn't need defragmenting anyway afaik)? Or is my game installation really messed up?

It's another two days of downloading for me? At the moment the servers seem to be too busy to even try if the game starts, but I doubt anything would have changed while I was sleeping (I had tried the validation already).

Where is that file supposed to be? I found two "materials" directories from the game's installed files, but neither had a sub directory called console. I can't find anything with that file name.

Last edited by packinheat: 10-07-2010 at 09:17 PM.
  Reply With Quote
Old 10-07-2010, 09:48 PM   #5
packinheat
 
Guest
Posts: n/a
I deleted the files left 4 dead 2 client.ncf, left 4 dead 2 common.ncf and left 4 dead 2 mac content.ncf to see what happens.. relaunching the game, it pulled those files back from somewhere and is now downloading.. something. Time will tell if it's done before I have to go to work or if I'll have to wait till later today to continue with the fight for my right to play L4D2 :P

Edit,

now it works! My uneducated guess would be that with all the slowdowns and suspended downloads and cursings and fish shakings and forece quitting Steam because it was dead etc etc, it "finished" the download corrupted thinking it was done, the validation also thought it was done, but deleting those couple of files triggered it into realizing that stuff is still missing? Or something. Either way, the game launches now but I have to go to work so bye

Last edited by packinheat: 10-07-2010 at 09:57 PM.
  Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Discussions > Steam for Mac > Source games


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 07:24 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.