Go Back   Steam Users' Forums > Steam Discussions > Steam for Mac > Steam

Reply
 
Thread Tools Display Modes
Old 11-09-2010, 02:36 PM   #1
crimson_penguin
 
Guest
Posts: n/a
Left 4 Dead 2 won't launch anymore

So bought Left 4 Dead 2, downloaded it successfully (after having to come here to get help getting it to start downloading), played it a bunch, and all was well. Then one day, it stopped getting past the "Preparing to launch" screen. So I figured I tried canceling (made the client hang), restarting Steam, even restarting my computer, and verifying the app cache... And now it's even worse: now it insists on verifying the app cache every time, but every time it does, it fails and gives me false error messages. It gets to usually at most 33% done, and then says the Steam servers are too busy (which seems to be the default message for any sort of network error - my guess is it actually timed out). Even if that's true, which I doubt, it also says it verified 100% of the files successfully in the original dialog, which is obviously not true (and of course, it doesn't start the game).

In any case, I want to know why this is happening and how to make it work again. I bought this game, and I would like to play it.

I know someone's going to suggest "just delete it and download it again". That is an awful solution, and one that's particularly bad for me, because my internet sucks. My internet goes at a max sustained down speed of 40KB/s, which means L4D2, at ~12GB, takes about 3 days, 15 hours to download at full speed. And in addition to that, uses 60% of my 20GB/month bandwidth cap. Believe me, I would get better internet if it were available here. But clearly it was good enough to get the game, and once I've got the game, I should not have to get it again.
 
Reply With Quote
Old 11-13-2010, 12:37 AM   #2
Larix
 
Guest
Posts: n/a
Thumbs down The Steam Servers are too busy

Ha ha, same problem and for me.
But in my case - I already play in L4D2 on my MacPro and in one (perfect) day I got: "The Steam Servers are too busy"... and Near one week I can't play this game. "that's all, folks!"
From 11 of Nov. I send this letter to Valve teh. supp.:
=============
Dear All,

On last week I got Issue - "The Steam Servers are too busy" (or it's write "Download starting..." and nothing) for my L4D2 acc. on my MacBook Pro, I wait for 5 days before write this letter. I try 1) change connection servers to transfer downloads 2) launch this game from different locations (to check problems with ISP) and it's don't help. And my second game - CS - works fine. Last hope - In accordance with one of your tips - it's to delete any *.ncf files, but I don't want to do this, because in this case I need to re-transfer again >7Gigs of data, but it's too much for my current ISP - velocity will be near 512 Kbits.
If you give me any advice I'll be grateful to you.
=============

I saw some posts on this forum abt of this problem... so.. 1) I think Valve don't provide me with any reply 2) one way - it's delete all *.ncf files and re-trasfer > 7 Gigs again. But it's not a guarantee, what same problems arise in future....
I'll do it on next week, if I don't find any over solution.
  Reply With Quote
Old 11-14-2010, 02:33 PM   #3
Larix
 
Guest
Posts: n/a
So, I continue

I don't got any reply from Valve about of my problem and today at morning I delete all "ncf" file for L4D2 game. And re-start Steam. So, my Mac restart it, transfer near 20 Mb on my Mac and while it transfer, it synchronizing local data. It wrote, what synchronization takes near 20 mins. But in 20 mins it's don't stop it and I can't see - how many it's takes more because MAc constantly freeze. I decide to leave it until everning. 12 hours later I come back and I saw, what it's synchronized 99% -
11.208,8 megs from 11.202,9 megs. And synchronization paused.
I decide to restart Steam…. it was wrong conclusion. I make 2 actions: 1) Open Steam 2) try to resume download. And this 2 actions takes from me 40 mins! My computer was unassailable for me. After 40 mins it try resume download, but can't do it. I reboot Mac, restore old "ncf" files, re-start Steam and try (via menu) to "delete local files" of L4D2 - but no result, files still be here. When, I remove all Steam files manually. For me it was a terrible nightmare and I think Valve Co. don't think about of Mac users - we are not so big part of market and they may don't care about of us.
  Reply With Quote
Old 11-14-2010, 03:25 PM   #4
progressia
 
Guest
Posts: n/a
U have to be joking....please use the search function as there are at least 3 other threads existing on this very issue!

Link to threads: http://forums.steampowered.com/forum....php?t=1568718
http://forums.steampowered.com/forum....php?t=1518936
http://forums.steampowered.com/forum....php?t=1475493
http://forums.steampowered.com/forum....php?t=1563403

Solution:
Quote:
Go in to user/library/application support/steam/steamapps and DELETE the 'left 4 dead 2 client.ncf' and 'left 4 dead 2 mac content.ncf' and 'left 4 dead 2 common.ncf' (some of u may or may not have this file, but it doesn't matter whether u do or dont). Of course, make sure you've got L4D2 uninstalled (i know it's not uninstalled properly because the game is broken) AND then quit Steam before doing this!! After they're deleted, run Steam again, and re-download L4D2 again
This has worked for many, I hope it works for u.
  Reply With Quote
Old 11-14-2010, 10:44 PM   #5
Larix
 
Guest
Posts: n/a
Quote:
Originally Posted by progressia View Post
U have to be joking....please use the search function as there are at least 3 other threads existing on this very issue!

Link to threads: http://forums.steampowered.com/forum....php?t=1568718
http://forums.steampowered.com/forum....php?t=1518936
http://forums.steampowered.com/forum....php?t=1475493
http://forums.steampowered.com/forum....php?t=1563403

Solution:

This has worked for many, I hope it works for u.
As I told before:

Quote:
delete all "ncf" file for L4D2 game. And re-start Steam. So, my Mac restart it, transfer near 20 Mb on my Mac and while it transfer, it synchronizing local data. It wrote, what synchronization takes near 20 mins. But in 20 mins it's don't stop it and I can't see - how many it's takes more because MAc constantly freeze. I decide to leave it until everning. 12 hours later I come back and I saw, what it's synchronized 99% -
11.208,8 megs from 11.202,9 megs. And synchronization paused.
At present moment I don't have any desire to re-transfer from Stem servers 17 Gigs of data for my L4D2 & CS.
  Reply With Quote
Old 11-20-2010, 09:32 AM   #6
crimson_penguin
 
Guest
Posts: n/a
Quote:
Originally Posted by progressia View Post
U have to be joking....please use the search function as there are at least 3 other threads existing on this very issue!
Did you read any full post in this thread? Please read the last paragraph of my original post.
  Reply With Quote
Old 11-20-2010, 01:55 PM   #7
wetnap
 
Banned
Join Date: Feb 2010
Reputation: 44
Posts: 791
Quote:
Originally Posted by progressia View Post
U have to be joking....please use the search function as there are at least 3 other threads existing on this very issue!

Link to threads: http://forums.steampowered.com/forum....php?t=1568718
http://forums.steampowered.com/forum....php?t=1518936
http://forums.steampowered.com/forum....php?t=1475493
http://forums.steampowered.com/forum....php?t=1563403

Solution:

This has worked for many, I hope it works for u.
That is an awful solution

Seriously valve...you guys need to fix this. It happened to me as well, suddenly a perfectly good install now won't run, it just opens the game validation over and over.
wetnap is offline   Reply With Quote
Old 09-17-2011, 06:16 AM   #8
drskll
 
Join Date: Aug 2011
Reputation: 0
Posts: 11
Same problem exactly..worked fine for weeks..then the standard valve cop-out, before someone spams endless links about how this problem has been sorted before..ive tried it iv already spent the entire day looking over forums trying crap, deleting files, re-installing files, moving files, changing locations...i thought i paid money to i dunno...actually play my games..not screw around and do everything-but..totally ridiculous, & unacceptable..my macbook pro is less than a month old..its totally clean..everything else runs fine..you cannot charge money for a product then release unstable updates..or provide no support whatsoever..its incredibly slack.
No customer should have to be digging through system logs & files to run a game..its beyond ridiculous..and then getting diverted to a handful of links like your a total moron..who hasn't ALREADY BEEN TO THOSE LINKS A THOUSAND TIMES OVER AND DONE ALL THE USELESS CRAP THEY TOLD YOU TO DO..The games appears broken..i don't know why, if i did id fix it, I didn't do anything but play the goddam thing..id like to know why i can longer launch this application..without being told the same stuff..THAT DOES NOT WORK, over, and over, and over, and over , and over...etc, gets boring..except i paid good obey for this, its the only game i actually enjoy on steam for mac..and the bottom line is..it does not work
drskll is offline   Reply With Quote
Old 09-23-2011, 06:46 AM   #9
macxuser
 
Join Date: Oct 2010
Reputation: 4
Posts: 85
Exact same here just keeps on validating everytime i try to run the game
macxuser is offline   Reply With Quote
Old 09-23-2011, 10:51 AM   #10
neema_t
 
 
 
Join Date: Jun 2010
Reputation: 34
Posts: 238
Same here, the fix didn't work for me either so I deleted my local game files (from inside Steam) and now I can't download them again either! Good thing I never really played L4D2, but still, I paid however little for 7-8gb of useless files.
neema_t is offline   Reply With Quote
Old 07-05-2012, 05:40 AM   #11
SlimyGuy
 
 
 
Join Date: May 2012
Reputation: 0
Posts: 5
I have a somewhat different problem. I have had l4d2 for 3 months now and suddenly for no reason when I start it up nothing happens. I see the starting l4d2 window but then nothing happens. When I check my bar I see hl2_osx on it. When I right click it just says the application is not responding and I should force quit it. From my experience whenever I have to force quit an app on my computer it starts lagging like crazy, but my mac runs just fine with the pointless hl2_osx there. And when I do force quit it shows no struggle to stay on like other games I played. So can I get some help please?

Last edited by SlimyGuy: 07-05-2012 at 05:41 AM. Reason: Grammar fix
SlimyGuy is offline   Reply With Quote
Old 01-24-2013, 04:14 PM   #12
pistolero75
 
 
 
Join Date: Jan 2013
Reputation: 0
Posts: 1
Talking I found a simple fix for my situation

I read all the posts in this thread and the other threads and didn't see the "fix" that pertained to what was going on with me. I have been playing Left 4 Dead and Left 4 Dead 2 for quite awhile and all of a sudden last week, it stopped working. I would click the executable icon for this to start and the Steam window would come up saying that it is validating and then quickly disappear. I tried uninstalling it and reinstalling it. I tried exiting steam and starting it as the admin. I tried uninstalling Steam and lost all the games I have installed. Before I did all this, I tried starting other games that I had on my steam library and worked just fine.

I was irritated to say the least so I starting messing around with my firewall. I have Comcast cable. They offer a free Norton Anti Virus with ConstantGuard thru there Xfinity service. I started spamming the hell out of the executable icon for Left 4 Dead and after about 20 clicks I got a message from the ConstantGuard interface saying that this was being blocked. I went into that interface and saw that both Left 4 Dead and Left 4 Dead 2 was blocked. I have no idea why they were because I didn't ask for that to happen nor did I know that there is a difference between the "smart firewall" on Norton Antivirus and Constant Guard which is a service that comes with Comcast Cables Xfinity.

Im not saying that this is the fix for you but if you have Xfinity thru Comcast Cable and have ConstantGuard installed on your system then get into that interface and look for the items that are being blocked. They are NOT the same as whats on your firewall. It was the ConstantGuard that was not allowing the game to start.

Last edited by pistolero75: 01-24-2013 at 04:16 PM.
pistolero75 is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Discussions > Steam for Mac > Steam


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 06:37 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2012, All Rights Reserved.