Go Back   Steam Users' Forums > Steam Game Discussions > D - G > Fallout series

Reply
 
Thread Tools Display Modes
Old 12-16-2010, 11:11 AM   #1
kingrex37
 
Join Date: Dec 2010
Reputation: 0
Posts: 7
Fallout 1 Graphics Glitch

I just got a new used computer and I uploaded Steam and download Fallout 1 (which I already owned and used on other computers without any problems) but now whenever I try to play it, every few seconds the screen blacks out and to get rid of it I have to "move" the screen e.g. talk to a character, scroll around the screen, move the mouse over things. Any ideas on how to fix it?
kingrex37 is offline  
Reply With Quote
Old 12-16-2010, 12:48 PM   #2
Hawkmoon
 
Join Date: Nov 2010
Reputation: 208
Posts: 126
Hmm, is this the problem where the entire screen goes black and you have to 'paint' the image back on using the cursor? Well I have slight OCD so I always rather enjoyed methodically painting it back :P but there is one thing you can try. You'll need to play in 16bit high colour with an 800x600 desktop area.

1. Click on Start
2. Click on Settings
3. Click on Control Panel
4. Double click on Display icon
5. Click on the Settings tab

On the left is the colour palette. Make sure it reads 16bit high colour and on the right the desktop area reads 800x600.

Click Start -> Run, type in 'msconfig', and press OK. Click the 'Startup' tab click 'Disable All', click the 'Services' tab, click 'Hide All Microsoft Services' then click 'Disable All', press OK, and restart.

Before running the game, go to Start, right-click on the link you would use to start the game, click 'Properties', and click the 'Compatibility' tab. Set compatibility mode for Windows 95, 640x480, 256 colors, and press OK.

That should fix your error.
Hawkmoon is offline   Reply With Quote
Old 12-16-2010, 01:45 PM   #3
Tessou
 
Join Date: Dec 2010
Reputation: 0
Posts: 3
If that fails, find the Fallout folder in your Steam directory and edit the ddraw.ini file in notepad. You will see a huge mess of text, within it this line:

Quote:
to 0 for 8 bit fullscreen
;Set to 1 for 8 bit windowed
;Set to 4 for dx9 fullscreen
;Set to 5 for dx9 windowed
;Mode 1 requires your desktop colour depth to be set to 32 bit
;Windowed modes incur a performance hit. (Modes 1 and 5 more so than mode 3)
;The 16 bit colour modes cause movies to display incorrect colours, and slows down fades
;dx9 modes cause some corruption of movies, but not as bad as 16 bit colour modes
;dx9 modes work with fallout 1, but results in movies being completely corrupted
Mode=0
Change the "Mode=0" to 4, save the file (not as txt if it asks you to), and run the game. It should patch up video problems aside from movies within the game (which will have some glitches, but it can't be helped).
Tessou is offline   Reply With Quote
Old 07-08-2011, 09:37 PM   #4
Burcalius
 
Guest
Posts: n/a
Thank you a million times Tessou!

That fixed my game back to normal. Minus the odd glitch in the videos. But who cares about the vids anyways lol
  Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > D - G > Fallout series


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 09:53 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.