Go Back   Steam Users' Forums > Steam Game Discussions > Q - S > SimCity 4

Reply
 
Thread Tools Display Modes
Old 12-21-2010, 12:54 PM   #1
Shockka
 
 
 
Join Date: Dec 2010
Reputation: 0
Posts: 37
Widescreen on Steam version?

I'm trying to run the game in 1920x1080, but when I try to start the game with the .exe + "-CustomResolution:enabled -r1920x1080x32" (steam/steamapps/common/simcity4/), it won't start at all. I've never before tried anything like that with a steam game; will that work at all or will I have to do it another way?

Help is appreciated!
Shockka is offline  
Reply With Quote
Old 12-21-2010, 02:09 PM   #2
fastica
 
Banned
Join Date: Feb 2007
Reputation: 0
Posts: 12
Quote:
Originally Posted by Shockka View Post
I'm trying to run the game in 1920x1080, but when I try to start the game with the .exe + "-CustomResolution:enabled -r1920x1080x32" (steam/steamapps/common/simcity4/), it won't start at all. I've never before tried anything like that with a steam game; will that work at all or will I have to do it another way?

Help is appreciated!
Maybe the game is in windowed mode. Try adding -f
fastica is offline   Reply With Quote
Old 12-21-2010, 08:49 PM   #3
jdenm8
 
Join Date: Jun 2010
Reputation: 42
Posts: 120
It is recommended that you apply your command line options to the shortcut, not to the EXE.

I'd add SC4 again as a Non-Steam Game (using the EXE in the steamapps folder, does work, I've done it with Portal to see if it works), then add the commands to the shortcut.

To be safe, I'd add -f to the shortcut too, so it should look like something like:
"root\steamapps\user\SimCity 4\Apps\SimCity 4.exe" -f -CustomResolution:enabled -r1920x1080

Make sure the commands are outside the commas.

(that path is adapted from my Retail Disc installation and may not be accurate to the Steam version)
jdenm8 is offline   Reply With Quote
Old 12-22-2010, 04:40 AM   #4
Shockka
 
 
 
Join Date: Dec 2010
Reputation: 0
Posts: 37
Thanks for your replies. I found the solution: A command line can be added right from the Steam menu; no tampering with a game file or shortcut neccessary.
Shockka is offline   Reply With Quote
Old 12-28-2010, 04:27 PM   #5
SSWeltenfeind
 
 
 
Join Date: Oct 2009
Reputation: 214
Posts: 1,024
There is no need to use shortcuts. Just set that on the Launch Options of the game.
SSWeltenfeind is offline   Reply With Quote
Old 12-28-2010, 08:35 PM   #6
City Builder
 
 
 
Join Date: Mar 2009
Reputation: 41
Posts: 1,332
Quote:
Originally Posted by SSWeltenfeind View Post
There is no need to use shortcuts. Just set that on the Launch Options of the game.
How?

As far as I can tell 1920x1200 is not an 'official' supported resolution so it's got to be done on the command line, (i.e. in the shortcut).

Is there some other way?
City Builder is offline   Reply With Quote
Old 12-28-2010, 11:24 PM   #7
RhiannOn
 
Join Date: Oct 2010
Reputation: 26
Posts: 20
In your steam library right click on Simcity 4 deluxe. Click on properties, then on the General tab click on "Set Launch options".
This is what I pasted and the game now runs at 1920x1200 fine
-intro:off -CustomResolution:enabled -r1920x1200x32

The intro off part stops the vid from showing at the beginning and you go straight to the "maps". If you like the video just dont put -intro:off

Hope this helps

Last edited by RhiannOn: 12-28-2010 at 11:28 PM.
RhiannOn is offline   Reply With Quote
Old 12-29-2010, 02:05 AM   #8
City Builder
 
 
 
Join Date: Mar 2009
Reputation: 41
Posts: 1,332
Thanks Rhiannon,

I guess since I don't generally launch the games from the steam client, I never thought mush about it. But it's good for when I do.

Thanks very much
City Builder is offline   Reply With Quote
Old 01-14-2011, 09:48 AM   #9
muppetts
 
Join Date: Sep 2006
Reputation: 0
Posts: 143
Quote:
Originally Posted by RhiannOn View Post
In your steam library right click on Simcity 4 deluxe. Click on properties, then on the General tab click on "Set Launch options".
This is what I pasted and the game now runs at 1920x1200 fine
-introff -CustomResolution:enabled -r1920x1200x32

The intro off part stops the vid from showing at the beginning and you go straight to the "maps". If you like the video just dont put -introff

Hope this helps
Thanks for this!!!!!
muppetts is offline   Reply With Quote
Old 05-05-2011, 07:18 AM   #10
z0diakwarrior
 
Join Date: Oct 2010
Reputation: 15
Posts: 122
just bought needs to be bumped solved my issue.
z0diakwarrior is offline   Reply With Quote
Old 05-05-2011, 10:42 AM   #11
nerves82
 
 
 
Join Date: Nov 2009
Reputation: 0
Posts: 35
Worked for me as well. I use 1360x768 and I just replaced the res numbers in the code line with the ones I needed. Thanks.
nerves82 is offline   Reply With Quote
Old 03-03-2012, 05:34 AM   #12
Atruss
 
Join Date: Oct 2010
Reputation: 0
Posts: 3
Setting this command line
-CustomResolution:enable -r1680x1050x32 -f -Introff
the game scales resolution to 1600x1200, any tips?
Atruss is offline   Reply With Quote
Old 03-03-2012, 11:18 AM   #13
icharus5559
 
 
 
Banned
Join Date: Feb 2012
Reputation: 17
Posts: 98
Hmm.. Same for me O,o

-nvm

http://www.simcitycentral.net/2010/0...in-widescreen/

-r1920x1080x32 -CustomResolution:enabled


Switch the numbers and custom res

Last edited by icharus5559: 03-03-2012 at 11:23 AM.
icharus5559 is offline   Reply With Quote
Old 03-04-2012, 03:29 PM   #14
jdenm8
 
Join Date: Jun 2010
Reputation: 42
Posts: 120
Quote:
Originally Posted by Atruss View Post
Setting this command line
-CustomResolution:enable -r1680x1050x32 -f -Introff
the game scales resolution to 1600x1200, any tips?
You have the "D" in "enabled" missing.
jdenm8 is offline   Reply With Quote
Old 03-04-2012, 07:19 PM   #15
Rellik66
 
Join Date: Dec 2010
Reputation: 117
Posts: 333
Yup, it's supposed to be:

-CustomResolution:enabled -r1680x1050x32 -f -intro:off
Rellik66 is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > Q - S > SimCity 4


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 03:59 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.