Go Back   Steam Users' Forums > Steam Game Discussions > Q - S > Star Wars collection > Dark Forces

Reply
 
Thread Tools Display Modes
Old 01-04-2011, 12:03 PM   #1
Amander
 
 
 
Join Date: Feb 2010
Reputation: 561
Posts: 8,142
My DOSBox configuration

I had some problems running this game with the default settings and optimized it a little, here's the result
Code:
[sdl]
fullscreen=true
output=ddraw
sensitivity=250

[render]
aspect=true
scaler=hq2x

[cpu]
cycles=20000

[autoexec]
mount c "game"
c:\
dark.exe
exit
The changes I added are in bold. They solve the palette problem I had (you know, the "LSD mode" some older games show), enforce correct aspect ratio and increase the mouse sensitivity. Also, the scaler makes the game look better.

To use that, go top [Your Steam directory]\SteamApps\Common\Dark Forces, find dosbox.conf there, open it with notepad and replace the content with everything above.

Last edited by Amander: 03-27-2011 at 07:13 PM.
Amander is offline  
Reply With Quote
Old 05-29-2011, 02:08 PM   #2
Dragonsbrethren
 
 
 
Join Date: Mar 2010
Reputation: 781
Posts: 5,703
I use this:

Code:
[sdl]
fullscreen=true
fullresolution=1600x1200
output=openglnb

[render]
scaler=none
aspect=true

[cpu]
cycles=auto

[mixer]
rate=49716
blocksize=4096
prebuffer=30

[sblaster]
sbtype=sb16
sbbase=220
irq=7
dma=1
hdma=5
sbmixer=true
oplmode=auto
oplemu=default
oplrate=49716

[autoexec]
@echo off
mount c game
c:
dark
exit
OpenGL enables the Steam overlay; openglnb is a "sharper" renderer than standard opengl and looks better if you're trying to replicate the look of the original. 1600x1200 is my desktop resolution and just happens to be the perfect res for scaling old 320x200 games up to a 4:3 aspect ratio as they would've been back in the day.

The overlay is, unfortunately, kind of unresponsive with DOSBox, but at least you can see what people message you before you alt-tab out of the game to reply. I also recommend dropping in the newest version of dosbox.exe to replace the one Steam ships with.
Dragonsbrethren is offline   Reply With Quote
Old 06-22-2011, 05:51 AM   #3
Knight99k
 
Join Date: Jun 2011
Reputation: 4
Posts: 23
Thank you both for helpful advice.
Knight99k is offline   Reply With Quote
Old 06-22-2011, 07:27 AM   #4
Amander
 
 
 
Join Date: Feb 2010
Reputation: 561
Posts: 8,142
I tried OpenGL and didn't get the overlay to work.
Amander is offline   Reply With Quote
Old 07-06-2011, 11:33 AM   #5
azraal
 
Join Date: May 2010
Reputation: 0
Posts: 72
Here is mine:
it should permit to enable a better sound (in theory) and configure your keyboard...

Code:
[sdl]
fullscreen=true
fulldouble=true
fullresolution=desktop
windowresolution=original
output=opengl
autolock=true
sensitivity=100
waitonerror=true
priority=higher,normal
usescancodes=true
overscan=0

[dosbox]
language=
machine=svga_s3
vmemsize=64
captures=capture
memsize=128

[cpu]
core=auto
cputype=auto
cycles=auto
cycleup=10
cycledown=20

[mixer]
nosound=false
swapstereo=false
rate=44100
blocksize=1024
prebuffer=20

[midi]
mpu401=intelligent
mididevice=default
midiconfig=
mt32ReverseStereo=off
mt32DAC=auto
mt32reverb.mode=auto
mt32reverb.time=5
mt32reverb.level=3


[sblaster]
sbtype=sb16
sbbase=220
irq=7
dma=1
hdma=5
sbmixer=true
oplmode=auto
oplemu=default
oplrate=44100
hardwarebase=220


[autoexec]
mount c "game"
c:\
install.exe
dark.exe
exit
Read first!
- Backup your jedi.cfg in the game folder in case you screw the config (I don't really see how you could, but do so anyway... better safe than sorry)

-Launch the game as you usually do...

- first select "Change sound setup":
If you're not used to configuring the sound of DOS programs hit "e" and follow the instructions on screen...
If you're used to this then hit "c" to select your sound cards (I do with Roland port 330 for music and sb16 port 220 irq 7 dma 1)

- Then select "configure Controller setup":
This one should be easy enough... Note that you can't use your gamepad or joystick: Too lazy to make it work as I don't use one myself...

- Configure to your liking then exit. It should goes in game...

- If your key config don't fit you quit and launch the game again to get to the menu... If it's good then open your dosbox.conf
and change the line "install.exe" to "#install.exe" save then launch the game... it will bypass the configuration menu and put you in game

Enjoy...

Last edited by azraal: 07-06-2011 at 11:36 AM. Reason: Typo
azraal is offline   Reply With Quote
Old 07-08-2011, 01:04 PM   #6
ParadoxSalem
 
Join Date: Mar 2010
Reputation: 457
Posts: 3,687
Quote:
Originally Posted by Dragonsbrethren View Post
I use this:

Code:
[sdl]
fullscreen=true
fullresolution=1600x1200
output=openglnb

[render]
scaler=none
aspect=true

[cpu]
cycles=auto

[mixer]
rate=49716
blocksize=4096
prebuffer=30

[sblaster]
sbtype=sb16
sbbase=220
irq=7
dma=1
hdma=5
sbmixer=true
oplmode=auto
oplemu=default
oplrate=49716

[autoexec]
@echo off
mount c game
c:
dark
exit
OpenGL enables the Steam overlay; openglnb is a "sharper" renderer than standard opengl and looks better if you're trying to replicate the look of the original. 1600x1200 is my desktop resolution and just happens to be the perfect res for scaling old 320x200 games up to a 4:3 aspect ratio as they would've been back in the day.

The overlay is, unfortunately, kind of unresponsive with DOSBox, but at least you can see what people message you before you alt-tab out of the game to reply. I also recommend dropping in the newest version of dosbox.exe to replace the one Steam ships with.
+rep, good sir. I got the game today on the sale, and this works far better than the default configuration.
ParadoxSalem is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > Q - S > Star Wars collection > Dark Forces


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 11:26 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2012, All Rights Reserved.