Go Back   Steam Users' Forums > Steam Game Discussions > Q - S > Ship Simulator Extremes

Closed Thread
 
Thread Tools Display Modes
Old 01-30-2011, 04:00 AM   #1
killkhan
 
Join Date: Dec 2009
Reputation: 75
Posts: 949
Poorly optimised?

Vista 32
2gig of ram
GTS250
Quad Core 2.66

These are hardly ground breaking graphics and I'm struggling to run it. I'm able to run anything else at a decent level so I'm wondering if it's just poorly optimised?
killkhan is offline  
Old 01-30-2011, 07:44 AM   #2
killkhan
 
Join Date: Dec 2009
Reputation: 75
Posts: 949
Come on, somebody must have some suggestions/answers.
killkhan is offline  
Old 01-30-2011, 07:50 AM   #3
killkhan
 
Join Date: Dec 2009
Reputation: 75
Posts: 949
Never mind. I've come to the conclusion that this is one of the worst attempts at a game, of any genre, that I've played.
killkhan is offline  
Old 01-30-2011, 12:19 PM   #4
lonewolfdon
 
Join Date: Mar 2009
Reputation: 328
Posts: 3,101
Three posts in a row within a few hours of each other?
Patience is a virtue.

Here's a post that may be of some help:
http://forums.steampowered.com/forum...12&postcount=3

You could also try asking for help at their forums:
http://80.95.161.114/shipsim/forum/i...oard,87.0.html
lonewolfdon is offline  
Closed Thread

Go Back   Steam Users' Forums > Steam Game Discussions > Q - S > Ship Simulator Extremes


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 11:17 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.