Go Back   Steam Users' Forums > Steam Game Discussions > Q - S > Shadowgrounds series

Reply
 
Thread Tools Display Modes
Old 01-27-2011, 08:58 AM   #1
FAButzke
 
Join Date: Jul 2010
Reputation: 146
Posts: 275
Shadowgrounds Survivor crash at 95%

I have a similar problem.
I've beaten Shadowgrounds just fine, without any problem whatsoever (awesome game by the way ) but Survivor refuses to finish loading the very first mission. It crashes to desktop without any errors when the loading bar reaches 95%

I've tried to:

lower all the settings
lower the resolution
disable sounds
verify the game cache
run the game in windowed mode

I'm running:

Windows XP SP3
Core 2 Duo 8500
Geforce 280 GTX

All drivers are up to date. (Including the drivers for the motherboard and sound)

Any ideas?
I've not tried yet the "save game workaround" because I've thought it didn't apply to my case, but I can try if you think it's relevant

Thanks in advance.
FAButzke is offline  
Reply With Quote
Old 01-28-2011, 03:46 AM   #2
JoelFB
 
JoelFB's Avatar
 
Frozenbyte
Join Date: May 2006
Reputation: 494
Posts: 3,235
Quote:
Originally Posted by FAButzke View Post
Survivor refuses to finish loading the very first mission. It crashes to desktop without any errors when the loading bar reaches 95%
I think this is simply a case of missing or otherwise messed up PhysX drivers. So download the latest PhysX drivers, install, and run the game again. Should work now.

(NVIDIA graphics drivers may also include some PhysX drivers but I'm not quite sure if the installation always 'works', so the above is probably a better idea.)

__________________
// Joel, Frozenbyte team, developers of Trine, Trine 2, Shadowgrounds & SG Survivor - Follow us on Twitter
JoelFB is offline   Reply With Quote
Old 01-28-2011, 05:02 AM   #3
FAButzke
 
Join Date: Jul 2010
Reputation: 146
Posts: 275
No luck =(
I've tried both methods. The crash still occurs at the exact same spot.
But thanks anyway. =)
I'll try to remove everything related to physx and then reinstall, see what happens then.

Edit:

I think it's not a physx related problem. Mirror's Edge (which also uses physx) is running fine. So, I'm out of options =(

Last edited by FAButzke: 01-28-2011 at 05:18 AM.
FAButzke is offline   Reply With Quote
Old 01-31-2011, 02:28 AM   #4
JoelFB
 
JoelFB's Avatar
 
Frozenbyte
Join Date: May 2006
Reputation: 494
Posts: 3,235
I moved this to its own thread, I hope you don't mind.

The problem sounds quite interesting... One thing you could try is to download the non-Steam demo and see if that behaves the same way. It could be the WMV drivers or something (although very unlikely)...

And of course, you could delete and re-download the entire game. It doesn't sound like the problem is related to bad data as such, but you never know...

__________________
// Joel, Frozenbyte team, developers of Trine, Trine 2, Shadowgrounds & SG Survivor - Follow us on Twitter
JoelFB is offline   Reply With Quote
Old 02-02-2011, 03:14 PM   #5
FAButzke
 
Join Date: Jul 2010
Reputation: 146
Posts: 275
Hey.
No, I don't mind =)

Thanks for replying. I'll try that, and see how it goes.
FAButzke is offline   Reply With Quote
Old 02-04-2011, 02:29 PM   #6
FAButzke
 
Join Date: Jul 2010
Reputation: 146
Posts: 275
I'm sorry to report that it didn't work... =(
I've reinstalled the game but no dice.
The demo (downloaded from gamespot) also didn't work =( (crashed at 95% too)

Well, it seems I'm cursed or something.

Perhaps it's time for a windows reinstall? Guess that's what's left. =P

Ah... One piece of information that might be useful:

During the demo installation, the physx install window poped up and, after clicking "Yes" to agree with the license, the following screen was displayed:

http://img828.imageshack.us/img828/6845/ageia.jpg

I've waited several minutes and nothing else happened. I had to click on 'Cancel' to resume the game installation. =(

That didn't happen when I installed using the Nvidia drivers.
FAButzke is offline   Reply With Quote
Old 02-05-2011, 09:16 AM   #7
JoelFB
 
JoelFB's Avatar
 
Frozenbyte
Join Date: May 2006
Reputation: 494
Posts: 3,235
I'm pretty much out of ideas. You can check if the log.txt or error_log.txt (probably in the root folder of the game) give you any ideas, but I doubt it has anything sensible. Any related problems would be at the bottom of the file.

You could try the WMV/WMP drivers (the version we used here, but that probably won't help.

You could also try running the game without sounds, and with the lowest possible graphics settings, and see if that makes any difference...

Other than these, I have no clue.

__________________
// Joel, Frozenbyte team, developers of Trine, Trine 2, Shadowgrounds & SG Survivor - Follow us on Twitter
JoelFB is offline   Reply With Quote
Old 02-05-2011, 02:50 PM   #8
FAButzke
 
Join Date: Jul 2010
Reputation: 146
Posts: 275
No problem. I had a blast playing Shadowgrounds, and the quick responses you gave me were enough to give Frozenbyte the credibility it deserves. =)

I would be forced to do a windows reinstall eventually, so, no big deal.

I'll try first, of course, those sugestions you've mentioned.

Thanks again and keep up the good work =)
FAButzke is offline   Reply With Quote
Old 02-07-2011, 09:36 AM   #9
JoelFB
 
JoelFB's Avatar
 
Frozenbyte
Join Date: May 2006
Reputation: 494
Posts: 3,235
Ok. I should say that I'm not convinced that a Windows reinstall will help for sure, but of course by all means it might.

One further thing you could try is to download the demo for Trine, it uses pretty much all the same things as SGS. If Trine crashes too, then it could be easier to find the reason...

__________________
// Joel, Frozenbyte team, developers of Trine, Trine 2, Shadowgrounds & SG Survivor - Follow us on Twitter
JoelFB is offline   Reply With Quote
Old 02-20-2011, 08:55 AM   #10
FAButzke
 
Join Date: Jul 2010
Reputation: 146
Posts: 275
Hey, sorry. I didn't see your post until now.
I'm not convinced either. =)
I have Trine (which is also a great game) and it's working fine. That's why the only thing left to do is a complete reinstall. =P (I'm just not in the mood to do it right now)
Thanks again for your support, man. I wish more companies could spare their time to actually answer their customers like you guys do.
Best of luck to you.
FAButzke is offline   Reply With Quote
Old 02-21-2011, 08:56 AM   #11
JoelFB
 
JoelFB's Avatar
 
Frozenbyte
Join Date: May 2006
Reputation: 494
Posts: 3,235
Thanks, and if the reinstall is something you'd have to do eventually anyway, then I guess that sounds like a plan. Let me know how it goes (but no pressure). (SGS is also available on Linux if that's of any interest.)

__________________
// Joel, Frozenbyte team, developers of Trine, Trine 2, Shadowgrounds & SG Survivor - Follow us on Twitter
JoelFB is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > Q - S > Shadowgrounds series


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 06:51 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.