Go Back   Steam Users' Forums > Steam Discussions > Steam for Mac > Third Party games

Reply
Click here to go to the first staff post in this thread.  
Thread Tools Display Modes
Old 02-26-2011, 01:00 PM   #1
koplux
 
Join Date: Jan 2011
Reputation: 0
Posts: 1
Question Two Worlds 2 won't start

please help. Whenever I try to start two worlds 2 on my macbook pro, the only thing that happends is that it tries to launch, but in stead of the game starting my TW2 playingtime increases with one minute... Why? Can someone please help me if they know something I don't know... oh, and also, I have tried to reinstall it, but same thing...
koplux is offline  
Reply With Quote
Old 02-26-2011, 06:15 PM   #2
jondgar
 
Join Date: Jul 2010
Reputation: 12
Posts: 16
Downloaded, installed and updated, verified and defragmented. Click Play. Preparing to launch briefly flashes up, then nothing except Steam counting the playtime. Uninstalled and reinstalled only to find the problem remains.

iMac 24" |:| OS X 10.6.6 |:| C2D 2.93GHz |:| 4GB |:| Radeon HD 4850 512MB

I sent a 'question' to support about this problem on Friday, 25th Feb, 2011.

So far, no response.

I hope this gets fixed quickly.
jondgar is offline   Reply With Quote
Old 02-27-2011, 12:47 PM   #3
OddIceTroll
 
Guest
Posts: n/a
I'm having same issue. I've tried reinstalling, I checked permissions of steam app directories, sudo from terminal, my imac 27" is updated with latest patches.
This was copied from console
2/27/11 3:39:29 PM com.apple.launchd.peruser.501[95] ([0x0-0x3c03c].pl.realitypump.tw2[512]) posix_spawn("/Users/username/Library/Application Support/Steam/SteamApps/common/two worlds ii/Two Worlds II.app/Contents/MacOS/Two Worlds II", ...): Permission denied
2/27/11 3:39:29 PM [0x0-0x31031].com.valvesoftware.steam[459] Couldn't get PID for app /Users/username/Library/Application Support/Steam/SteamApps/common/two worlds ii/Two Worlds II.app (-600)
  Reply With Quote
Old 02-27-2011, 10:57 PM   #4
icy1007
 
Join Date: Oct 2004
Reputation: 5
Posts: 918
If its not starting, I would try to just play it using boot camp in Windows. At least until your issue is resolved.
icy1007 is offline   Reply With Quote
Old 02-28-2011, 12:21 AM   #5
lesslinger71
 
Guest
Posts: n/a
Same here. I started my thread on Friday and still don't have any help or answers. It works on my Macpro but I just got my new Macbook Pro with the thunderbolt technology and it wont even start. I have same problems as everyone else.
  Reply With Quote
Old 02-28-2011, 04:49 PM   #6
z0mbi3guit4rist
 
Join Date: Jun 2010
Reputation: 0
Posts: 21
Its not working for me either. I also sent a question about a refund if they don't provide a solution and another simply asking for a solution or at least assurance that somethings being done and an ETA on when to expect the answer.

I always feel scammed when something goes wrong on steam, I spent 50$ on this game hoping for something good, now I can't even see the title screen because the game won't even open. Steam has received reports since people with macs started buying but no one from what i've googled or seen in any of the furoms has a fix. Only solutions that seem to work for a few people

I have the feeling i'm not going to get this game fixed or refunded and I just got scammed
z0mbi3guit4rist is offline   Reply With Quote
Old 02-28-2011, 05:02 PM   #7
OddIceTroll
 
Guest
Posts: n/a
Lightbulb

I fixed it for me, the app was not set to executable.
1. Open Terminal.app
2. cd /Users/username/Library/Application Support/Steam/SteamApps/common/two worlds ii/Two Worlds II.app/Contents/MacOS
3. ls -l check to see if Two Worlds II.app is set to -rwxr-xr-x
4. if not and it's set to -rw-r--r-- then chmod 755 ./Two\ Worlds\ II

Test running from steam. Hope this helps some frustrated peeps
  Reply With Quote
Old 03-01-2011, 07:02 AM   #8
jondgar
 
Join Date: Jul 2010
Reputation: 12
Posts: 16
Post How I got Two Worlds II for Mac working.

Thanks to OddIceTroll for supplying a solution. I post this as instructions for the rest of us that don't like getting their hands dirty with Terminal.

The solution to fix this game is so simple - it makes me angry that a fix still hasn't been supplied from Steam or the publishers/developers. The standard of support is truly disgusting.

The problem is that the main application is not set to executable. For Terminal savvy users, follow the instructions from OddIceTroll.

In Terminal, navigate to..
/Users/username/Library/Application Support/Steam/SteamApps/common/two worlds ii/Two Worlds II.app/Contents/MacOS
and find a file called Two Worlds II.app and set to -rwxr-xr-x using chmod 755 as shown here:

http://forums.steampowered.com/forum....php?t=1772498

I figure there's a large percentage of Mac users out there who don't know what all that means so I'll give an alternate method for the rest of us.

We do need to CHMod a file. I used a app called BatChmod which allows you to do this using a Graphical User Interface (GUI) without delving into Terminal. BatChmod can be downloaded from here:

http://www.macchampion.com/arbysoft/...d/Welcome.html

Download BatChmod.

You should get a file called 'batchmod_xxx.zip' where xxx is the version number of BatChmod. 163 is the version I downloaded.

Double-click this file to unzip it and then drag the BatChmod app to your Applications folder to install it.

Drag BatChmod to the Dock for easy access. You can drag it off later after we've finished.

Quit Steam.

Open Finder and go to your Home directory. Navigate to Library/Application Support/Steam/SteamApps/common/two worlds ii

Find Two Worlds II.app and Control+Click it (or Right-Click on it) and choose 'Show Package Contents' which will open another Finder window that shows all the files that make up the game.

Navigate to Contents/MacOS

Here you find a file called Two Worlds II. This is the file that we need to modify with BatChmod. Drag the Two Worlds II onto the BatChmod icon we put on the dock.

BatChmod launches with a window full of options. Let's go through them.

Owner should be set to your username and Group should be 'staff'. These shouldn't need changing.

The only thing we're really interested in is the line of check-boxes - three under Owner, three under Group and three under Everyone. Note that each check-box has three options - clear, dash or tick.

Under Owner, make sure you have ticks under R, W and X.

Under Group, make sure you have ticks under R and X. Make W clear.

Under Everyone, make sure you have ticks under R and X. Make W clear.

The next section have 'Change ownership and privileges' ticked while the rest of the check-boxes remain clear.

Click Apply and click Apply again in the dialogue box that asks you if you're sure.

Enter your Password to make changes to the file and decide whether or not you'd like to donate to the developer of BatChmod.

Quit BatChmod. Now is the time to remove it from the Dock if you so choose.

Launch Steam and see if Two Worlds II works.

It did the trick for me! Once again, thanks go to OddIceTroll for finding the problem and solving it. I'm sure someone from Steam could knock up a patch that could do this for everyone in no time, but hey, that's the kind of support we've become accustomed to.

Good luck everyone! I really, really hope this helps.

Last edited by jondgar: 03-01-2011 at 10:22 AM.
jondgar is offline   Reply With Quote
Old 03-01-2011, 09:11 AM   This is the last staff post in this thread.   #9
DerrickG
 
DerrickG's Avatar
 
Valve
Join Date: Mar 2008
Reputation: 417
Posts: 338
The developer is aware of the issue and we are looking into a fix. Thank you for your patience in this matter!
DerrickG is offline   Reply With Quote
Old 03-01-2011, 10:09 AM   #10
z0mbi3guit4rist
 
Join Date: Jun 2010
Reputation: 0
Posts: 21
Close(r) but not cigar. At least for me. It seems like a valid fix and I got closer to getting it started but still nothing. I had seen the icon in the dock for 2 seconds this time though, progression steams support simply can't match > lol
z0mbi3guit4rist is offline   Reply With Quote
Old 03-01-2011, 10:21 AM   #11
inaneDrivel
 
Guest
Posts: n/a
This did work for me.

The exact command I used:
Code:
chmod +x $HOME/Library/Application\ Support/Steam/SteamApps/common/two\ worlds\ ii/Two\ Worlds\ II.app/Contents/MacOS/Two\ Worlds\ II

I'm not sure whether to be happy or infuriated.
  Reply With Quote
Old 03-01-2011, 10:24 AM   #12
jondgar
 
Join Date: Jul 2010
Reputation: 12
Posts: 16
Thanks for the verbatim terminal command.
jondgar is offline   Reply With Quote
Old 03-01-2011, 11:47 AM   #13
Voryvzakone
 
Guest
Posts: n/a
It worked!

Hey it worked for me and I just got into game! Thanks a lot! I'm so happy, I have tears in my eys :'D
  Reply With Quote
Old 03-01-2011, 02:24 PM   #14
z0mbi3guit4rist
 
Join Date: Jun 2010
Reputation: 0
Posts: 21
anyone else still having a problem even after this? :/
z0mbi3guit4rist is offline   Reply With Quote
Old 03-01-2011, 03:08 PM   #15
z0mbi3guit4rist
 
Join Date: Jun 2010
Reputation: 0
Posts: 21
I just got it to work! I had to op out of the Beta that steam is offering in Steam preferences. That on top of the other stuff of course
z0mbi3guit4rist is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Discussions > Steam for Mac > Third Party games


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 04:30 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.