Go Back   Steam Users' Forums > Steam Game Discussions > # - C > Crysis series

Reply
 
Thread Tools Display Modes
Old 03-24-2011, 12:57 PM   #1
lord infamous
 
Join Date: Oct 2007
Reputation: 0
Posts: 33
CROSSFIRE FIX for flickering

Here is a temporary fix that worked for me to get rid of the massive flickering. only for ATI users.

download radeonpro

add crysis 2 profile

click the advanced tab

select the bioshock crossfire profile

RIGHT click on crysis2 profile in radeonpro and click apply

right click on crysis2 profile and launch game

Done



I am able to get full crossfire rendering on all 4 of my GPU's with fullscreen and NO flickering.

let me know if this works.

-Infamous

Last edited by lord infamous: 03-24-2011 at 02:44 PM.
lord infamous is offline  
Reply With Quote
Old 03-24-2011, 02:22 PM   #2
sadinkaraga
 
Join Date: Jan 2011
Reputation: 0
Posts: 35
I have 5970 and that dindt worked for me. There is a fix that worked for me. I was testing everything and one thing worked. Install 11.2 ati drivers and DO NOT INSTALL CROSSFIRE APPLICATION. No more flickering
sadinkaraga is offline   Reply With Quote
Old 03-24-2011, 02:25 PM   #3
Raven701
 
Join Date: Mar 2011
Reputation: 12
Posts: 561
Quote:
Originally Posted by sadinkaraga View Post
I have 5970 and that dindt worked for me. There is a fix that worked for me. I was testing everything and one thing worked. Install 11.2 ati drivers and DO NOT INSTALL CROSSFIRE APPLICATION. No more flickering
Where is that application? I didn't see it in the custom list?
Raven701 is offline   Reply With Quote
Old 03-24-2011, 02:33 PM   #4
lord infamous
 
Join Date: Oct 2007
Reputation: 0
Posts: 33
hmm, i got 2x 5970 in crossfire and it works perfect for me now
lord infamous is offline   Reply With Quote
Old 03-24-2011, 02:39 PM   #5
shr00mz
 
Join Date: Feb 2011
Reputation: 98
Posts: 621
you can just rename crysis2.exe to bioshock.exe

problem is it doesnt utilize both gpu to max and I suspect its the same with your method.
shr00mz is offline   Reply With Quote
Old 03-24-2011, 02:40 PM   #6
shr00mz
 
Join Date: Feb 2011
Reputation: 98
Posts: 621
Quote:
Originally Posted by sadinkaraga View Post
I have 5970 and that dindt worked for me. There is a fix that worked for me. I was testing everything and one thing worked. Install 11.2 ati drivers and DO NOT INSTALL CROSSFIRE APPLICATION. No more flickering
I believe you are just using one gpu without that
shr00mz is offline   Reply With Quote
Old 03-24-2011, 02:42 PM   #7
lord infamous
 
Join Date: Oct 2007
Reputation: 0
Posts: 33
Quote:
Originally Posted by shr00mz View Post
I believe you are just using one gpu without that
no sir, i know damn well with 1 gpu or windowed mode i get 45-50fps.. with crossfire im in the 120-180fps range and thats where im at
lord infamous is offline   Reply With Quote
Old 03-24-2011, 03:08 PM   #8
lemiwinks115
 
Join Date: Feb 2010
Reputation: 2
Posts: 10
I have tried running radeon pro with the Bioshock Profile, however when I attempt to run the game the steam window "Preparing to launch Crysis2" appears, immediately crashes and then will keep attempting to start... unsuccessfully. Just wondering if anyone else was having this issue running Radeon pro with the Bioshock Profile.
lemiwinks115 is offline   Reply With Quote
Old 03-24-2011, 04:14 PM   #9
lord infamous
 
Join Date: Oct 2007
Reputation: 0
Posts: 33
Quote:
Originally Posted by lemiwinks115 View Post
I have tried running radeon pro with the Bioshock Profile, however when I attempt to run the game the steam window "Preparing to launch Crysis2" appears, immediately crashes and then will keep attempting to start... unsuccessfully. Just wondering if anyone else was having this issue running Radeon pro with the Bioshock Profile.
start it in windowed mode (alt+enter)
lord infamous is offline   Reply With Quote
Old 03-24-2011, 04:19 PM   #10
Wulfstan77
 
Join Date: Jul 2010
Reputation: 0
Posts: 20
Well I tried this and it fixed my flickering put my FPS doesn't seem like its right for 2 6850's in crossfire. Only about 40-70 fps with crossfire enabled.

Im using 11.4 Preview Driver with the newest application profiles.
Wulfstan77 is offline   Reply With Quote
Old 03-25-2011, 01:51 AM   #11
sadinkaraga
 
Join Date: Jan 2011
Reputation: 0
Posts: 35
Quote:
Originally Posted by shr00mz View Post
I believe you are just using one gpu without that
Nope both gpu:s are working. I have much higher framerate and was abe to crank up 16AF.
sadinkaraga is offline   Reply With Quote
Old 03-25-2011, 01:53 AM   #12
sadinkaraga
 
Join Date: Jan 2011
Reputation: 0
Posts: 35
Quote:
Originally Posted by Raven701 View Post
Where is that application? I didn't see it in the custom list?
I mean the extra application you get when downloading the drivers to ati cards.
sadinkaraga is offline   Reply With Quote
Old 03-25-2011, 04:55 AM   #13
alpah_ger
 
Guest
Posts: n/a
i thought i got it working with this sollution.

i am not sure , because it wasn't always working (very strange).

would be great if you can tell us which DRIVER version and which PROFILE version you are using. pretty please!
  Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > # - C > Crysis series


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 03:11 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.