Go Back   Steam Users' Forums > Steam Discussions > Hardware and Operating Systems

Reply
 
Thread Tools Display Modes
Old 04-05-2011, 10:18 PM   #1
Stryker2[X]
 
Join Date: Nov 2003
Reputation: 257
Posts: 5,697
Wireless network - Strong signal, slow speed

I got a mind boggling question for you networking experts.

Linksys E2000 Router, Wireless G mode. Auto channel. Most up to date firmware.

I just moved in to my new place a few days ago. My room is in the back of the house (pretty far from the router, between maybe 3-4 walls).

In the room with the router, with my laptop, I get 15mb/s down. In the kitchen, a mere 10 feet further from the router, still full signal(with no FULL wall blocking the signal), it crawls anywhere to 3-5mb/s. In my room, with a 4/5 bar signal, it crawls to around 2-3mb/s.

I just got a wireless adapter for my desktop, it gets a FULL signal. It consistently speed tests at 2mb/s. The only time I can get the speed to change is by changing the channel my router is on, and some channels are slower, and at best I have achieved around 5mb/s.

Plugged in, I CAN GET 25mb/s! This scenario is not possible because I cannot run a 50foot network cable to my room.

In every other place I lived, I have used a WRT54GL with Tomato firmware, and if I ever had full signal, I would have my max speed. Signal correlated to speed. Here, with this router (E2000), that is NOT the case. How can TEN FEET make such a huge difference (router room to kitchen)?

If anybody can help me get to the bottom of this, I will thank you dearly.

SIDE NOTE: The PC wireless adapter I got is also Wireless-N capable, so I set the router to N to test it and was getting 15mb/s down, nearly my full speed. Unfortunately, no other computer in the house has a wireless N card, including my Macbook Pro, so this isn't an option. But this goes to show that I am capable of getting a good speed.

Last edited by Stryker2[X]: 04-05-2011 at 10:23 PM.
Stryker2[X] is offline  
Reply With Quote
Old 04-05-2011, 10:31 PM   #2
Bad_Motha
 
Banned
Join Date: Sep 2008
Reputation: 3208
Posts: 13,401
Wireless-G (54mbps max = 5mb max) is going to be slower then using an Ethernet cable that is capable of the max wired router speed of 100 or 1000 mbps. Depending on your router and LAN device.

The only way to get close to the wired speed on wireless is with Wireless-N

Trying different channels on your router and wireless device is good to see where the sweet-spot is. The Linksys WRT54G that I have was defaulted to channel 6 and I've never had a reason to change it. Sometimes you can leave the router at a certain channel and still change the channel on your wireless device, sometimes this helps. Your wireless device doesn't need to be set at the same channel as your router. Wireless devices need to be at a different channel if you have more than one, so that they do not interfere which one another or cause drop-outs.

What can also help is looking at the advanced settings your the wireless adapter in Windows (or other OS) and see if changing some of those extra settings helps. Most wireless devices have different options. Things like Prefer Max Performance, or Better Signal. If you can set to Prefer Performance and still get a decent signal, at least 2 - 3 bars, then this should be fine as you are still getting a good enough signal, while maintaining decent speed/throughput.

If you are not using any media sharing options or care about HomeGroup sharing and such, turn off IPv6 for any LAN/Wireless devices that don't use it and this can help performance as well.

Last edited by Bad_Motha: 04-05-2011 at 10:36 PM.
Bad_Motha is offline   Reply With Quote
Old 04-05-2011, 10:32 PM   #3
Stryker2[X]
 
Join Date: Nov 2003
Reputation: 257
Posts: 5,697
Quote:
Originally Posted by Bad_Motha View Post
Wireless-G (54mbps max = 5mb max) is going to be slower then using an Ethernet cable that is capable of the max wired router speed of 100 or 1000 mbps. Depending on your router and LAN device.

The only way to get close to the wired speed on wireless is with Wireless-N

Trying different channels on your router and wireless device is good to see where the sweet-spot is. My Linksys WR54G that I have was defaulted to channel 6 and I've never had a reason to change it. Sometimes you can leave the router at a certain channel and still change the channel on your wireless device, sometimes this helps. Your wireless device doesn't need to be set at the same channel as your router. Wireless devices need to be at a different channel if you have more than one, so that they do not interfere which one another or cause drop-outs.
54mb/s (54 megabits/s) is 6.75MB/s MAX. Capital MB. Meaning Megabyte. It is still CAPABLE of 54mb/s. Hitting my max internet speed (not network speed, I am not asking to hit 54mb/s wirelessly) of 15mb/s should be do-able from my room if I have a full signal, BUT IT ISN'T. I am getting 2 mb/s (megabits/s) down in my room.

Did you read the part that I said in the router room, I am getting 15-20 megabits down (wirelessly) and in the kitchen (10ft away) I am getting 5megabits down. Do you get what I am saying? At my old apartment, my old wireless-G router was more than capable of getting me full speed (10-15mb/s).

I AM GETTING 2 mb/s. MEGABITS. That is .25MB/S. CRAWLING.

Last edited by Stryker2[X]: 04-05-2011 at 10:34 PM.
Stryker2[X] is offline   Reply With Quote
Old 04-05-2011, 10:44 PM   #4
Bad_Motha
 
Banned
Join Date: Sep 2008
Reputation: 3208
Posts: 13,401
Try SPEEDTEST and see what you get.
Don't have any other web pages running/refreshing during the test.

Also what Wireless-N device are you using?
Could you link to it's specs or tell us the brand + model#

Also to get good speeds with a Wireless-N device, your Linksys E2000 router will need to be setup as Wireless (G/N). Some routers might have a setting for (B/G/N) but if you're not using B and all your devices support at least G specs, then try setting to (G/N). Usually this will negotiate the speeds a little and you might not get full speed on a Wireless-N device unless the router is set to (N-Only). It may vary though depending on the router itself and it's options/firmware. Sorry I can't provide more help on the router settings, but I'm not familiar with that particular model.
Bad_Motha is offline   Reply With Quote
Old 04-05-2011, 10:52 PM   #5
BuckALE
 
Banned
Join Date: Apr 2010
Reputation: 135
Posts: 699
Quote:
Originally Posted by Stryker2[X] View Post
Unfortunately, no other computer in the house has a wireless N card, including my Macbook Pro, so this isn't an option. But this goes to show that I am capable of getting a good speed.
This should make no difference. B, G and N are all immediately compatible. Just about every modern router should be capable of running mixed modes. Devices will simply negotiate for the highest rates they are capable of, and this won't affect any other clients.

The signal strength really doesn't have much to do with anything else either. You could have "full bars" but performance can suffer if there's a a high S/N ratio due to interference (commonly caused by electrical wiring, of which there's typically a ton of in a Kitchen).

I don't usually recommend people disable or limit available modes. This is for the same reason we don't recommend disabling auto-negotiation for ethernet links, nor recommend disabling any advertised capabilities (adv_caps).

People who do believe that it "forces" a connection to always use it's highest rate. In reality, it can cause the link to drop completely should the link not be able to maintain a given rate. Better to drop rate than to drop connection completely.

Chances are, your problem is due to interference. All you can do is re-orient, and make sure your drivers are up to date.

Last edited by BuckALE: 04-05-2011 at 10:59 PM. Reason: added babble
BuckALE is offline   Reply With Quote
Old 04-05-2011, 10:55 PM   #6
Stryker2[X]
 
Join Date: Nov 2003
Reputation: 257
Posts: 5,697
Quote:
Originally Posted by Bad_Motha View Post
Try SPEEDTEST and see what you get.
Don't have any other web pages running/refreshing during the test.

Also what Wireless-N device are you using?
Could you link to it's specs or tell us the brand + model#

Also to get good speeds with a Wireless-N device, your Linksys E2000 router will need to be setup as Wireless (G/N). Some routers might have a setting for (B/G/N) but if you're not using B and all your devices support at least G specs, then try setting to (G/N). Usually this will negotiate the speeds a little and you might not get full speed on a Wireless-N device unless the router is set to (N-Only). It may vary though depending on the router itself and it's options/firmware. Sorry I can't provide more help on the router settings, but I'm not familiar with that particular model.
My adapter is the EnGenius EUB9603H.

Here is a screenshot showing you my router is set to G/N: http://img703.imageshack.us/i/wireless.png/ - The data rate says 72 Mbps, I am getting nothing close to that.

http://www.speedtest.net/result/1238650466.png

Trust me, nothing else was running my browser or on my network to slow this test down. I can do this same test from the router room and get close to 15Mbps. Setting my router to N only is not an option, considering no other computer in this house has an N adapter (nor is it an option to get new N adapters).

PS I have bypassed the adapter wireless software before and it makes NO difference. Like I said, I get about the same speed whether on my desktop using this adapter or on my Macbook Pro in the same spot of my room.
Stryker2[X] is offline   Reply With Quote
Old 04-05-2011, 11:02 PM   #7
Bad_Motha
 
Banned
Join Date: Sep 2008
Reputation: 3208
Posts: 13,401
Try setting your router to a channel that your neighbors routers are not using (like channel 9) and see if that helps. In most cases it might not matter since you are logged into one router at a time, but that doesn't mean that they can't interfere with one another when on the same channel. The channel you choose is a distinct frequency within the 2.4 - 2.5 Ghz range. Choosing a channel no one else is using might help.

And yes like BuckALE says, just because you get good signal in the Kitchen, doesn't mean the performance will be good due to alot of possible things that can interfere with signal/performance, such as thick walls, wiring inside the walls, appliances, etc.

Forget what I said about changing your router's mixed mode (B/G/N). Normally this shouldn't matter, but I just wanted to see if setting to (N-only) resulted in better speeds overall. But like u said, your router doesn't even have this option, so no worries.

Last edited by Bad_Motha: 04-05-2011 at 11:05 PM.
Bad_Motha is offline   Reply With Quote
Old 04-05-2011, 11:21 PM   #8
Stryker2[X]
 
Join Date: Nov 2003
Reputation: 257
Posts: 5,697
Quote:
Originally Posted by Bad_Motha View Post
Try setting your router to a channel that your neighbors routers are not using (like channel 9) and see if that helps. In most cases it might not matter since you are logged into one router at a time, but that doesn't mean that they can't interfere with one another when on the same channel. The channel you choose is a distinct frequency within the 2.4 - 2.5 Ghz range. Choosing a channel no one else is using might help.

And yes like BuckALE says, just because you get good signal in the Kitchen, doesn't mean the performance will be good due to alot of possible things that can interfere with signal/performance, such as thick walls, wiring inside the walls, appliances, etc.

Forget what I said about changing your router's mixed mode (B/G/N). Normally this shouldn't matter, but I just wanted to see if setting to (N-only) resulted in better speeds overall. But like u said, your router doesn't even have this option, so no worries.
First off, the kitchen (10ft from router but no full walls) is where the speed dips dramatically. The router is in the living room. Second off, my router does have N only as an option, but only my desktop has an adapter capable of Wireless-N. If I set it to N only, it is no longer compatible with the other computers. For this reason, I have to keep it in G/N mixed mode. But yes, in Wireless-N mode I can achieve full speed.

As for changing channels, you are right. Saw on my Wireless LAN Utility that most of the routers near me were set to Channel 11, and so was mine. So I set it to 8, a channel nobody else was on. Guess what? 10mbps down! http://www.speedtest.net/result/1238661348.png

Then I did another Speedtest then got 4.2mbps http://www.speedtest.net/result/1238675978.png . So it's not consistent, but definitely better than 2mbps.

So obviously the main variable is the channel. If my auto channel doesn't work good enough (the whole point of auto is so that it finds the best channel for me) then what is a good solution? My old router (now being used in my office) uses Tomato, an amazing custom firmware. I hear the new TomatoUSB works on the E2000, could it make any difference?
Stryker2[X] is offline   Reply With Quote
Old 04-05-2011, 11:28 PM   #9
Bad_Motha
 
Banned
Join Date: Sep 2008
Reputation: 3208
Posts: 13,401
Yes the channel can make a big difference, as you can see for yourself. Glad to be of help. Sorry that you can't use Wireless-N ONLY, but on some routers, using mixed mode means that it will compromise the overall speed to allow wider compatibility ranges for the various modes. But since you do see yourself getting full speed (or very close to it) when using N-ONLY mode, then it does make a difference. This isn't always the case on all routers/adapters, but again sometimes it's just not good to use mixed-mode, unless you have to. In your case you need it, so not much you can do about that.

Speedtests are usually not great, but can help to figure out your overall pings/speeds, based on your connection. But trying a different server can help, so can trying different times of day. Plus you're on a CABLE ISP, which is a shared network. The more people in your area that have that same ISP, it can effect everyone's overall speed and connections if it's a peak period where ALOT of those ISP customers are all on at the same time.

So there are alot of factors. Not just your ISP/Modem/Router/Adapters

Last edited by Bad_Motha: 04-05-2011 at 11:32 PM.
Bad_Motha is offline   Reply With Quote
Old 04-05-2011, 11:39 PM   #10
Stryker2[X]
 
Join Date: Nov 2003
Reputation: 257
Posts: 5,697
Quote:
Originally Posted by Bad_Motha View Post
Yes the channel can make a big difference, as you can see for yourself. Glad to be of help. Sorry that you can't use Wireless-N ONLY, but on some routers, using mixed mode means that it will compromise the overall speed to allow wider compatibility ranges for the various modes. But since you do see yourself getting full speed (or very close to it) when using N-ONLY mode, then it does make a difference. This isn't always the case on all routers/adapters, but again sometimes it's just not good to use mixed-mode, unless you have to. In your case you need it, so not much you can do about that.

Speedtests are usually not great, but can help to figure out your overall pings/speeds, based on your connection. But trying a different server can help, so can trying different times of day. Plus you're on a CABLE ISP, which is a shared network. The more people in your area that have that same ISP, it can effect everyone's overall speed and connections if it's a peak period where ALOT of those ISP customers are all on at the same time.

So there are alot of factors. Not just your ISP/Modem/Router/Adapters
Yes but when I am wired I am able to achieve 20-25mbps down all the time. So my neighbors are not eating up the cable bandwidth. It's just a wireless issue.

I am changing rooms in a week or two to a nicer one that is not even 20 feet from the router, so if it isn't good there then I will re-evaluate.
Stryker2[X] is offline   Reply With Quote
Old 04-05-2011, 11:46 PM   #11
Bad_Motha
 
Banned
Join Date: Sep 2008
Reputation: 3208
Posts: 13,401
Must be your house/apartment is all I can say.

I have no problem getting a good signal w/ full speed on Linksys WRT54G
I have 4 systems in the house and a laptop, all on Wireless-G. The router is also set to G-ONLY.

Heck I can sit with my laptop on the picnic table in backyard and be a good 150ft away from router and still rockin'
But I also have the router sitting in a room up on the 2nd floor in the home, which helps all the connections overall.
Bad_Motha is offline   Reply With Quote
Old 04-05-2011, 11:50 PM   #12
Stryker2[X]
 
Join Date: Nov 2003
Reputation: 257
Posts: 5,697
Quote:
Originally Posted by Bad_Motha View Post
Must be your house/apartment is all I can say.

I have no problem getting a good signal w/ full speed on Linksys WRT54G
I have 4 systems in the house and a laptop, all on Wireless-G. The router is also set to G-ONLY.

Heck I can sit with my laptop on the picnic table in backyard and be a good 150ft away from router and still rockin'
But I also have the router sitting in a room up on the 2nd floor in the home, which helps all the connections overall.
I never had a problem with my WRT54GL either...

Maybe I should bring home my router from my office (my WRT54GL) and test it here and see if it makes any difference.
Stryker2[X] is offline   Reply With Quote
Old 04-05-2011, 11:58 PM   #13
Stryker2[X]
 
Join Date: Nov 2003
Reputation: 257
Posts: 5,697
Also...I'm back to <2mbps. Looks like the channel change isn't helping anymore. I'm the only router on channel 8 in my radius, too.
Stryker2[X] is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Discussions > Hardware and Operating Systems


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 10:14 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2012, All Rights Reserved.