Go Back   Steam Users' Forums > Steam Game Discussions > Q - S > Saints Row 2

Reply
 
Thread Tools Display Modes
Old 04-06-2011, 12:30 AM   #1
sarttan
 
Join Date: Jul 2010
Reputation: 0
Posts: 36
HELP! Saints Row Not Starting!

You know the drill by now. My Dell Studio xps Windows 7 (64bit) doesn't properly start Saints Row 2. Here's what I've tried/noted.


I tried the "defaults" in the launch options, but it crashed.

I've downloaded the settings.dat file, but I can tell its not working because it still tries to start fullscreen.
Edit: Turns out I had left "defaults" in the launch options on. I got rid of it and it started windowed, but still crashed at the same spot.

I unplugged my Gaming controller. Nothing. Same thing after unplugging my headphones and microphone.

I verified the game cache with no errors and even deleted local files and re-downloaded. Nothing.

I emptied my CD drive and unmounted my CD images and even left my CD drive open. You get the picture.

My Speakers are Realtek and do not have the Disable All Enhancements button. It instead has Disable All Sound Effects, an Immediate Mode box on the far right, and location settings at the bottom. These are all completely unchecked/empty.

I do not have a second monitor, but my default monitor is 1600x900.

My computer has an intel i7 core and a NVIDIA GeForce GTS 240 plugged into the back.

I have read about similar problems with Red Faction Gurella, but my copy of Red Faction Gurella starts without a hitch.


I crash in the middle of the copyright screen. Please help.
sarttan is offline  
Reply With Quote
Old 04-06-2011, 01:59 AM   #2
IdolNinja
 
Join Date: Feb 2010
Reputation: 499
Posts: 1,082
Quote:
Originally Posted by sarttan View Post
You know the drill by now. My Dell Studio xps Windows 7 (64bit) doesn't properly start Saints Row 2. Here's what I've tried/noted.


I tried the "defaults" in the launch options, but it crashed.

I've downloaded the settings.dat file, but I can tell its not working because it still tries to start fullscreen.
Edit: Turns out I had left "defaults" in the launch options on. I got rid of it and it started windowed, but still crashed at the same spot.

I unplugged my Gaming controller. Nothing. Same thing after unplugging my headphones and microphone.

I verified the game cache with no errors and even deleted local files and re-downloaded. Nothing.

I emptied my CD drive and unmounted my CD images and even left my CD drive open. You get the picture.

My Speakers are Realtek and do not have the Disable All Enhancements button. It instead has Disable All Sound Effects, an Immediate Mode box on the far right, and location settings at the bottom. These are all completely unchecked/empty.

I do not have a second monitor, but my default monitor is 1600x900.

My computer has an intel i7 core and a NVIDIA GeForce GTS 240 plugged into the back.

I have read about similar problems with Red Faction Gurella, but my copy of Red Faction Gurella starts without a hitch.


I crash in the middle of the copyright screen. Please help.
If it's crashing after the copyright screen then it's an issue with trying to initialize the main menu. It sounds like a usb device is getting mistakenly identified by the game as a controller. I know that you said you physically unplugged your devices, but did you also look in your device manager and make sure that the keyboard itself isn't being identified as an HID-Compliant Game Controller? If you have any of those listed, then temporarily disable them and see if that helps.

Also, I'm going to assume that you're trying to run SR2 clean. No mods or powertools? If not, remove them and go back to plain vanilla to test and make sure that they aren't responsible.
IdolNinja is offline   Reply With Quote
Old 04-06-2011, 02:38 PM   #3
CaRnaGe30
 
Guest
Posts: n/a
Am having the same problem as this person. My game goes thru the THQ screen, the Voli whatever screen with the sprays, the Powered By GameSpy screen, and then the crash at the text with ESRB + rights. I also have Realtek and my monitor runs at 1024x768, Windows 7 64x Pro.

I have vanilla SR2, no mods, not cheats, no powertools. It worked fine until about 30 minutes ago.

I have not deleted the local content, but I have deleted the settings.dat file. Started it up, still crashed. Put defaults in the parameters...nada. Downloaded and put the 800x settings.dat and still bombed. I checked my cache with no errors and still bombed. I haven't got a 2nd monitor. I've disabled the sound enhancements like the picture said, but the Realtek control panel also has an type of enhancement thing . I also haven't deleted local content and re-downloaded it (partially on fear of losing my game saves and control config).

I checked and did everything mentioned here and the FAQ about the startup crash.

My computer does not have an HID-Compliant Game Controller.

One other thing that disturbs me... there is no audio during the startup now.. Does that hint that the sound is to blame?

**Edit** Dunno if this is what fixed it or if it was with other fixes but I had Ventrilo running with me. I turned it off and started it up and it worked.

*** So, if your running some kind of program that using a headset or mic or whatever, turn that program off and start the game. When you get in you can start it again. Exit game, and start it up again. It might work.

Last edited by CaRnaGe30: 04-06-2011 at 03:03 PM. Reason: Fixed my problem
  Reply With Quote
Old 04-06-2011, 04:45 PM   #4
sarttan
 
Join Date: Jul 2010
Reputation: 0
Posts: 36
Quote:
Originally Posted by IdolNinja View Post
If it's crashing after the copyright screen then it's an issue with trying to initialize the main menu. It sounds like a usb device is getting mistakenly identified by the game as a controller. I know that you said you physically unplugged your devices, but did you also look in your device manager and make sure that the keyboard itself isn't being identified as an HID-Compliant Game Controller? If you have any of those listed, then temporarily disable them and see if that helps.

Also, I'm going to assume that you're trying to run SR2 clean. No mods or powertools? If not, remove them and go back to plain vanilla to test and make sure that they aren't responsible.
I checked and they are HID-compliant consumer control device and two HID-compliant devices. I'll try disabling those.
EDIT: Nope. No good. I also tried disabling the three USB input devices, but stopped when my mouse stopped working. (Its USB. I should have seen that one coming....)

Last edited by sarttan: 04-06-2011 at 04:47 PM.
sarttan is offline   Reply With Quote
Old 04-06-2011, 04:49 PM   #5
sarttan
 
Join Date: Jul 2010
Reputation: 0
Posts: 36
Quote:
Originally Posted by CaRnaGe30 View Post
Am having the same problem as this person. My game goes thru the THQ screen, the Voli whatever screen with the sprays, the Powered By GameSpy screen, and then the crash at the text with ESRB + rights. I also have Realtek and my monitor runs at 1024x768, Windows 7 64x Pro.

I have vanilla SR2, no mods, not cheats, no powertools. It worked fine until about 30 minutes ago.

I have not deleted the local content, but I have deleted the settings.dat file. Started it up, still crashed. Put defaults in the parameters...nada. Downloaded and put the 800x settings.dat and still bombed. I checked my cache with no errors and still bombed. I haven't got a 2nd monitor. I've disabled the sound enhancements like the picture said, but the Realtek control panel also has an type of enhancement thing . I also haven't deleted local content and re-downloaded it (partially on fear of losing my game saves and control config).

I checked and did everything mentioned here and the FAQ about the startup crash.

My computer does not have an HID-Compliant Game Controller.

One other thing that disturbs me... there is no audio during the startup now.. Does that hint that the sound is to blame?

**Edit** Dunno if this is what fixed it or if it was with other fixes but I had Ventrilo running with me. I turned it off and started it up and it worked.

*** So, if your running some kind of program that using a headset or mic or whatever, turn that program off and start the game. When you get in you can start it again. Exit game, and start it up again. It might work.
Closest thing to that is Skype, but I leave that turned off most of the time. It also doesn't leave a running process either. Also my start-up has sound, just doesn't reach the main menu.

Last edited by sarttan: 04-06-2011 at 04:51 PM.
sarttan is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > Q - S > Saints Row 2


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 05:33 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.