Go Back   Steam Users' Forums > Steam Game Discussions > M - P > Portal 2

Reply
Click here to go to the first staff post in this thread.  
Thread Tools Display Modes
Old 04-18-2011, 09:39 PM   #1
Finnegan808
 
 
 
Join Date: Oct 2010
Reputation: 28
Posts: 48
Crashing after Valve vid

===== IMPORTANT =====
Quote:
Originally Posted by BurtonJ View Post
Do you have Steam installed on a FAT32 partition? If so, is it installed in the root?
Quote:
Originally Posted by austonst View Post
I think some people here are confused. Many people have reported problems with FAT32 and external drives. Chances are this is because an external drive would likely be used as storage, and FAT32 would be used for storage (not an operating system) as well. This is a thread about the problem where the game crashes immediately after the Valve video, sometimes with no error and sometimes with the virtual function call error. If your problem involves crashes when loading a singleplayer map or when trying to watch a video from under "extras", this is NOT the thread for you. In fact, I think a lot of extra reports are causing inaccurate data.

We have a Valve employee who has mentioned FAT32 being a problem, so I think it makes sense that FAT32 actually is a problem. External versus internal doesn't matter; it's just that external drives are more likely to be FAT32. People who report "getting the same problem, but not using FAT32" should probably explain the situation a little better then. Are you REALLY using FAT32 on the drive which contains Portal 2, and are you REALLY getting the R6025 error?

Just trying to keep things sane around here...

===== /IMPORTANT =====



game freezes on intro screen immediately following valve logo vid


R6025
-pure virtual function call

win7 home premium 64

sadface!!!!

Last edited by BurtonJ: 04-19-2011 at 02:36 PM. Reason: updated with clarification from a user
Finnegan808 is offline  
Reply With Quote
Old 04-18-2011, 09:40 PM   #2
Ninja_Fish
 
Join Date: Jan 2010
Reputation: 4
Posts: 199
This is now my worst fear.
Ninja_Fish is offline   Reply With Quote
Old 04-18-2011, 09:41 PM   #3
AmperWitty
 
Guest
Posts: n/a
You best be trollin'. Otherwise, I think I MIGHT cry myself to sleep to drown out the sorrows...
  Reply With Quote
Old 04-18-2011, 09:41 PM   #4
Ericson666
 
 
 
Banned
Join Date: Apr 2011
Reputation: 658
Posts: 2,856
I had like the same thing happen with Borderlands. You just need some pre-requisite, like Direct-X or such if it's like what I had.
Ericson666 is offline   Reply With Quote
Old 04-18-2011, 09:41 PM   #5
cerberusdest
 
Join Date: Apr 2011
Reputation: 71
Posts: 91
omg.. i have windows home premium 64... its the worst piece of crap ever has problems with EVERYTHING
cerberusdest is offline   Reply With Quote
Old 04-18-2011, 09:42 PM   #6
Dravu
 
Join Date: Jun 2009
Reputation: 62
Posts: 493
Quote:
Originally Posted by cerberusdest View Post
omg.. i have windows home premium 64... its the worst piece of crap ever has problems with EVERYTHING
Judging by your post, Windows isn't the problem...
Dravu is offline   Reply With Quote
Old 04-18-2011, 09:54 PM   #7
Finnegan808
 
 
 
Join Date: Oct 2010
Reputation: 28
Posts: 48
current nvidia drivers... rolling back a version...
Finnegan808 is offline   Reply With Quote
Old 04-18-2011, 09:55 PM   #8
Horse
 
 
 
Join Date: Dec 2008
Reputation: 2
Posts: 119
ATI drivers here for a 5770, got the same exact crash.

Verifying game cache now.

Im not happy.
Horse is offline   Reply With Quote
Old 04-18-2011, 09:57 PM   #9
Puzzlemaker
 
Guest
Posts: n/a
Getting same error.
  Reply With Quote
Old 04-18-2011, 09:58 PM   #10
chugaslug
 
Join Date: Sep 2010
Reputation: 5
Posts: 21
Quote:
Originally Posted by Dravu View Post
Judging by your post, Windows isn't the problem...
rep for you good sir
chugaslug is offline   Reply With Quote
Old 04-18-2011, 09:58 PM   #11
Horse
 
 
 
Join Date: Dec 2008
Reputation: 2
Posts: 119
Ok, I verified the game cache files and it found an error, re-downloaded something real fast, and is back to waiting to get a spot on a server.

Got a different loading screen and it started doing it again. Im REALLY upset now.
Horse is offline   Reply With Quote
Old 04-18-2011, 09:58 PM   #12
Puzzlemaker
 
Guest
Posts: n/a
Okay cool, let me wait for it to finish verifying and hopefully it will work.
  Reply With Quote
Old 04-18-2011, 09:59 PM   #13
decltype
 
Guest
Posts: n/a
"Pure virtual call" actually refers to an impossible condition in C++ usually caused by the program overwriting a virtual function pointer table.
  Reply With Quote
Old 04-18-2011, 10:01 PM   #14
Horse
 
 
 
Join Date: Dec 2008
Reputation: 2
Posts: 119
Quote:
Originally Posted by decltype View Post
"Pure virtual call" actually refers to an impossible condition in C++ usually caused by the program overwriting a virtual function pointer table.

Awesome. How do you fix this?
Horse is offline   Reply With Quote
Old 04-18-2011, 10:01 PM   #15
Korushi
 
Join Date: Dec 2008
Reputation: 86
Posts: 1,324
Im in this boat
Heartbreaking :<
Korushi is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > M - P > Portal 2


Tags
p2 bug tracker

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 06:22 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2012, All Rights Reserved.