Go Back   Steam Users' Forums > Steam Game Discussions > T - Z > Terraria

Reply
 
Thread Tools Display Modes
Old 05-17-2011, 02:25 AM   #1
Kiir
 
Guest
Posts: n/a
Those of you having trouble running servers

(This is if you've tried forwarding ports and making sure your firewall and other such things aren't blocking it.)

So, there are a lot of you out there that are unable to run servers, when you probably should be able to, and you may be intelligent enough to forward ports and such...

Wanna know why?

It's because Terraria's multiplayer currently broadcasts on the first network slot, as opposed to the one that's actually connected to the internet. So, most people who are connected to a wireless router will have an ethernet lan port that is active, and will generally be first (so it tries to broadcast off of that).

They need to disable all of the other connections if they wish it to actually broadcast through the wireless connection.

On windows 7, to get to that window, is:
Control Panel -> View Network Status and Tasks -> Change Adapter Settings (left side).

Then just right-click the other connection types and disable. OR, alternatively (or if that doesn't work), hold alt, select Advanced -> Advanced Settings, and reorganize the list so that your true internet connection is on top.

Last edited by Kiir: 05-18-2011 at 10:42 AM.
 
Reply With Quote
Old 05-17-2011, 04:13 AM   #2
Stokesy
 
Guest
Posts: n/a
Thanks for this.
I looked in the control panel like you said, and my virtual Hamachi adaptor was enabled, I disabled it and it worked straight away.
  Reply With Quote
Old 05-17-2011, 04:40 AM   #3
FoxBlade
 
Guest
Posts: n/a
Just a bit of extra information on this. I did the above, disabling two VMWare and a TeamViewer connection, however I still could not get people to connect, including myself.

On the network adapters window, press Alt to bring up the menu, select Advanced and then make sure the connection you want Terraria to use is at the top of the list.

Don't ask me why disabling the other adapters didn't work, apparently it wasn't enough for me. I also rebooted, although disabling and enabling the connection again should do it.

Oh also I still couldn't connect using 127.0.0.1, however using my local network IP (ie. 192.168.1.3) did work.
  Reply With Quote
Old 05-18-2011, 10:41 AM   #4
Kiir
 
Guest
Posts: n/a
Quote:
Originally Posted by FoxBlade View Post
On the network adapters window, press Alt to bring up the menu, select Advanced and then make sure the connection you want Terraria to use is at the top of the list.
Well, was unaware you could actually re-organize the priority. That's a much better way of doing it, I imagine. Cheers.
  Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > T - Z > Terraria


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 10:13 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2012, All Rights Reserved.