Go Back   Steam Users' Forums > Steam Discussions > Help and Tips

Reply
 
Thread Tools Display Modes
Old 06-25-2011, 01:24 PM   #1
El Xando
 
Join Date: Nov 2010
Reputation: 62
Posts: 14
Trackmania United Won't Start...

Hi,
When I first bought Trackmania United, it wouldn't start through steam because it just hanged on installing "Microsoft Register Server". I managed to bypass this by using "tmtp://" to launch the game however now that has stopped working too. What happens now is "Performing first time setup... Installing: Microsoft(C) Register Server (step 1 of 1)" comes up, then goes away, then comes up, very quickly. It flashes every half a second or so.
How do I fix this?!
Thanks.
El Xando is offline  
Reply With Quote
Old 06-25-2011, 01:36 PM   #2
PELUXA1
 
 
 
Join Date: Dec 2010
Reputation: 1263
Posts: 8,917
It is really weird. Microsoft REgister Server is just your Windows Registry, so if that thing is not working, something in your pc got corrupted.

Try running an Antivirus...
PELUXA1 is offline   Reply With Quote
Old 06-25-2011, 01:42 PM   #3
El Xando
 
Join Date: Nov 2010
Reputation: 62
Posts: 14
Quote:
Originally Posted by PELUXA1 View Post
It is really weird. Microsoft REgister Server is just your Windows Registry, so if that thing is not working, something in your pc got corrupted.

Try running an Antivirus...
That's a bit worrying :S
It was working earlier fine and between then and now I have done very little... don't think anything on my PC would have changed. I've got Microsoft Security Essentials and it scans my computer daily, no problems...
Here's a video of what it does: http://www.youtube.com/watch?v=38Q3Q8pJseQ
El Xando is offline   Reply With Quote
Old 06-25-2011, 01:46 PM   #4
damaged
 
Join Date: Jul 2008
Reputation: 8656
Posts: 7,266
How is your DEP configured?
damaged is offline   Reply With Quote
Old 06-25-2011, 01:57 PM   #5
El Xando
 
Join Date: Nov 2010
Reputation: 62
Posts: 14
Quote:
Originally Posted by damaged View Post
How is your DEP configured?
DEP...?
El Xando is offline   Reply With Quote
Old 06-25-2011, 02:00 PM   #6
damaged
 
Join Date: Jul 2008
Reputation: 8656
Posts: 7,266
http://helpdeskgeek.com/how-to/micro...opped-working/

Try the steps in that link and reboot.
damaged is offline   Reply With Quote
Old 06-25-2011, 02:08 PM   #7
El Xando
 
Join Date: Nov 2010
Reputation: 62
Posts: 14
Quote:
Originally Posted by damaged View Post
http://helpdeskgeek.com/how-to/micro...opped-working/

Try the steps in that link and reboot.
When I try to add regsvr32.exe to that I get "You can not set DEP attributes on 64-bit executables."

EDIT: I read the comments and saw for 64-bit OS I have to do the regsvr32.exe that was in SysWOW64 instead of System32. I did that and restarted, and now the Register Server loop does not occur, but it goes away then nothing happens. I can't even load the settings through steam anymore.
HOWEVER, that fixed tmtp://. So I can at least play now, however it is still not working entirely properly...

Last edited by El Xando: 06-25-2011 at 02:16 PM.
El Xando is offline   Reply With Quote
Old 06-25-2011, 02:21 PM   #8
damaged
 
Join Date: Jul 2008
Reputation: 8656
Posts: 7,266
Quote:
Originally Posted by El Xando View Post
When I try to add regsvr32.exe to that I get "You can not set DEP attributes on 64-bit executables."

EDIT: I read the comments and saw for 64-bit OS I have to do the regsvr32.exe that was in SysWOW64 instead of System32. I did that and restarted, and now the Register Server loop does not occur, but it goes away then nothing happens. I can't even load the settings through steam anymore.
HOWEVER, that fixed tmtp://. So I can at least play now, however it is still not working entirely properly...
Try adding the game's executable in the same way you added regsvr32.exe to DEP exceptions.
damaged is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Discussions > Help and Tips


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 04:10 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.