Go Back   Steam Users' Forums > Steam Discussions > Hardware and Operating Systems

Reply
 
Thread Tools Display Modes
Old 06-30-2011, 06:09 PM   #1
ThatIndianGuy95
 
Join Date: Jun 2011
Reputation: 0
Posts: 19
Unhappy Sound comes through speakers instead of headphones

I recently installed Team Fortress 2 and Steam since it is now free-to-play and my sound is all messed up. I had games like A.V.A and Sudden Attack and all system sounds, game sounds, and skype voice calls went through the speakers with no problem.

Now everything is messed up. Only thing that goes through the headphones now is voice calls (skype and/or steam voice chat) and that is it if the game is running. If the game is running, system sounds, game sounds, and other things like youtube videos sound goes through the speaker instead of headphones. This happens to all games now like Sudden Attack and A.V.A.

The game sounds and system sounds go through the headphones when I don't do voice chat with skype/steam but when I do voice chat, the game sounds and system sound go through the speakers while the voice sounds go through the headphones.

OS: Windows 7 Ultimate SP1 x64
Sound Card: IDT 92HD79B1 Rev: A03
Laptop: Dell Inspiron N5010
Drivers: The one Windows automatically installs and the IDT driver from the Driver CD/website.

Please, this is driving me insane. I removed all sound drivers and reinstalled them multiple times from the Driver CD that came with the laptop and drivers from the manufactures website.

I searched in Google and steam and couldn't find an answer.

EDIT: Could be both Drivers conflicting. I uninstalled the Windows Driver and kept the IDT Driver. I will see if the problems are fixed when I play with my buddies tomorrow since we do voice chat.

Last edited by ThatIndianGuy95: 06-30-2011 at 06:25 PM.
ThatIndianGuy95 is offline  
Reply With Quote
Old 06-30-2011, 07:13 PM   #2
j3ff86
 
Join Date: Jun 2008
Reputation: 9
Posts: 233
TF2 will use the default win7 audio playback device (right click the audio icon in the taskbar to set it). You can set skype's audio settings in its options.
j3ff86 is offline   Reply With Quote
Old 07-01-2011, 12:22 AM   #3
spichopat
 
Join Date: Oct 2010
Reputation: 11
Posts: 369
disable speakers in control panel>Hardware and sound>Manage Audio Devices
spichopat is offline   Reply With Quote
Old 07-06-2011, 08:26 PM   #4
ThatIndianGuy95
 
Join Date: Jun 2011
Reputation: 0
Posts: 19
I just uninstalled both drivers and let windows install the default ones.

I tried setting the default audio playback devices before I uninstalled the drivers but it wouldn't change.
ThatIndianGuy95 is offline   Reply With Quote
Old 04-22-2012, 03:19 PM   #5
IDefectedI
 
Banned
Join Date: Feb 2012
Reputation: 18
Posts: 872
need to bump this because I am about to give up with steams voice chat lol ... everything works but incoming voice chat comes through the speakers not headset ! Also when I test my headset with "steam settings" my voice comes through my headset like it's supposed to


all other apps on my PC have Zero issues !! Come on steam get your act together .

Last edited by IDefectedI: 04-22-2012 at 03:22 PM.
IDefectedI is offline   Reply With Quote
Old 02-05-2013, 10:34 PM   #6
Narcotic Clown
 
Join Date: Mar 2008
Reputation: 3
Posts: 387
Sorry for necro-posting, but I had this problem in the past but do not remember how I solved it. However, I am absolutely sure that the problem lies with Dell IDT audio since I had fixed this problem by disabling it or installing another driver.
Narcotic Clown is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Discussions > Hardware and Operating Systems


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 07:17 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.