Go Back   Steam Users' Forums > Steam Game Discussions > M - P > Magicka

Reply
 
Thread Tools Display Modes
Old 07-02-2011, 04:01 PM   #1
Lorenco
 
Guest
Posts: n/a
Unable to initialize a sound device.

Hi,

i just bought Magicka with all DLC's, and sadly, it doesn't work. At start, the error from the title of this thread is popping up (i can "ignore" him), and then game is starting - but all i see is black screen, sometimes Paradox & Magicka Logo, and then game freezes. Help, please : (.

I didnt found similar problem, so i tought i will make new thread.
 
Reply With Quote
Old 07-03-2011, 01:05 AM   #2
Varrok
 
 
 
Join Date: Aug 2009
Reputation: 51
Posts: 730
Try um... installing newer drivers to your sound card? Posting your system specs would be nice too
Varrok is offline   Reply With Quote
Old 07-03-2011, 04:50 PM   #3
TuRdIn8ToR
 
Guest
Posts: n/a
im haveing the same problems
  Reply With Quote
Old 07-04-2011, 01:00 AM   #4
Cambios
 
Join Date: Feb 2009
Reputation: 4
Posts: 38
Same problem here.

Soundblaster Audigy SE 7.1

I double checked to make sure I have the latest drivers for it, and I do.

This failure appears to completely bork the game, because it never loads after this.
Cambios is offline   Reply With Quote
Old 07-04-2011, 06:59 AM   #5
Emanuel
 
Guest
Posts: n/a
Same here and I have a Sound Blaster X-Fi Xtreme Audio.
  Reply With Quote
Old 07-04-2011, 07:08 AM   #6
Emanuel
 
Guest
Posts: n/a
I think it have something to do whit Soundblaster cards couse it works if I uninstall my soundblaster card.
  Reply With Quote
Old 07-04-2011, 11:39 AM   #7
Cambios
 
Join Date: Feb 2009
Reputation: 4
Posts: 38
Quote:
Originally Posted by Emanuel View Post
I think it have something to do whit Soundblaster cards couse it works if I uninstall my soundblaster card.
That's pretty bad since Soundblaster is basically the #1 sound card on the market.

Is there a way to just get a refund on the game?

I have never been able to launch it even a single time because of this error.
Cambios is offline   Reply With Quote
Old 07-04-2011, 03:05 PM   #8
Cosh Holga
 
 
 
Join Date: Feb 2010
Reputation: 2
Posts: 65
I have the same thing but the thread keeps getting bumped down. With as many people haveing the same issue you would think someone found a fix for it by now but seem they are just laughing at us all the way to the bank.


Specs.
OS: Vista 32 bit
Proc. Intel Core 2 quad 2.5 gig
Ram: 4 gigs of DDR3
Graphic: Nvida GTX 480
Sound: Sound blaster HD

All drivers up to date, the exact same issue happens to me even after verifying, uninstalling and reinstalling. (note to self never get anything from arrow head again)
Cosh Holga is offline   Reply With Quote
Old 07-04-2011, 04:04 PM   #9
PS_
 
Join Date: Jan 2011
Reputation: 103
Posts: 1,670
There is an SB-issue, yes. If the game crash when using SB, it's the "enhanced sound issue". But you say it freezes ?


Anyway, check this.
This is from Sticked "Solutions collection" thread.

Quote:
[E 1] Enhanced sound problem. Look here.
Error log: System.NullReferenceException: Object reference not set to an instance of an object.
Solution posted by Gregzenegair2

[E 2] Enhanced sound problem.
Same crash, but a new text in the error report, came with Vietnam release. (I think)
Error log: System.InvalidOperationException: This resource could not be created.
Suggestion to resolve here, confirmed by jwtheis
PS_ is offline   Reply With Quote
Old 07-04-2011, 04:59 PM   #10
Cambios
 
Join Date: Feb 2009
Reputation: 4
Posts: 38
This isn't a crash. This issue happens while launching the game and prevents it from even launching.
Cambios is offline   Reply With Quote
Old 07-04-2011, 05:03 PM   #11
PS_
 
Join Date: Jan 2011
Reputation: 103
Posts: 1,670
Exactly.
PS_ is offline   Reply With Quote
Old 07-05-2011, 04:08 PM   #12
PS_
 
Join Date: Jan 2011
Reputation: 103
Posts: 1,670
Quote:
Originally Posted by Cambios View Post
This isn't a crash. This issue happens while launching the game and prevents it from even launching.
And still, after questioning my advice, you got the game going. And not even so much as a thanks. I wouldn't have mind this normally, it's common. But in your case @Cambios I'm starting to regret my help here.

Following your track-record for the last day, It's not much of anything that's good enough for you it seams. Playing Magicka just can't be healthy for you.
PS_ is offline   Reply With Quote
Old 11-17-2011, 01:06 PM   #13
Faerie
 
Guest
Posts: n/a
I have the exact same problem with magicka, but not a sound blaster card. Builds in audio on motherboard, latest drivers and tried reinstalling .Net XNA and magicka all to no effect. Nothing in magickas log files. Win7 64 bit system.

Last edited by Faerie: 11-17-2011 at 01:16 PM.
  Reply With Quote
Old 11-17-2011, 03:44 PM   #14
PS_
 
Join Date: Jan 2011
Reputation: 103
Posts: 1,670
Quote:
Originally Posted by Faerie View Post
I have the exact same problem with magicka, but not a sound blaster card. Builds in audio on motherboard, latest drivers and tried reinstalling .Net XNA and magicka all to no effect. Nothing in magickas log files. Win7 64 bit system.
If you don't have an error report, it's NOT the same problem. This error have always produced some kind of error report.

Se if you can find an event log for your crash.
If you go to Start > Run and type ' "reliability ', then hit enter. Se what it saes regarding Magicka.exe. Explained here.
PS_ is offline   Reply With Quote
Old 11-19-2011, 03:09 AM   #15
Faerie
 
Guest
Posts: n/a
I found it but I doesn't make much sense.


The program Magicka.exe version 1.4.3.2 stopped interacting with Windows and was closed. To see if more information about the problem is available, check the problem history in the Action Center control panel.
Process ID: 12c0
Start Time: 01cca56dc0cec5ed
Termination Time: 0
Application Path: d:\spel\steam\steamapps\common\magicka\Magicka.exe
Report Id:

This was from a time when I clicked "ignore" in the "Can not initialize sound device". The game proceeds to hang.
  Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > M - P > Magicka


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 06:02 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2012, All Rights Reserved.