Go Back   Steam Users' Forums > Steam Game Discussions > Q - S > Star Ruler

Reply
 
Thread Tools Display Modes
Old 07-07-2011, 05:05 PM   #1
ThyReaper
 
 
 
Blind Mind Studios
Join Date: Apr 2007
Reputation: 18
Posts: 139
Exclamation Game won't start on Windows Vista/7 64-bit

Some players have experienced issues getting the game to start. If you are running on 64-bit Windows 7, please try the following steps:

Install oalinst.exe, located in the Star Ruler folder.

Copy 'C:\Windows\System32\OpenAL32.dll' into 'C:\Windows\SysWOW64'

If you experience this issue, please report whether or not this worked.

Thanks to cloudybay for this potential solution.

Last edited by ThyReaper: 07-07-2011 at 05:09 PM.
ThyReaper is offline  
Reply With Quote
Old 07-18-2011, 07:07 PM   #2
Dr. The BoB
 
Join Date: Jan 2010
Reputation: 0
Posts: 21
Good News/ Bad News

Evenin' 'Reaper

Like the title suggests, I've got a good news/bad news situation here...

Bad News: I still can't play it.
After the game gives me the "Preparing to Launch" window, it turns into a "Performing First Time Set-up Installing Microsoft VC Redist Package (step 1 of 1)" window.
This message is only open for about a second, before the window closes. Sadly, that's all it does.

Good News: Now it doesn't crash my machine when I try running the game! I've got to say, mate, that the Good def. outweighs the Bad here.

Stay Groovy
DtB
Dr. The BoB is offline   Reply With Quote
Old 07-19-2011, 10:29 PM   #3
ICMB
 
Guest
Posts: n/a
I bought this two weeks ago and still haven't been able to play. At first it was a repeated triggering of my anti-virus software. After resolving that and reinstalling, it stopped saying "unavailable" and now just closes without any errors.

I tried the steps described above and it did nothing to help.

I removed my various .blob files, and rebooted.

Any other ideas to get it started?
  Reply With Quote
Old 07-19-2011, 10:43 PM   #4
ICMB
 
Guest
Posts: n/a
Good grief.

I had been trying to launch it from Steam. If I actually launch from the executable, it seems to work fine.

And now, running it from Steam works as well. That's nuts.
  Reply With Quote
Old 08-09-2011, 04:19 AM   #5
Dr. The BoB
 
Join Date: Jan 2010
Reputation: 0
Posts: 21
... You there Reaper?

Hey Reaper... just wondering if you might have any other advice on how I can get the game to run...

DtB
Dr. The BoB is offline   Reply With Quote
Old 08-09-2011, 09:26 AM   #6
ThyReaper
 
 
 
Blind Mind Studios
Join Date: Apr 2007
Reputation: 18
Posts: 139
Try installing the 2008 version of the microsoft redistributable:

http://www.microsoft.com/download/en...ylang=en&id=29
ThyReaper is offline   Reply With Quote
Old 08-11-2011, 06:48 PM   #7
despiseusername
 
Guest
Posts: n/a
All right I had the same problem as other people on Windows 7 64 bit but I figured out a solution.

What I finally did was delete OpenAL32.dll from C:\Windows\System32\ and C:\Windows\SysWOW64

then clicked on the oalinst.exe file in the directory StarRuler.exe was installed into.

Then I was able to run starruler either from steam or the starruler.exe without a problem.
  Reply With Quote
Old 08-21-2011, 01:59 PM   #8
Dr. The BoB
 
Join Date: Jan 2010
Reputation: 0
Posts: 21
Hey Reaper, unfortunately that didn't work. (I manually uninstall the old versions I had before doing the install)

Despise, unfortunately, that didn't work for me.
The time I tried it w/o migrating a copy of the OpenAL32.DLL caused my machine to give me the blank white window and completely lock up.
When I migrated a new copy of the file into the SysWOW64 and tried it just won't launch, like before.

It might be worth mentioning that I'm having a similar problem with another game I just picked up (on Steam) called Space Pirates And Zombies.
Dr. The BoB is offline   Reply With Quote
Old 08-24-2011, 12:49 PM   #9
Binkles
 
Join Date: Aug 2011
Reputation: 0
Posts: 9
Appears I'm in the same boat.

1) I've copied 'C:\Windows\System32\OpenAL32.dll' into 'C:\Windows\SysWOW64'

2) I've installed the 2008 version of the microsoft redistributable

3) I've clicked on the oalinst.exe file in the directory StarRuler.exe was installed into.

Clicking on the icon results in the steam window "preparing to launch" followed by nothing. Loading C:\Program Files (x86)\Steam\steamapps\common\star ruler\Starruler.exe results in "The application was unable to start correctly (0xc000007b)."

Last edited by Binkles: 08-24-2011 at 01:49 PM.
Binkles is offline   Reply With Quote
Old 08-24-2011, 05:32 PM   #10
despiseusername
 
Guest
Posts: n/a
"OpenAL32.dll from C:\Windows\System32\ and C:\Windows\SysWOW64

then clicked on the oalinst.exe file in the directory StarRuler.exe was installed into"

Why haven't you tried that people? It worked for me and I was not able to run starruler from a brand new computer that installed starruler from steam till I deleted that openal32.dll from those two directories and clicked on the oalinst.exe from the starruler directory that steam created upon installation.
  Reply With Quote
Old 08-25-2011, 04:39 AM   #11
Dr. The BoB
 
Join Date: Jan 2010
Reputation: 0
Posts: 21
Quote:
Originally Posted by despiseusername View Post
"
Why haven't you tried that people? It worked for me and I was not able to run starruler from a brand new computer that installed starruler from steam till I deleted that openal32.dll from those two directories and clicked on the oalinst.exe from the starruler directory that steam created upon installation.
Mornin' Despiseusername

I did try that, and it crashed my machine.
Sorry if I wasn't clear about that in my last post.

DtB
Dr. The BoB is offline   Reply With Quote
Old 09-17-2011, 03:09 PM   #12
chiyu
 
Guest
Posts: n/a
tried to install then copy files... FAIL, waste of money.. don't buy this junk, and be wary of ANYTHING you buy from steam as steam could care less about support, they just put a forum up and let the users figure it out. i.e..... vampire masqurade, stubbs the zombie , this game.. and a slew of others.
  Reply With Quote
Old 09-17-2011, 10:04 PM   #13
ThyReaper
 
 
 
Blind Mind Studios
Join Date: Apr 2007
Reputation: 18
Posts: 139
Quote:
Originally Posted by chiyu View Post
tried to install then copy files... FAIL, waste of money.. don't buy this junk, and be wary of ANYTHING you buy from steam as steam could care less about support, they just put a forum up and let the users figure it out. i.e..... vampire masqurade, stubbs the zombie , this game.. and a slew of others.
Steam Support cannot solve errors with the games themselves. If you need our help, please ask on our forums which all of us frequent, or email our support email.
ThyReaper is offline   Reply With Quote
Old 10-13-2011, 04:57 AM   #14
Dooby
 
Join Date: Jun 2011
Reputation: 0
Posts: 1
Is there a definite fix for this? Seems like a lot of people are still having this problem, I have tried everything in this thread and on your forums and nothing works. I've basically just lost £12.
Dooby is offline   Reply With Quote
Old 10-30-2011, 11:33 AM   #15
Cpt.Badger
 
Join Date: Apr 2011
Reputation: 7
Posts: 46
I'm on that list also. Can't play at all.
Cpt.Badger is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > Q - S > Star Ruler


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 12:28 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.