Go Back   Steam Users' Forums > Steam Game Discussions > D - G > Deus Ex series

Reply
 
Thread Tools Display Modes
Old 08-24-2011, 08:23 AM   #1
klkitchens
 
 
 
Join Date: Jan 2011
Reputation: 125
Posts: 476
Load speed IMPROVED... wow...

In the other thread on load speeds being slow, someone mentioned Vsync being an issue. Well, I know I'd turned it off in the initial setup, and said it was off. But on a lark, I checked in-game and somehow it was on!

I went into my Nvidia control panel, turned off Vsync and turned on Triple buffering... then ran the DEHR setup again and made sure they were off and on in there as well. I also set the field of view to 16:9 instead of Auto.

Lo and behold... my load times dropped from 29 seconds to 18 on the first load and 16 seconds for a subsequent load.

Hope this might help others...

This is Win 7/64 bit.

Since the load screen is animated, it stands to reason that this might have an affect, since it's doing that and loading data and processing that data.
klkitchens is offline  
Reply With Quote
Old 08-24-2011, 08:27 AM   #2
Listen
 
Join Date: Apr 2011
Reputation: 62
Posts: 307
Quote:
Originally Posted by klkitchens View Post

I went into my Nvidia control panel, turned off Vsync and turned on Triple buffering...

Triple buffering does nothing if V-Sync is off, so no idea why you'd want to have it set like that.
Listen is offline   Reply With Quote
Old 08-24-2011, 08:31 AM   #3
klkitchens
 
 
 
Join Date: Jan 2011
Reputation: 125
Posts: 476
Quote:
Originally Posted by Listen View Post
Triple buffering does nothing if V-Sync is off, so no idea why you'd want to have it set like that.
You'ere the first one I've heard say that. I'm not doubting you, I'm just not a overclocking, live and breathe every settings junkie.

All I read in the other thread was turn off Vsync. Turn on Triple buffering. Never the two were mentioned as being symbiotic.

Thanks for the tip. So turning Vsync OFF is the fix then.

ADD: Wow... that's old new too. Again, I just like to play games, not tweak them, but apparently this is 100% correct. Seems like Nvidia would have their UI set up so that you can only turn on TB if the Vsync was on, otherwise it's disabled.

Last edited by klkitchens: 08-24-2011 at 08:36 AM. Reason: I googled it...
klkitchens is offline   Reply With Quote
Old 08-24-2011, 08:33 AM   #4
Armas
 
 
 
Join Date: May 2011
Reputation: 0
Posts: 77
Most suspicious... When I disabled v-sync all I got was unbearable tearing... no reduction in load times.
Armas is offline   Reply With Quote
Old 08-24-2011, 08:34 AM   #5
MrEntropy
 
Guest
Posts: n/a
Talking

Quote:
Originally Posted by klkitchens View Post
I went into my Nvidia control panel, turned off Vsync and turned on Triple buffering... then ran the DEHR setup again and made sure they were off and on in there as well. I also set the field of view to 16:9 instead of Auto.
Yoicks. I just turned off vsync in the Deus Ex setup and it knocked my load time from ~30 seconds to 15.

Thanks! I wish I had read this sooner.
  Reply With Quote
Old 08-24-2011, 08:42 AM   #6
klkitchens
 
 
 
Join Date: Jan 2011
Reputation: 125
Posts: 476
Quote:
Originally Posted by MrEntropy View Post
Yoicks. I just turned off vsync in the Deus Ex setup and it knocked my load time from ~30 seconds to 15.

Thanks! I wish I had read this sooner.
Awesome!
klkitchens is offline   Reply With Quote
Old 08-24-2011, 08:50 AM   #7
kevnb
 
Join Date: Feb 2011
Reputation: 65
Posts: 141
other folks are saying similar things... There must be some form of vsync hard coded in the menus.
kevnb is offline   Reply With Quote
Old 08-24-2011, 08:53 AM   #8
acrylamidetic
 
Join Date: Nov 2010
Reputation: 2
Posts: 32
I didn't have vsync on according to the in-game and setup menu. It is also turned off in Catalyst Control Center (set to Off, unless application specifies it.) I was using D3DOverrider to force triple buffering, so I disabled that and still took 47s to load a save, then quicksaved and immediately reloaded that save and it took 46s to load.
acrylamidetic is offline   Reply With Quote
Old 08-24-2011, 08:55 AM   #9
jim2point0
 
Join Date: Jun 2011
Reputation: 229
Posts: 1,583
Vsync is turned off in the game for me in-game and in my CCC... load times are horrendous
jim2point0 is offline   Reply With Quote
Old 08-24-2011, 08:57 AM   #10
acrylamidetic
 
Join Date: Nov 2010
Reputation: 2
Posts: 32
Quote:
Originally Posted by jim2point0 View Post
Vsync is turned off in the game for me in-game and in my CCC... load times are horrendous
Actually, this works, at least for me. In CCC turn Vsync all the way to the left so Always Off rather than "Off, unless application specifies it."

When I did that, the loads that were previously taking 50s now take 20s. Still not amazing, but I can live it.

So basically even though I turned off vysnc everywhere I could, the game was still turning it on while loading, and for some reason that was over doubling the load times.

Edit: Unfortunately without vsync or triple buffering this game tears like crazy.

Last edited by acrylamidetic: 08-24-2011 at 09:13 AM.
acrylamidetic is offline   Reply With Quote
Old 08-24-2011, 09:30 AM   #11
Kayan
 
Join Date: Jul 2011
Reputation: 0
Posts: 6
Thumbs up

Yep, this tip worked for me as well. Turned off V-sync in CCC and in game and load times went from almost a minute to under 20 seconds. Only tested one load, but it was MUCH quicker. Definitely manageable now.

Thanks!
Kayan is offline   Reply With Quote
Old 08-24-2011, 09:32 AM   #12
DFC*GaNjAdk
 
Join Date: Jul 2011
Reputation: 5
Posts: 112
Quote:
Originally Posted by klkitchens View Post
You'ere the first one I've heard say that. I'm not doubting you, I'm just not a overclocking, live and breathe every settings junkie.

All I read in the other thread was turn off Vsync. Turn on Triple buffering. Never the two were mentioned as being symbiotic.

Thanks for the tip. So turning Vsync OFF is the fix then.

ADD: Wow... that's old new too. Again, I just like to play games, not tweak them, but apparently this is 100% correct. Seems like Nvidia would have their UI set up so that you can only turn on TB if the Vsync was on, otherwise it's disabled.
kids...
DFC*GaNjAdk is offline   Reply With Quote
Old 08-24-2011, 09:39 AM   #13
klkitchens
 
 
 
Join Date: Jan 2011
Reputation: 125
Posts: 476
Quote:
Originally Posted by DFC*GaNjAdk View Post
kids...
Since I'll be 45 next month, thank you.
klkitchens is offline   Reply With Quote
Old 08-24-2011, 09:49 AM   #14
Mr Miyagi
 
Join Date: Jul 2010
Reputation: 0
Posts: 143
Triple buffering is a subsetting of Vsync that allows the game to run at higher FPS in situations where vsync alone would cap you at an interval of your refresh rate. An example being a game that runs at 44 FPS would be capped at 30 since 30 is an interval of 60hz (refresh rate) but if triple buffering was enabled the game would run at 44 FPS regardless. Some people experience slight input lag when triple buffering is on but I've never had a problem with it. I can't game without Vsync and triple buffering both on..the tearing is too unbearable if it is off.
Mr Miyagi is offline   Reply With Quote
Old 08-24-2011, 09:56 AM   #15
United_Strafes
 
Join Date: Apr 2010
Reputation: 49
Posts: 635
Quote:
Originally Posted by Listen View Post
Triple buffering does nothing if V-Sync is off, so no idea why you'd want to have it set like that.
Ya and tweaking Open GL settings in my control center don't give me 20fps more in Mass Effect 1, except they do. Sometimes these things happen.
United_Strafes is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > D - G > Deus Ex series


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 06:14 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.