Go Back   Steam Users' Forums > Steam Tool Discussions > Source SDK General Discussion

Reply
 
Thread Tools Display Modes
Old 10-15-2011, 10:19 AM   #1
Mxthe
 
Join Date: Jul 2009
Reputation: 11
Posts: 108
Simple Workaround for Black Viewports

Hey, since the new update Hammer would not load, after a while it was fixed but now the Hammer Viewports do not display anything.

After messing around for a while I found out a simple work around:


First, set your 3D camera to 3D Shaded Textured Polygons to display the 3D View.

Then go in Tools/Options :
  1. First click on the General Tab, and Uncheck USE VGUI Model Browser (it crashes hammer)
  2. Click on the 2D Views TAB, and on the left Side, uncheck the "White-on-Black color scheme".


It will display the viewports in inverted color modes, it is pretty ugly but at least it displays the objects in the viewports and allows you to manipulate them and to work if you are in a hurry.


Valve will fix this soon, you can count on it, but if you are currently in a hurry to use the SDK like I am, this should make it functional.

Last edited by Mxthe: 10-15-2011 at 10:23 AM.
Mxthe is offline  
Reply With Quote
Old 10-15-2011, 01:14 PM   #2
natinusala
 
Join Date: Mar 2011
Reputation: 0
Posts: 18
That's very ugly but it works. Thanks !
natinusala is offline   Reply With Quote
Old 10-15-2011, 01:28 PM   #3
BlackOps101
 
Join Date: Mar 2011
Reputation: 74
Posts: 579
Lightbulb

haha very well played... It works, it's ugly, but it works... Rep to you....
BlackOps101 is offline   Reply With Quote
Old 10-15-2011, 03:00 PM   #4
Zalo98
 
Join Date: Apr 2010
Reputation: 19
Posts: 419
IT's all screwed up, even with the fix I can't see my blocks in the 3D viewer (The top left box)
Zalo98 is offline   Reply With Quote
Old 10-15-2011, 03:42 PM   #5
Labyr!nth
 
Join Date: Dec 2007
Reputation: 0
Posts: 93
A nicer fix.

Navigate to Steam\steamapps\<username>\sourcesdk\bin\orangebox \bin

Open dxsupport.cfg. If you don't have one, make one.

Select all

Delete

Save

Map, almost perfectly. Transparency models no longer work and the vgui model browser still doesn't.

You cannot delete the file itself

I went through the whole file trying to pinpoint a fix. The only way it works if its an empty file. No idea why.

If anyone can elaborate and figure it out, even better.

Last edited by Labyr!nth: 10-15-2011 at 03:47 PM.
Labyr!nth is offline   Reply With Quote
Old 10-15-2011, 03:44 PM   #6
Mxthe
 
Join Date: Jul 2009
Reputation: 11
Posts: 108
I don't have that .cfg file in that folder.

Are you sure?
Mxthe is offline   Reply With Quote
Old 10-15-2011, 03:46 PM   #7
Labyr!nth
 
Join Date: Dec 2007
Reputation: 0
Posts: 93
If you don't, make one and leave it empty. Does that work?
Labyr!nth is offline   Reply With Quote
Old 10-15-2011, 04:33 PM   #8
MadLarry
 
Join Date: Feb 2008
Reputation: 0
Posts: 17
I made an empty dxsupport.cfg file using Notepad and it works.
MadLarry is offline   Reply With Quote
Old 10-15-2011, 06:23 PM   #9
episoder
 
Join Date: Aug 2011
Reputation: 112
Posts: 1,812
dxsupport is on a bogus line? mmh. :/

I think this' all about the mobile GL milk. yeh... we know!?!

Last edited by episoder: 10-15-2011 at 06:31 PM.
episoder is offline   Reply With Quote
Old 10-16-2011, 12:17 AM   #10
taz-ed
 
Join Date: Nov 2008
Reputation: 117
Posts: 2,258
sweet this work around sorted it for me
taz-ed is offline   Reply With Quote
Old 10-16-2011, 12:27 AM   #11
DoubleThinking
 
Join Date: Jan 2011
Reputation: 18
Posts: 85
oh cool, thanks! that fix helped alot
DoubleThinking is offline   Reply With Quote
Old 10-16-2011, 05:04 AM   #12
Lukeme99
 
 
 
Join Date: Oct 2011
Reputation: 2
Posts: 160
IN HAMMER MODEL BROWSER FAIL!! NOOOOO!!

IN HAMMER MODEL BROWSER FAIL!! NOOOOO!! The model browser quits hammer!
Lukeme99 is offline   Reply With Quote
Old 10-16-2011, 06:34 AM   #13
shadd0w09
 
Join Date: Nov 2007
Reputation: 0
Posts: 4
top answer work's for seeibg your blocks in camra view switch it to
3D Ray-traced preview you can see your blocks in hammer
shadd0w09 is offline   Reply With Quote
Old 10-17-2011, 04:39 PM   #14
KainThornn
 
Join Date: Mar 2008
Reputation: 53
Posts: 532
The empty dxsupport.cfg file worked for me...models in the 3d view still don't show properly or show up covered in black "wrapping paper" that says "gap". No designer clothing here. And Hammer shuts down when I try to view a model in the model viewer.
KainThornn is offline   Reply With Quote
Old 10-18-2011, 12:51 PM   #15
MMmaster
 
Guest
Posts: n/a
I would be careful using the editor while this bug is present, as I am getting another error since these buggy updates:
"... # solid(s) were not loaded due to errors in the file...."

These same files were previously (few days ago)opened by the editor without any error.
  Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Tool Discussions > Source SDK General Discussion


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -7. The time now is 06:59 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.