Go Back   Steam Users' Forums > Steam Game Discussions > M - P > PAYDAY The Heist

Reply
 
Thread Tools Display Modes
Old 10-24-2011, 03:11 PM   #1
overkill_bo
 
OVERKILL Software
Join Date: Sep 2011
Reputation: 448
Posts: 1,562
MOUSE LAG FIX

If you experience mouse lag in PAYDAY or other games, try the following:

Here is Valve's tip for solving mouse lag in Valve games and other games
https://support.steampowered.com/kb_...5365-RXBN-5508

Here is another very good run down on solutions and insight into mouse lag/smoothing/acceleration
http://www.overclock.net/mice/173255...ion-guide.html

For both of these solutions, disregard anything that is valve game specific. Like game console commands or game startup commands. But everything done in windows counts.

There is also a some graphical settings for NVIDIA cards you can try.
You have to open up the graphical display settings for you graphics card.

1. Right click your desktop.
2. click NVIDIA Control Panel

http://i51.tinypic.com/2vwyckw.jpg

3. click "Manage 3D Settings" (it is located under 3D Settings, the top most list item to the left)
This will open up a list of options for specific applications.

4. Click on the dropdown menu located underneath the "1. Select a program to customize" text.
5. Select Payday in that list
5.b. If payday does not excist in the list, click the "Add" button located to the right of the dropdown menu.

http://i52.tinypic.com/x44qbp.jpg

5.c. If you have a laptop or a computer with two graphics cards you might have to pick the graphics card to, it should be named NVIDIA high performance graphics, or something equally flashy.

6. Scroll down the list, select the option called "Maximum pre-rendered frames"

7. The setting for this option normally says "Use global setting (3)" Change the setting to 0 by clicking the the box containing the setting text and selecting 0.

http://i56.tinypic.com/zn4hag.jpg

If you experiencing lower framerates after this fix, try changing the value to 1 or 2, test what works best for you. Sofar, this sollution has worked for us.

8. Make sure the setting Triple Buffering is set to OFF.

FOR LAPTOPS
Go to the list of options where you found the "Maximum pre-rendered frames" option.
Edit the option called "Power management mode" set this to "Prefer maximum performance"
run PAYDAY with your power cord plugged IN for best performance.

Always try running all graphics hardware on high-performance, if you experiencing problems.

OVERKILL is working hard to figure out if all this can be resolved through the game, meanwhile and for other games with the same issues, above should help in most cases.

In all of the above solutions, if you have old graphics hardware, lowering the game resolution will help make the game run better and therefore remove a lot of any experienced lag.

Please report on your findings, so we can hunt down any further issues and get to robbing some more banks.
Please add computer/graphics hardware/driver version and mouse specs to any problem post.

Last edited by OVERKILL_crew: 10-27-2011 at 05:12 AM.
overkill_bo is offline  
Reply With Quote
Old 10-24-2011, 03:17 PM   #2
deadlymass
 
Join Date: Apr 2004
Reputation: 123
Posts: 1,610
Thank you for looking into it!
Payday will be a lot more enjoyable when we can aim
Great game.
deadlymass is offline   Reply With Quote
Old 10-24-2011, 03:34 PM   #3
Vustom
 
 
 
Join Date: May 2010
Reputation: 48
Posts: 499
Hurry!
Vustom is offline   Reply With Quote
Old 10-24-2011, 03:47 PM   #4
mystrdat
 
 
 
Join Date: Nov 2008
Reputation: 478
Posts: 3,720
ATI/AMD users have to use an external app to set the Flip Queue since the default drivers don't have any advanced settings like that.

I would highly recommend installing RadeonPro in this regard (the best app in existence for advanced driver tweaking) and setting the Flip Queue Size to 1 or 2 (Advanced tab), since 0 is a bit drastic. It will indeed help a lot with the game (and many others).

http://www.radeonpro.info

Last edited by mystrdat: 10-24-2011 at 04:37 PM.
mystrdat is offline   Reply With Quote
Old 10-24-2011, 03:54 PM   #5
Overkill_Ilija
 
OVERKILL Software
Join Date: Oct 2011
Reputation: 60
Posts: 224
*Thread updated with more info and some pictures*
Overkill_Ilija is offline   Reply With Quote
Old 10-24-2011, 03:58 PM   #6
Vustom
 
 
 
Join Date: May 2010
Reputation: 48
Posts: 499
Thanks,
Vustom is offline   Reply With Quote
Old 10-24-2011, 04:03 PM   #7
Sebhael
 
 
 
Join Date: Sep 2009
Reputation: 0
Posts: 48
I turn this setting off on all of my computers, so I'm still suffering from mouse lag
Sebhael is offline   Reply With Quote
Old 10-24-2011, 04:21 PM   #8
deadlymass
 
Join Date: Apr 2004
Reputation: 123
Posts: 1,610
Lowered to 0 and it is significantly better.
Any idea why it affects PAYDAY so much but other games don't experience the same lag?
Either way, playing is way better.
Thank you! Good to see developers active about feedback.
deadlymass is offline   Reply With Quote
Old 10-24-2011, 04:32 PM   #9
overkill_bo
 
OVERKILL Software
Join Date: Sep 2011
Reputation: 448
Posts: 1,562
Quote:
Originally Posted by Sebhael View Post
I turn this setting off on all of my computers, so I'm still suffering from mouse lag
Hi

What computer spec do you have?

Bo
overkill_bo is offline   Reply With Quote
Old 10-24-2011, 04:35 PM   #10
OVERKILL_crew
 
OVERKILL Software
Join Date: Oct 2011
Reputation: 499
Posts: 1,247
In response to deadlymass

We are guessing other games force this through graphics drivers, or something along those lines. But it is guess work right now, working on it.
OVERKILL_crew is offline   Reply With Quote
Old 10-24-2011, 04:36 PM   #11
Sebhael
 
 
 
Join Date: Sep 2009
Reputation: 0
Posts: 48
Quote:
Originally Posted by overkill_bo View Post
Hi

What computer spec do you have?

Bo
i7 M620 (2.67GHz), 4GB DDR3, Nivida GeForce GT330M

It's a 15" MBP I'm using bootcamp to run Windows 7 on.

My mouse, if relevant, is a Razer Deathadder BE.
Sebhael is offline   Reply With Quote
Old 10-24-2011, 04:38 PM   #12
defrag1
 
Join Date: Sep 2010
Reputation: 11
Posts: 194
I don't think its a video issue
I assume its the way mouse input is handled or some acceleration


Don't have any fps issue here
HD4870
phenomII x4 3.2gh
defrag1 is offline   Reply With Quote
Old 10-24-2011, 04:39 PM   #13
mystrdat
 
 
 
Join Date: Nov 2008
Reputation: 478
Posts: 3,720
Quote:
Originally Posted by Sebhael View Post
I turn this setting off on all of my computers, so I'm still suffering from mouse lag
Either force V-sync off or leave it on and limit processed FPS to 1 below your screen refresh rate. http://dxtory.com/v2-home-en.html can do that. Eg: 59 FPS limit for a 60Hz screen. Will fix all your trouble.

V-sync always causes trouble on systems above 60 FPS (or your refresh rate), you can find more on the issue at my blog or anywhere else.
http://mystrd.at/gaming/v-sync-mouse-lag-how-to-fix-it

Last edited by mystrdat: 10-24-2011 at 04:43 PM.
mystrdat is offline   Reply With Quote
Old 10-24-2011, 04:40 PM   #14
OVERKILL_crew
 
OVERKILL Software
Join Date: Oct 2011
Reputation: 499
Posts: 1,247
Quote:
Originally Posted by Sebhael View Post
i7 M620 (2.67GHz), 4GB DDR3, Nivida GeForce GT330M

It's a 15" MBP I'm using bootcamp to run Windows 7 on.

My mouse, if relevant, is a Razer Deathadder BE.
Try this:
Go into the task manager, find your mouse driver under "Processes"
Right click it, select "set priority"
Set it to "above normal", if that doesn't cut it, go higher.
I'm hoping that you can find your mouse driver process since you have a high-end gaming mouse. I don't know the name of the driver process though, you should be able to find it through google.
OVERKILL_crew is offline   Reply With Quote
Old 10-24-2011, 04:41 PM   #15
OVERKILL_crew
 
OVERKILL Software
Join Date: Oct 2011
Reputation: 499
Posts: 1,247
Quote:
Originally Posted by mystrdat View Post
Either force V-sync off or leave it on and limit processed FPS to 1 below your screen refresh rate. http://dxtory.com/v2-home-en.html can do that. Eg: 59 FPS limit for a 60Hz screen. Will fix all your trouble.

V-sync always causes trouble, you can find more on the issue at my blog or anywhere else.
http://mystrd.at/gaming/v-sync-mouse-lag-how-to-fix-it
Is this a proven sollution?

Last edited by overkill_bo: 10-24-2011 at 04:55 PM.
OVERKILL_crew is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > M - P > PAYDAY The Heist


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 11:52 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2012, All Rights Reserved.