Go Back   Steam Users' Forums > Steam Game Discussions > Q - S > Sonic the Hedgehog series > Sonic Generations

Reply
 
Thread Tools Display Modes
Old 11-04-2011, 12:35 PM   #31
ChimneySwift11
 
Guest
Posts: n/a
Same laptop, same problem. I can only run it with Integrated Graphics
  Reply With Quote
Old 11-04-2011, 04:18 PM   #32
Nettacki
 
 
 
Join Date: Mar 2011
Reputation: 0
Posts: 37
Don't know if this helps but I'll try.

I had a similar problem with my laptop's Geforce 425M when trying to run Rusty Hearts. What I did was go to forums at laptopvideo2go.com and installed the latest NVIDIA OEM Mobile graphics drivers along with the modded INF files (see the site for details), and all of a sudden it worked. I was able to run the game in Discrete Graphics mode.

Granted, I don't have Sonic Generations, so I don't know if the same thing works here, but yeah. Updating your graphics drivers to the latest ones from that site might help.
Nettacki is offline   Reply With Quote
Old 11-04-2011, 04:48 PM   #33
mjcowley
 
Guest
Posts: n/a
Mine seems to find the Intel HD and run, but performance is poor. If I tell it to manually switch to the Nvidia, the config tool doesn't see it, but the game does and I get an error about the config being wrong.

I'm kinda regretting this laptop as I've had a few games do this now.
  Reply With Quote
Old 11-04-2011, 06:08 PM   #34
DJ Cryotek
 
 
 
Join Date: Feb 2010
Reputation: 148
Posts: 1,207
Game compatibility with laptops is always a risky proposition. Integrated adapters are rarely supported in any official capacity. Always check around, try demos, etc. before buying. If you are going to game on a laptop, you're going to run into compatibility issues. That's just how it is.

I wish you luck, though. Just don't expect Sega to think this is their problem to fix, much less a priority.
DJ Cryotek is offline   Reply With Quote
Old 11-04-2011, 06:17 PM   #35
Pamper
 
Join Date: Jan 2008
Reputation: 6
Posts: 221
If you would bother to read, you would see that this isn't directly about integrated graphics but the actual graphics card in our laptops not being able to be detected by the game whatsoever. I can run BF3 on medium settings 30-50fps. Sonic doesn't even recognize my card.
Pamper is offline   Reply With Quote
Old 11-04-2011, 06:23 PM   #36
Cool_Al
 
Join Date: Mar 2004
Reputation: 8
Posts: 1,262
Connecting a display and running extended desktop doesn't work for me. In the configuration tool I get two Intel HD entries #0 and #1. The game still won't run if I force dedicated graphics.
Cool_Al is offline   Reply With Quote
Old 11-04-2011, 06:44 PM   #37
rettahS
 
 
 
Join Date: Dec 2010
Reputation: 4
Posts: 11
Quote:
Originally Posted by DJ Cryotek View Post
Game compatibility with laptops is always a risky proposition. Integrated adapters are rarely supported in any official capacity. Always check around, try demos, etc. before buying. If you are going to game on a laptop, you're going to run into compatibility issues. That's just how it is.

I wish you luck, though. Just don't expect Sega to think this is their problem to fix, much less a priority.
Optimus technology uses two graphics cards. Our laptops have an integrated graphics card to save power when not gaming+an NVIDIA card for gaming. The config does not recognize our NVIDIA cards so we can only play using integrated graphics cards unfortunately.
rettahS is offline   Reply With Quote
Old 11-04-2011, 07:03 PM   #38
mjcowley
 
Guest
Posts: n/a
Quote:
Originally Posted by rettahS View Post
Optimus technology uses two graphics cards. Our laptops have an integrated graphics card to save power when not gaming+an NVIDIA card for gaming. The config does not recognize our NVIDIA cards so we can only play using integrated graphics cards unfortunately.
Exactly. Mine is a week old Alienware laptop. Dell kinda advertise these as gaming laptops.
  Reply With Quote
Old 11-04-2011, 07:28 PM   #39
Majora27
 
Guest
Posts: n/a
Quote:
Originally Posted by Cool_Al View Post
Connecting a display and running extended desktop doesn't work for me. In the configuration tool I get two Intel HD entries #0 and #1. The game still won't run if I force dedicated graphics.
Do you have a Nvidia 325m, by any chance? Cuz thats the exact issue I'm having. I'm not entirely sure the 325m drives the HDMI port. Maybe try a VGA cable, if you can find one?
  Reply With Quote
Old 11-05-2011, 04:18 AM   #40
Marcio_xD
 
 
 
Join Date: Jan 2007
Reputation: 11
Posts: 220
Quote:
Originally Posted by Cool_Al View Post
Connecting a display and running extended desktop doesn't work for me. In the configuration tool I get two Intel HD entries #0 and #1. The game still won't run if I force dedicated graphics.
Try pressing WINDOWS + P and going to Projector Only mode.
Marcio_xD is offline   Reply With Quote
Old 11-05-2011, 04:56 AM   #41
Cool_Al
 
Join Date: Mar 2004
Reputation: 8
Posts: 1,262
No, that doesn't work for me either. Just comes up with one Intel HD Graphics option then. Same in clone mode.
Cool_Al is offline   Reply With Quote
Old 11-05-2011, 07:00 AM   #42
Pamper
 
Join Date: Jan 2008
Reputation: 6
Posts: 221
Trying to alter the hardware string at the end of the graphics.cfg, no luck so far.
Pamper is offline   Reply With Quote
Old 11-05-2011, 07:08 AM   #43
L1qu1d
 
 
 
Join Date: Oct 2010
Reputation: 23
Posts: 270
It cannot be done as of yet, unless you can have both the Nvidia card and Intel Chip activated.

Also you CANNOT disable the Intel period. It is always running, thats how Optimus works.

I've also tried projector mode, but that just enables the Intel chip twice according to Sonic Gen.

Face it, it was a crappy Config tool implemented. We need a patch that disables the game from only accepting either the tool bar chosen card, or possibly enable it to be chosen from the tool bar.

As of now, just play Sonic 3 and knuckles
L1qu1d is offline   Reply With Quote
Old 11-05-2011, 10:54 AM   #44
BrainOfSweden
 
 
 
Join Date: Jan 2011
Reputation: 8
Posts: 67
Found a working fix
First of all, I want to thank everyone that gave me ideas, this is kind of a mashup of all fixes I've found that only worked partly. Unfortunately I don't remember where I read everything, so, thanks to everyone who tried to get the game running.
Second, this fix requires no extra screens or cables.

I cant guarantee it will work on every laptop, but if you have an Nvidia Optimus card, try it. Here's how to:

Begin with opening Nvidia control panel. In the "Manage 3D settings" tab, go to program settings and click add.
Navigate to your Steam installation path, and go to \steamapps\common\Sonic Generations\ and choose the sonicgenerations.exe file. Force it to use your Nvidia card. I don't know if it's necessary, but I also did this with the config exe.
After you have applied the settings, go to your desktop.

Right click and select screen resolution. In this window you should click detect. If you can see two displays that are grayed out and named after your video cards, you're probably good to go.
Choose your Nvidia card and select "Attempt to connect anyway on (VGA in my case)". Don't remember which drop down menu it is, just fool around a little. When you found it, click apply.
Then, choose extended desktop and apply again. This will force-activate your discrete GPU.
Now the fun starts.

The guide is edited from here

Open the Sonic Config tool and check if your Nvidia card is present. But instead, choose your Intel card and whatever other settings you want.
Now start Sonic, and it will propably work.

What's technically happening is that Sonic starts on the integrated GPU, But since the Nvidia card is active through the fake monitor, it will force itself to render Sonic thanks to the changes in the Nvidia control panel.

I really hopes this works for you, but leave a message if it doesn't, and I'll try to help you.

Last edited by BrainOfSweden: 11-05-2011 at 04:40 PM.
BrainOfSweden is offline   Reply With Quote
Old 11-05-2011, 11:08 AM   #45
xX760Xx
 
Join Date: Nov 2011
Reputation: 0
Posts: 16
Quote:
Originally Posted by BrainOfSweden View Post
Found a working fix
First of all, I want to thank everyone that gave me ideas, this is kind of a mashup of all fixes I've found that only worked partly. Unfortunately I don't remember where I read everything, so, thanks to everyone who tried to get the game running.
Second, this fix requires no extra screens or cables.

I cant guarantee it will work on every laptop, but if you have an Nvidia Optimus card, try it. Here's how to:

Begin with opening Nvidia control panel. In the "Manage 3D settings" tab, go to program settings and click add.
Navigate to your Steam installation path, and go to \steamapps\common\Sonic Generations\ and choose the sonicgenerations.exe file. Force it to use your Nvidia card. I don't know if it's necessary, but I also did this with the config exe.
After you have applied the settings, go to your desktop.

Right click and select screen resolution. In this window you should click detect. If you can see two displays that are grayed out and named after your video cards, you're probably good to go.
Choose your Nvidia card and select "Attempt to connect anyway on (VGA in my case)". Don't remember which drop down menu it is, just fool around a little. When you found it, click apply.
Then, choose extended desktop and apply again. This will force-activate your discrete GPU.
Now the fun starts.

Open the Sonic Config tool and see if your Nvidia card is present (it really should be), and of course, choose it.
Now start Sonic, and it will propably work.

What's technically happening is that Sonic starts on the discrete GPU, wich is on the faked monitor. But since we forced Nvidia in their control panel, it will switch upon starting on the built in screen that Sonic only recognizes as the integrated GPU.

I really hopes this works for you, but leave a message if it doesn't, and I'll try to help you.
This did infact make my NVIDIA show up on the configure tool. But I still get a critical error. I'm gonna try reinstalling the game.

Thanks dude
xX760Xx is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > Q - S > Sonic the Hedgehog series > Sonic Generations


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 09:46 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.