Go Back   Steam Users' Forums > Steam Game Discussions > Q - S > Sonic the Hedgehog series > Sonic Generations

Reply
 
Thread Tools Display Modes
Old 11-03-2011, 05:43 PM   #1
SnakemanEXE
 
Join Date: Feb 2008
Reputation: 2
Posts: 73
Can't launch Sonic Generations Configuration tool

It's always stuck at "performing first time setup". The little prompt pops up for ten seconds, showing me that it's performing first time setup. Then, it closes, and the game doesn't even launch.
SnakemanEXE is offline  
Reply With Quote
Old 11-03-2011, 05:57 PM   #2
Kintobor
 
Guest
Posts: n/a
I'm getting the exact same thing as you, dude.
  Reply With Quote
Old 11-03-2011, 06:00 PM   #3
SnakemanEXE
 
Join Date: Feb 2008
Reputation: 2
Posts: 73
Not even re-installing works, apparently.
SnakemanEXE is offline   Reply With Quote
Old 11-03-2011, 06:01 PM   #4
DV8ing1
 
Join Date: Aug 2010
Reputation: 55
Posts: 357
Try running the game not the config first. The config came up anyways for me the first time.
DV8ing1 is offline   Reply With Quote
Old 11-03-2011, 06:03 PM   #5
SnakemanEXE
 
Join Date: Feb 2008
Reputation: 2
Posts: 73
I tried that, and it told me to run the configuration tool first.
SnakemanEXE is offline   Reply With Quote
Old 11-03-2011, 06:03 PM   #6
Sonikku2008
 
Guest
Posts: n/a
I have something similar, yet slightly different.

When I try to run the config tool, UAC pops up with Valve asking for permission to run something. I say no, the game crashes. I say yes, the game crashes TWICE.

When I try to run the game itself, UAC pops up again. I say no, the game crashes. I say yes, the game crashes AND tells me to run the config tool first.

The crash I get is one of those Windows messages saying the program stopped working.
  Reply With Quote
Old 11-03-2011, 06:05 PM   #7
Kintobor
 
Guest
Posts: n/a
Quote:
Originally Posted by DV8ing1 View Post
Try running the game not the config first. The config came up anyways for me the first time.
I just did that and all it says is "No valid Graphics Configuration File found. Please run the Configuration Tool and Save."

  Reply With Quote
Old 11-03-2011, 06:06 PM   #8
Year_of_the_Fox
 
Join Date: Nov 2011
Reputation: 0
Posts: 17
Play Sonic Generations:

Allow steam to blah?

Yes.

Installing: Sonic Generations Configuration (Step 1 of 1)

Blah blah please run config tool first.



Configure?

Yes

Install?

Yes

Installing: Sonic Generations Configuration (Step 1 of 1)

Then nothing.
Year_of_the_Fox is offline   Reply With Quote
Old 11-03-2011, 06:06 PM   #9
AlexanderP
 
Guest
Posts: n/a
It seems like a .Net problem. I'm currently trying to reinstall all the .Net versions i have installed (that's up from 2.0 to 3.5). Hope it will help.
  Reply With Quote
Old 11-03-2011, 06:06 PM   #10
DV8ing1
 
Join Date: Aug 2010
Reputation: 55
Posts: 357
I have it running so its not impossible. What OS are you using snake? If in win 7 try making sure you have steam set NOT to open as admin (restart steam if you needed to change) and use the steam library to verify then relaunch.
DV8ing1 is offline   Reply With Quote
Old 11-03-2011, 06:09 PM   #11
boker1
 
Guest
Posts: n/a
I run sonic generations

it asks me to start steam client service

Then it says preforming first time setup part 1 of 1 and then 2 seconds later i get a sonic generations has stopped working message.

i click cancel and it says no valid graphics configuration file found please run the configuration tool and save

I open program files/steam/steamapps/common/sonic generations/configuration tool

another windows error

click cancel and nothing

Last edited by boker1: 11-03-2011 at 06:18 PM. Reason: Rewrite
  Reply With Quote
Old 11-03-2011, 06:14 PM   #12
DV8ing1
 
Join Date: Aug 2010
Reputation: 55
Posts: 357
Some general advice.

Close steam, and delete all the files in the steam folder aside from the steamapps folder and steam.exe. Rerun the exe to reinstall steam and then verify the gamecache for sonic. Running the game directly opened the config for me. Also the config tool did take a little while to load which I found slightly unusual.
DV8ing1 is offline   Reply With Quote
Old 11-03-2011, 06:19 PM   #13
Ro9ge
 
Join Date: Nov 2011
Reputation: 0
Posts: 16
Quote:
Originally Posted by DV8ing1 View Post
Some general advice.

Close steam, and delete all the files in the steam folder aside from the steamapps folder and steam.exe. Rerun the exe to reinstall steam and then verify the gamecache for sonic. Running the game directly opened the config for me. Also the config tool did take a little while to load which I found slightly unusual.
I don't think this is steam's fault. I've been able to directly access the game's configuration file, and even then it won't work. It seems to be an issue with the configurationtool directly.
Ro9ge is offline   Reply With Quote
Old 11-03-2011, 06:22 PM   #14
Sonikku2008
 
Guest
Posts: n/a
Yeah, I tried running their configuration manager directly, and it crashed just like before.

But it only crashed once and didn't pull up a UAC menu.
  Reply With Quote
Old 11-03-2011, 06:22 PM   #15
AlexanderP
 
Guest
Posts: n/a
I've just found out what unplugging my gamepad fixes the problem.
  Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > Q - S > Sonic the Hedgehog series > Sonic Generations


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 08:06 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2012, All Rights Reserved.